Skip navigation

Windows 8.1 install fails on new 2013 Retina MacBook

167844 Views 586 Replies Latest reply: 2014/04/18 4:22 by turbostar RSS Branched to a new discussion.
  • Nvtsallo Calculating status...

    Ok I have win 8.1 installed and running fine. I just bought a 15" base MBPR haswell. Here is what I did

    1. setup and update mavericks and reboot

    2. open boot camp assistant and only check the lower 2 options

    3. insert a usb flash drive (for boot camp driver install

    4. plug in a usg dvd drive with a retail copy of windows 8 or 8 professional

    5 select how big you want your partition. I recommend at least 80gb but just a suggestion based on needs.

    6 when its done creating the windows boot camp usb eject the usb drive before you allow it to restart to install windows.

    7. when it is at the install screen you will see a message saying that partition 0s4 is unable to install windows. highlight that windows partition and click delete then highlight it and select format.

    8 click next to proceed with install

    9 when in win 8 run the boot camp installer and all windows 8 updates. restart

    10 go to the windows store and select the windows 8.1 update and click install

    11 after a restart you are at 8.1 Done. Enjoy.

    Thats my experience and I did it in just a few hours tonight.

  • Brian Kendig Level 2 Level 2 (170 points)

    Your step 8 is where I get the error and the installation fails. What are you doing different from what I'm doing?

     

    - I am installing Windows 8, not 8.1

    - I left the USB drive connected through the installation

    - I reformatted the Boot Camp partition; I didn't delete it and recreate it

     

    Otherwise, the same. How do other people's attempts compare?

  • Nvtsallo Level 1 Level 1 (10 points)

    I would follow step 7 exactly  delete the partition then select format and proceed. Also I used a dvd external drive not a usb I would try that. If your referring to leaving the boot camp usb I would reboot that before windows starts to install and remove all devices.

     

    I think it's something about deleting and recreating that partition that helps. I am sure better support will come but probably not for awhile.

  • Brian Kendig Level 2 Level 2 (170 points)

    Weird that deleting/recreating a partition would be the key to it. Can anyone else confirm?

  • Jgamse Calculating status...

    It has not yet worked for me.

  • jarvil Level 1 Level 1 (10 points)

    It appears this procedure can get you to Windows 8.1 using in place upgrade. It does not solve a new install of 8.1. We are still waiting on support for Apple from this.

     

    Late 2013 rMBP Build 13A3017 Running OSX 10.9 Maverick

    Windows 8.1 Professional OEM English International, Selecting English (Australia) as only variation from default.

    Using Apple bootcamp installation process.

     

    • Deleting partition and reformatting a new one from Windows install does not solve the problem.
    • Formatting the partition with Disk Utility then installing into that does not solve the problem

     

    It appears the partial solution is a workaround where Windows 8.1 cannot update the boot information prior to first reboot during the installation process. Windows 7 does not appear to suffer from this issue. So installing it then upgrading gets you around the problem.

  • ganomi Level 1 Level 1 (0 points)

    so is this a mbr or efi installation now. because you can start it in parralels i suppose it is mbr? can you check the partitioning system in windows?

  • ganomi Level 1 Level 1 (0 points)

    ok thanks, thats unfortunate for my usecase. still someone mentioned he did an efi install. will have to try it myself when i get my 13"

  • penrobe Calculating status...

    No DVD drive here. Anyone have a variation of this without a DVD drive that works?

  • BarnCleave Level 1 Level 1 (0 points)

    I have the same problem and the solution doesn't work for me

  • penrobe Level 1 Level 1 (0 points)

    Tried something new, but it didn't work. This is what I tried.

     

    1. download trial version of windows 7 premium SP1.

    2. Prepared bootcamp install using USB flash drive

    3. Rebooted and installed windows 7.

    4. Say skip when it asks for a CD key (unless you have one).

    5. Windows 7 premium installs fine and so do bootcamp drivers.

    6.Boot back into OS X and use Bootcamp to make USB flash drive using windows 8 iso.

    7. Boot into windows 7.

    8. Run the setup of windows 8.

    9. At this point I thought it was going to work but then after install it boots into OS X.

    10. Booting back into windows continues install but then it just ends with a black screen.

    11. Rebooting says no OS installed.

    12. Rebooted back into mac os.

     

    Note. If you ever have trouble returning your windows parition back into one partition using bootcamp use disk utility to erase the windows partition and format it MS-DOS (FAT). After doing this bootcamp will be able to repartition your drive to be one drive again or so I found.

     

    Anyway, still can't get windows 8 on this computer. I think I'm going to give up and just use windows 7. All I'm using windows for is to play games anway. Don't really need 8. Just that I bought a copy. Now, I have to buy a copy of windows 7 too.

  • Mr. News Calculating status...

    I just can't wrap my head around how random this issue seems to be. The fact that it didn't work the first time, but it then worked the second time, with presumably the same routine.

     

    I have followed this thread for 24 hours and tried every method to the point to install Windows 8.1, and still i get the either the "unable to prepare for next boot phase" (paraphrasing) with EFI, or i get GPT error in BIOS mode. When i try to convert GPT to MBR with refit, it gives me another error at install: "Can't create or find partition" (paraphrasing again).

     

    Almost everybody reports success in installing Windows 7, but since that uses BIOS mode, i get the same issue as above.

     

    I am at the point where i am considering wiping the entire drive, just to make sure any faulty partition tables/settings are cleared:-(

     

    I am glad it works for some of you, but it hurts my heart knowing that it  should and has worked for you guys.

     

    When the W 8.1 EFI setup fails, it is just prior to the final reboot, suggesting that only boot settings needs to be changed. Is there a way to manually edit the EFI to make the bootcamp partition bootable? Maybe using refit?

     

    Best regards

    Exhausted owner of new 2nd tier late 2013 15".

1 ... 4 5 6 7 8 ... 40 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (17)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.