Skip navigation

FCP 7 on Macbook Air 11" (canvas playback  & sequence/render)

755 Views 10 Replies Latest reply: Apr 6, 2014 2:35 PM by Paul E Jones RSS
elisenew Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 26, 2013 9:56 AM

My high school students are using FCP 7 on Macbook Airs. One problem a few of them are encountering is playback in the Canvas-- the resolution is very low and when I go to their Playback Video Quality setting in the Timeline, the only options are Dynamic or Low. Why are Medium and High greyed out?


Also, sometimes the video 'stutters' in the Canvas. The footage we are currently working with has all been transcoded into ProRes LT.


Also, when I match the settings to the clips formats, the students all still need to render. Yet, on my computer (also a Macbook Air with FCP 7), when I do the same thing (match the settings to the clip), I do not need to render.


All of these problems seem to be related to format/compression....the only one I've experienced on my computer is the stutter. The Playback and Render issues are not happening to me, nor to all of the students.


I've looked through all the possible settings everywhere and I can't see what is different about the macbooks that work vs. the ones that do not.


Any thoughts?



MacBook Air, iOS 7.0.3
  • Meg The Dog Level 6 Level 6 (9,385 points)

    The timeline is set to Unlimited RT and Playback Video Quality to Dynamic?

    Final Cut ProScreenSnapz001.png



  • Meg The Dog Level 6 Level 6 (9,385 points)

    There are two issues here, the suggestion to switch to Dynamic is to address the "stuttering" issue.


    On a problematic machine, click on a source clip in the FCP browser to select it, and once selected, type Command + 9 to see the item properties for the clip. Either report those properties, or post a screen shot of those properties.


    Next, click anywhere on the timeline, and then type Command + 0 {zero} to see the sequence setttings for the timeline. Either report the sequence settings or take a screen shot and post that here.



  • Michael Grenadier Level 6 Level 6 (19,805 points)

    Not sure if this could be the problem, but worth a shot


    where is your media stored?  Storing media on the internal drive is not recommended.  Also, there should be a minimum of 10% free space on all drives and 20% on your internal (start up) drive. 


    If the material is stored on an external drive, you may have a hardware problem with the drive or some sort of corruption on the drive.  First step is to run applications:  Utilities:  Disk Utility and do a "Repair Disk" on the external drive.  I'd also recommend getting and running DiskWarrior on all drives



    Not sure if there are any issues running diskwarrior on the internal drive of a macbookair.  Not even sure how you'd do it. 

  • Paul E Jones Level 1 Level 1 (10 points)

    Are you using current/last gen macbook airs? There seems to be an issue where FCP limits the RT performance based on clock speed. Obviously this is no longer relevant, and you simply need to modify a plist the FCP bundle to get around it. i will post details of how I did it if anyone wants to get into it, just ask, in the meantime, i gleened most of what I know from this thread.



    Like I say, I will post a succinct how to if anyone fancys it. I have done real work using Pro Res 4444 from the internal SSD outputting to a Blackmagic Thunderbolt SDI box with nothing but regular supported FCP problems. :-)

  • Meg The Dog Level 6 Level 6 (9,385 points)

    Well, this is certainly be valuable to know. I use a MacBook Air for location camera/sound file transfer via ShotPut Pro, and have had a copy of FCP-7 on it that I occasionally open just to take a peek at the files. I could not replicate the OP's problem on my mid 2012 5,1 Air.



  • AndrewRJCherry Level 1 Level 1 (0 points)

    Hi Paul,


    Sorry to dig up an old thread, but is there any chance you could post a how to? I've had a look at the MacRumours thread, an I'm unable to get my head around it.


    I'm using the low-end current generation Macbook Air 11".

  • Paul E Jones Level 1 Level 1 (10 points)



    The quick answer, and the one that worked for me is to open


    /Applications/Final\ Cut\ Pro\\ Settings/FXScripts/Enablers/RT\ Software\ Enabler.txt


    and replace every insance of cpuspeed to cpuspeed >= 1200 (by MBA is 1.3 (current gen) so this covers all bases.) You will get a warning on every startup about an unsupported enabler file, but it's worth that to not have to render, and it works like a charm.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.