Skip navigation

IOS 7.0.3 wifi Bluetooth issues

12503 Views 21 Replies Latest reply: Feb 1, 2014 9:06 PM by A Theist RSS Branched to a new discussion.
1 2 Previous Next
Qasid121 Calculating status...
Currently Being Moderated
Oct 26, 2013 12:24 PM

I m using iOS 7.0.3 now on my iphone 4s since last upgrade to iOS 7 my wifi is greyed out it worked first week well one day my phone went off I put it back on no wifi no Bluetooth I m 100% sure it's something to do with new softwear iOS 7 please apple fix this problem ASAP

iPhone 4S, iOS 7.0.3
  • ChrisJ4203 Level 7 Level 7 (26,520 points)
    Currently Being Moderated
    Oct 26, 2013 12:26 PM (in response to Qasid121)

    You are not addressing Apple here, so telling them to fix it ASAP isn't necessary. This is a user to user technical support forum.


    For the wifi and Bluetooth grayed out issue, see this support document

  • Eric Ross Level 6 Level 6 (11,650 points)
    Currently Being Moderated
    Oct 26, 2013 12:38 PM (in response to Qasid121)

    If your Wi-Fi and bluetooth is not working then, it is most likely a hardware issue.  You should take your iPhone to Apple for an evaluation. 

  • ChrisJ4203 Level 7 Level 7 (26,520 points)
    Currently Being Moderated
    Oct 26, 2013 1:57 PM (in response to Qasid121)

    If the device is under warranty and there is a defect, Apple will replace it for free. However, if the device is out of warranty, for an iPhone 4S, the cost in the US is $149. You can use this to see what the cost would be in your area by just changing the location. ne

  • abouris Calculating status...
    Currently Being Moderated
    Oct 31, 2013 12:06 AM (in response to Qasid121)

    I guess this is not hardware because I have the same problem. Since this morning WiFi  grayed out. It was working perfectly until last night. I hard reboot it, put it in airplane mode and turned the Do not disturb mode on, let it rest for 15 mins, I totaly erased it and performed a software restore... in a few words I followed every provided on the internet "recipe". WiFi refuses to work. 

  • sanjaytheonlyone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2013 11:58 AM (in response to Qasid121)

    I am having iphone 4s. I have upgraded it IOS 7.0.3 after that I started facing issue with wifi access. My phone always drop connection to the wifi. While trying to connect, always I got error message as "Unable to connect to wifi". Is there any way I can go back to ios 7.0.2 or any fix to this issue? If I keep on trying, after 20-25 attempts, it will get connected to wifi but again will drop it and same issue reoccurs.


    Help is highly appreciated as I used to work from phone and it's stopped as it is not getting connected to wifi.

  • Arielsam Calculating status...
    Currently Being Moderated
    Nov 5, 2013 7:18 AM (in response to Qasid121)

    Hi Guys - It happened the same to me. After a couple of days after upgrading to 7.0.3 my iPhone 4S grayed the WiFi switch.


    Somehow, after trying several things, now the Switch is not grayed anymore, but it does not detect any WiFi signal. And when it detects a signal, it does not connect.


    Obviously is not a HW problem. Does anybody know if Apple is going to take action over this BIG issue?




  • ShyViolet Calculating status...
    Currently Being Moderated
    Nov 5, 2013 5:43 PM (in response to Qasid121)

    I upgraded to an iPhone 5S and have had issues with my hands free bluetooth. I even have a new car audio system so my old iPhone 4 settings  have never been in the new unit.  I cannot get the hands free to work on a consistent basis.  They pair but most of the time I cannot use my voice activated feature in my car.  The same thing happened in my old car audio system once I upgraded to the 5S.  I know it is in the 5S.  I am going to call Apple support.  Anyone else having the same problem?

  • unixtcp Calculating status...
    Currently Being Moderated
    Nov 8, 2013 6:44 AM (in response to Qasid121)

    my iphone is 4s with IOS 7.0.3 and is the same isue, bluetooth is not working.

  • Jaymaniac Calculating status...
    Currently Being Moderated
    Nov 9, 2013 11:23 AM (in response to Qasid121)

    Same here, iPhone is 4s. After iOS 7.0.3 update, Bluetooth is not working, especially for my car (which always worked flawlessly prior to this update, same car), or for certain apps which use Bluetooth (Knock, for example).

  • pocolocos Calculating status...
    Currently Being Moderated
    Nov 14, 2013 12:35 AM (in response to ChrisJ4203)

    didn't help

  • ShyViolet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 16, 2013 9:17 AM (in response to unixtcp)

    The way to handle this is when you get into the car you go to settings on the iPhone then tap on Bluetooth.  Then the hands free voice activation will work. But you have to do it every time.  But it is a workaround.  I have contacted Apple and explained to the that when the iPhone 5s was first paired with the car I saw where the Hans free said no.  And there was no way to change that.  Apple needs to fix that but then we would have to reinitialize the car radio and start from scratch.

  • claytonetheriff Calculating status...
    Currently Being Moderated
    Dec 16, 2013 11:01 PM (in response to Qasid121)

    Looks like my Wifi and Bluetooth are out after I updated to 7.03 about a month or two ago. Of course I didn't figure it out until I noticed my phone bills have been increased because of my data usage... Has anyone figured this problem out yet?

  • GeorgeIsaac Calculating status...
    Currently Being Moderated
    Dec 26, 2013 7:16 PM (in response to Qasid121)

    I am having this issue as well. But here's a twist :


    I encountered this issue (Bluetooth perpectually in seeking mode, wifi cannot be activated) after upgrading the Iphone 5 to IOS 7.0.3. (The update happened in Singapore).


    Then, I flew to Hongkong for my holiday.


    I was surprised to find that there were pockets of time when I could receive wifi (plus bluetooth was in non seeking mode - albeit in the settings app, things were moving slower than usual).


    This happened in Airplane mode (I didn't want to incur any data roaming costs overseas, as an added measure; even though I had data roaming turned off as well).


    In those pockets of times, everything worked perfectly well again.


    Then, for some inexplicable reason, the phone lost its head again, and went into bluetooth searching-wifi unactivatable mode.


    For what it's worth, perhaps this phenomenon I surfaced here, could help the Apple guys troubleshoot better.


    PS : I am FULLY CONVINCED this phenomenon was caused by the IOS update, and that the software is the culprit.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.