Skip navigation

Mavericks upgrade wifi problem exclamation mark

54850 Views 143 Replies Latest reply: Mar 13, 2014 1:50 PM by luisalva777 RSS Branched to a new discussion.
  • Rob Reid Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2013 1:46 PM (in response to macmark2)

    That worked for me too. MBP 8,3

  • Pugmomsf Calculating status...
    Currently Being Moderated
    Oct 26, 2013 10:31 PM (in response to skahloun)

    I have 13" MacBook retina.  Booting up into safe boot mode and then restarting into regular mode works for me.  BUT, I have to do this every time I connect to a new wireless network.  This is independent of what kind of wireless access point I'm connecting to.  This is such a royal pain.  My wireless was completely fine before I upgraded to Mavericks. 

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Oct 26, 2013 10:54 PM (in response to Roger Green)

    Roger,

    Forgot to add, after you run the tcpdump command, you need to renew your DHCP lease from System prefs->Network->TCP/IP.

     

    Leave the ethernet cable unplugged allthrough. When you renew the dhcp lease, you will see the packet count in tcpdump go up a bit. Then hit Ctrl+C there and upload the .pcap file someplace and I can look at it.

  • AndyS1967 Calculating status...
    Currently Being Moderated
    Oct 27, 2013 3:32 AM (in response to skahloun)

    Hi everyone...

     

    I had exactly the same issue.  I've got a dual band router (ASUS RT66).  I had 2.4ghz reserved for legacy stuff around my house and ipad/iphones etc.  The 5ghz band was reserved for 2013 MacBook Pro with Retina.

     

    After upgrading to Maverick i've noticed the 5ghz band was very unstable.  I had to link to the slower 2.4ghz band for stability.   Reading the boards i got a little despondant that others were having this issue.  I tried the usual fixed but nothing worked.

     

    Then....

     

    I decided to try manually configured IP.  I switched off DHCP on the wifi adaptor, allocated a fixed IP to my wifi MAC address and connected. So far so good.  I've had a stable connection for a couple of hours.

     

    I don't know if the issue is related to DHCP or to WPA (you don't need WPA if you hard code your IP in your router), but it does seem to be working.

     

    Give it a try.  You've got nothing to loose.

     

    Andy

  • MoeBeans Calculating status...
    Currently Being Moderated
    Oct 27, 2013 1:34 PM (in response to skahloun)

    I have a Macbook Pro late 2011 and my ethernet connection worked fine.  it was NOT using dhcp but had a static IP.  I have an Apple Airport Timecapsule wireless.

     

    When I tried turning on my WI FI I got the exclaimination point and would not connect. Wireless was set to use DHCP.

     

    I switched my static IP on the ethernet card to DHCP to see if DHCP was working at all and it got an IP address.  When I did that I looked up and saw my WI Fi was now working.  I switched back to static on my ethernet card and the WI FI has worked ever since.

     

    I can still not get DHCP working on my WMWare Fusion but static IP works fine. 

     

    My 2012 Macbook Air upgraded flawlessly. 

  • Changedman77 Calculating status...
    Currently Being Moderated
    Oct 27, 2013 6:32 PM (in response to skahloun)

    I had the same problem after I down loaded OS X mAv. This is what worked for me,  I went to system preferences, network, at the bottom of that window is the button for assist me. Since I already have my network set up I went with the option to run a diagnostic, from there you are guided through locating your network name and wi-fi (wireless connection). Once I got to the part where I wanted a wi-fi connection the diagnostic made the changes for me and gave me the correct IP address I needed to connect to the internet. Done deal!

  • Roger Green Level 1 Level 1 (90 points)
    Currently Being Moderated
    Oct 28, 2013 3:51 PM (in response to wifiguru)

    wifiguru

     

    Sorry, haven't been able to get onto the iMac for a day or two - it's the family machine. Anyway, this evening they are all out so I've had the opportunity to spend some time on it. I thought I would have one last go at the simple thing - removing the wifi network in the Network pane, and then setting up access to it again from first principles, and believe it or not, I am now connected to the internet by both wifi and ethernet. I'll monitor it and see if it reverts to the question mark again, but I've done one restart and it seems to have stuck.

     

    One thing that I did notice is that I signed up to iCloud Keychain a couple of days ago, and now I have a huge list of wifi networks listed in the advanced/wifi pane of the Network preference, from all the networks that I have ever connected to with iPhone, iPad or MacBook Pro. If I try to delete them, a message comes up to say that they will be deleted from my other devices as well, so I've left them there. Did Apple intend to have desktop computers with all these wifi networks linked to them?

     

    Thanks for your help over the past few days

  • Lily_Evans Calculating status...
    Currently Being Moderated
    Oct 30, 2013 10:09 PM (in response to macmark2)

    thank you macmark2!!!!!

    finally my macbook sees the wifi again

    in so many posts the fixes are beyond my understanding and assume a knowledge base

    your simple step by step instructions were super easy to follow and worked like a charm

    so appreciate that you took the time to post for everyone's benefit

  • macmark2 Level 1 Level 1 (130 points)
    Currently Being Moderated
    Oct 31, 2013 5:29 AM (in response to Lily_Evans)

    You're welcome.  I'm glad it worked for you as well!

  • rensuchan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 10:34 AM (in response to AndyS1967)

    Intersting find AndyS1967.  I have the same router model as you and it seems my new Retina MBP 15" is having the same issue (no problems on 2.4GHz band but couldn't even get it to connect to the 5GHz one unless I was sitting right next to it).

     

    Interestingly enough, my Mid 2011 MBA upgraded to Mavericks has absolutely no problems connecting to the 5GHz network with DHCP enabled but your solution to manually set the IP seems to be the only permanent solution for me thus far on the MBP.  I tried macmark2's safe mode solution that was posted earlier successfully but it reverted to it's original (bad) behavior after a reboot and since I switch between Windows and OS X on the MBP I don't want to have to repeat that every single time I switch operating systems.

     

    It's a confusing problem. It's hard to narrow it down to DHCP or WPA because my 2.4GHz WPA network is just fine with DHCP :/

     

    If you find any more on this I'd be interested in hearing it.

  • rensuchan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 11:08 AM (in response to rensuchan)

    Scratch the permanent solution part... now setting the IP manually wont even work and I can't seem to get on the 5GHz broadcasts at all.  Not even an exclaimation point... it just says can't connect.

     

    Guess I'm stuck on 2.4GHz for now.  At least that much works but I'd really prefer to be able to use my 5GHz since there are only a few devices on it.

  • racingsnake Calculating status...
    Currently Being Moderated
    Oct 31, 2013 11:23 AM (in response to skahloun)

    hey guys!hope all is well.

    well my applejack solution failed through.my wifi worked for like a day then started dropping again.

    what fixed it for me was go to the app store and in the purchase section under mavericks was an option to download full installer.so i did and ran it instead of upgrading through app store itself.everything works as it should after that.

    hope that helps.

  • Roger Green Level 1 Level 1 (90 points)
    Currently Being Moderated
    Oct 31, 2013 2:47 PM (in response to Roger Green)

    An update on my progress.

     

    I think that a big part of my problem was that I was using WEP to sign in to the network on one of my computers, and WPA Personal on the other. This didn't matter when I hadn't turned on all the iCloud and Keychain options, but now that I have, it seems that all the networks I have ever joined on my laptop are now showing up in the Network pane of the iMac, including the MBP's version of the home network. I think that signing into the wifi using say WEP on one computer somehow screwed up the wifi network on the other one. Does this sound plausible? Anyway, I deleted both the home wifi networks from both the computers, them set them up again making sure that I used WPA Personal on both, and for the moment, everything is as it should be. No more exclamation mark!

     

    I hope that this might help others.

  • Jeremy Photographer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 4:45 PM (in response to Roger Green)

    I went and bought another airport extreme to boost the signal strength to my office and now I have a more stable connection but it is still terribly and painfully slow.

     

    I worked in my office ( WEP personal) for a long time with no internet issues and better speeds (even downloaded mavericks quickly) but once in Mavericks the connection to wifi died. My theory is that the new operating system somehow weakens the wifi strength which is why many are not connecting or constantly dropping out. I tried about everything mentioned on numberous threads over the last week and nothing helped unfortunately. I tried everything. Simply boosting the signal to a ridiculously strong level has helped a little. BUT still not really able to stream a video as it's about 80kbps as opposed to the 700kbps I was getting.

  • Rob10041 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2013 4:50 PM (in response to skahloun)

    A straight forward question: Is there any way to just shut airport (and all WiFi Rf) off?

1 ... 3 4 5 6 7 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.