7 Replies Latest reply: Dec 4, 2013 2:59 PM by mojdeh banafsheh
Eric Sheppard Level 1 Level 1 (0 points)

I've been trying for the past few days to sign in to the Mac App Store. I get as far as entering my Apple ID, password and hit Enter but the activity clock just keeps spinning and spinning. I have a second Apple ID and tried that - it works no problem. The first ID I'm having the trouble with works fine elsewhere, on iTunes and here on the discussion communities. I've looked through a lot of the suggestions, have logged out, changed the password, deleted more plists than I care to remember, still no joy. Any geniuses out there able to help me on this really odd one? I'm running 10.8.5 on a MacBook Pro.


MacBook Pro, OS X Mountain Lion (10.8.5)
  • 1. Re: I cannot sign in to the Mac App Store
    Jerome Colas Level 2 Level 2 (215 points)

    I have the same issue with one of my Apple IDs.

    I use 2, an Alerican one and a French one.

    Everything works fine wirth the newer French one.

     

    But I have had issues with the American one for several weeks.

    One is that I get an error message signinf into iTunes that the iTunes store is unavilable. Deleting cookies and certain files is a temporrary fix.

     

    And for the last few days (I was already using Mavericks) I have the same issur as you signing to the Mac App Store with my American Apple ID. (load for ages).

     

    I have spent several hours with iTunes and Applecare teams over the last month and a half. They provided a temporary fix for iTunes but nomore.

    The issues are the same on 3 different Macs, as well as Windows 7 inside VMWare (except of course that there is no Mac App Store on Windows)

     

     

    Anyway, I have a temporary fix for accessing the Mac App Store :

    - Create a new user in System Preferences/Users and Groups. A standard user is sufficient.

    - Login to your Mac as that new user.

    - Sign on to the Mac App Store.

    - Buy / update your apps.

    - Log out and delete the "new" user in System Preferences/Users and Groups

     

    I could see that if I sign on iTunes with my French Apple ID (as the new Mac user), I then have the same problems when trying to sign on with the American ID.

     

    Hope this helps,

    Jérôme.

  • 2. Re: I cannot sign in to the Mac App Store
    9edge Level 1 Level 1 (0 points)

    Just a "me too" here - since I upgraded to Mavericks, I can not get into the App Store at all, just spins after I enter my credentials...

     

    Same Apple ID works fine (so far anyway!) in iTunes, and here, and in my Apple Developer accounts and etc...

     

    Quite anoying, as there are a bunch of updates I want and some stuff I need to install form the store...

  • 3. Re: I cannot sign in to the Mac App Store
    Eric Sheppard Level 1 Level 1 (0 points)

    Thanks everyone. It eventually started working again. How? Not sure, deleted the plists suggested in a number of other posts, changed my password, restarted 5 or 6 times along the way then it just started working.

  • 4. Re: I cannot sign in to the Mac App Store
    9edge Level 1 Level 1 (0 points)

    Hmm, still not working for me: At least, not from my regular user login - I tried Jerome's suggestions of creating a new user, and that worked fine...

     

    So, what I have is:

     

    - Everything worked fine prior to the Mavericks upgrade (indeed I used the Ap Store to do the upgrade!)

     

    - After the upgrade, iTunes and etc., that use the same Apple ID, all seem to still work.

     

    - But I can not log into the App Store... From any of the pre-exisitng accounts on this machine.

     

    - A freshly created account, however, can log in to the App Store.

     

    I tried the various suggestions for deleting plists and etc., but so far they have not worked for me. I also tried various varioations on safe mode too, to no avail.

     

    The only thing that seems to have worked (so far anyway) is to create a fresh account for access to the App Store.

     

    This is not great, but it is working for now, until a better fix comes along!

  • 5. Re: I cannot sign in to the Mac App Store
    Reaperducer Level 1 Level 1 (0 points)

    Same problem here -- Since upgrading to Mavericks, only the Mac App Store account that installed Mavericks will login.  All other Apple IDs just give the spinning sticks icon.

  • 6. Re: I cannot sign in to the Mac App Store
    9edge Level 1 Level 1 (0 points)

    Well, inspired by this post, I just tested it again - having only tried to access from the "known good" account.

     

    And... it now appears to be working again, on my "regualr" account.

     

    So, broken for days, nothing I did made any difference.

    Ignore it for a few days. Fixed!

     

    Time, it seems, is a great healer.

     

    Wish I knew what actually changed though!

  • 7. Re: I cannot sign in to the Mac App Store
    mojdeh banafsheh Level 1 Level 1 (0 points)

    I did All every body told, but nothing could be usful! It seems that from Mac to Mac even with the same OX  S it's different.

    Anyway What helped me at last was this:

     

    http://support.apple.com/kb/HT5621?viewlocale=en_US

     

    Follow the step of changing ID insteas of changing password or creat a new one.

    That helped me and now it's working.

     

    Good chance