Skip navigation

My Command Key isn't working.

4507 Views 6 Replies Latest reply: Apr 7, 2014 9:27 AM by Alex Chaffee RSS
TPFleck Calculating status...
Currently Being Moderated
May 26, 2013 6:36 PM

What am I running?


Well based on the forum I'm posting in, I'm running the follow:


Mac OS X v10.6.8 Snow Leapord

2 GHz Intel Core i7

8 GB 1333 MHz DDR3


Boot Camp w/ Windows 7 Ultimate

It should be noted though that I am using OS X when I wrote this message and I'm talking about my CMD key not working in OS X.



What is Happening?

Oddly enough, it seems my cmd key and option key are remapped permanently?


Steps I've taken:


  • System Pref > Keyboard > Modifier Keys > Default (I also made sure the cmd key was set to command and option as option)


  • System Pref > Keyboard > Change Keyboard Type... (still no luck)


  • Reset PRAM


  • Safe Mode Boot (my cmd keys worked properly in Safe Mode, but when I restart into normal it doesn't work)


  • Created a new user (no luck still)


  • Went through the Apple Support forums and deleted some .plist files that people said helped and fixed their problem.




I feel like I'm one step short to throwing this thing through a window. Seeing as I'm a web developer, I feel that my cmd key is almost essential as it is my quickest way to copy and paste current and previous lines, save, and anything else you might think of. Oh did I mention cmd + f to search files? Oh yeah, big help for us developers.


Anything else anyone can think of? Please I'm all ears, I feel I am technically SAVY with my MBP, but obviously I'm not.

MacBook Pro, Mac OS X (10.6.8)
  • christopher rigby1 Level 4 Level 4 (2,070 points)
    Currently Being Moderated
    May 27, 2013 4:10 AM (in response to TPFleck)

    Purely a guess, but as you're also running Windows via BootCamp, is this article any help?


  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    May 27, 2013 4:46 AM (in response to TPFleck)

    Perplexing problem, it seems to be a OS X software issue as it's occurs in another user but not in Safe Mode or at boot time (like Command V or S) on a wired/built in keyboard.


    Was some sort of third party keyboard software installed? Have you tried a wired keyboard or another one?


    It sounds like OS X has gotten the keyboard map wrong somehow, like that check that occurs when one connects a new keyboard?



    The #12/#13 OnyX cache cleaning and corrupt preference file check might cure/find the problem


    ..Step by Step to fix your Mac



    Perhaps the #8 Reinstall Just OS X over itself to give you a new fresh copy



    I've arranged the Steps in order as to be systemmatic until you find something that works

  • LittleDuckAlex Calculating status...
    Currently Being Moderated
    Jul 2, 2013 2:54 PM (in response to TPFleck)

    I was having the same problem with my G11. Spent ages looking around for a fix, couldn't find anything. I have now fixed it and feel a bit dumb. The gaming switch was enabled on my keyboard which disables those keys. Not sure if this is your problem too but I thought I might mention it seeing as your keyboard also features the gaming switch.

  • chrisjbrough Calculating status...
    Currently Being Moderated
    Oct 27, 2013 5:32 AM (in response to LittleDuckAlex)

    This was exactly my problem.  Switched gaming mode off and fixed it!  I'm on the Logitech G15 keyboard.  Thank you for your help!!!!

  • Alex Chaffee Calculating status...
    Currently Being Moderated
    Apr 7, 2014 9:27 AM (in response to LittleDuckAlex)

    That was it! The little joystick icon at the top is next to the "gaming mode" switch on my Logitech G110 keyboard. Thanks.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.