Skip navigation

Non-responsive keyboard/trackpad in W7 install via Boot Camp

573 Views 1 Reply Latest reply: Oct 27, 2013 7:15 AM by sveur RSS
sveur Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 27, 2013 4:13 AM

I have a brand new MacBook Air, upgraded to Maverics, and trying to install Windows 7 64 bit.

 

I have made a usb stick via an iso image from DigitalRiver, through Boot Camp, and started the installation via bootcamp. I also installed the rEFIt drivers, so i got the nice boot menu.

 

When I boot into the installation, i cant do anything. My trackpad and keyboard is non-responsive (I can't even get the caps lock to light up).

 

I've tried to:

*boot into W7 safe mode, pressing F8 while booting, but it doesn't help.

*"run unsigned drivers", from the same menu

*Removing setup.exe from the Bootcamp folder on the disk. Also with no avail.

 

I have seen that people have been struggling with keyboard and trackpads in W7 over Boot camp, but I cant even install it...

 

Please help

 

Edit:

Only key responding is the shutdown key.

I don't have any external mice or keyboards.

MacBook Air, OS X Mavericks (10.9), Boot camp, trying to install W7

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.