Skip navigation

File folders changing to inaccessible UNIX documents

785 Views 7 Replies Latest reply: Oct 27, 2013 11:42 AM by Yeehat RSS
A. Steinberg Level 1 Level 1 (65 points)
Currently Being Moderated
Oct 15, 2013 12:39 PM

I'm on a MacBook running 10.6.8. I often run files back and forth to my workplace on a Lexar 16 GB stick...now just a few months old (since my last one seemed ot be overheating -- a Kingston prone to this, as it happens).

 

The other day I noticed a folder (full of files) on my stick seemed to have changed (on a PC) to an 8kb "file" of no type. I was not able to open it.

 

I figured I would fix it at home, but at home it appears as a UNIX file...and today I am seeing more and more folders changing in this way! I have notivced four more just in the past few minutes, some at the root level, other buried.

 

I ran Disk First Aid and the PC's own scanner equivalent on the stick, but no serious problems were found; DFA did make a few fixes. But the problem continues.

 

Should I buy a file retrieval program? Is this stick HOSED? That would be a big shame.

 

Is this a known issue in Snow Leopard? I have had documents change to UNIX before, but I was able to change them back by adding the proper suffix. But with folders I am stumped -- and this is much more severe as many files are now inaccessible.

 

-A-

MacBook, Mac OS X (10.6.7)
  • Eric Root Level 6 Level 6 (13,820 points)

    How is the USB stick formatted?

  • Eric Root Level 6 Level 6 (13,820 points)

    Finder sometimes has problems with files on a disc formatted for Windows unless the format is FAT or Ex-Fat.

     

    Applications/Utilities/Disk Utility - select the USB drive, and look at the bottom left for format.

  • Eric Root Level 6 Level 6 (13,820 points)

    If neither computer can open them then I think the USB stick is corrupted. Hopefully someone smarter than I will see this and can offer a cure.

  • Yeehat Level 1 Level 1 (40 points)

    I fear this is not a known issue with SL but a cross-platform issue with Windows. If you perform a Google search for "folders turning to unix executables" you'll find you're sadly not alone. Most users report this problem in connection with Windows; see, e.g. https://discussions.apple.com/thread/5413592?start=0.

    As far as I could find, there's no solution for folders (and neither a satisfactory explanation). I only found this:

     

    http://www.mac-forums.com/forums/os-x-operating-system/289108-folders-turned-int o-unix-executable-files-2.html#post1471648

     

    I don't think a data recovery software will help. Afaik, only FileSalvage offers support for FAT32 volumes (Data Rescue's user guide states "limited support"). But you can download a trial version of both applications, do a scan and check whether one finds files to be recovered on the USB stick and/or your inner disk. I'd try with FileSalvage first.

     

    Another suggestion you'll find around is repairing your inner disk (you can't repair a FAT32 volume on a Mac, afaik). This won't do any harm (and probably no good either), but I'd prefer the single user mode. Follow the detailed instructions from http://support.apple.com/kb/TS1417:

     

     

    To use fsck:

    1. Start up your computer in single-user mode to reach the command line.
      Note: If necessary, perform a forced restart as described in the Emergency Troubleshooting Handbook that came with your computer. On desktop computers, you can do this by pressing the reset/interrupt button (if there is one) or holding down the power button for several seconds. On portable computers, simultaneously press the Command-Control-power keys. If your portable computer doesn't restart with this method, you may need to reset the Power Manager.
    2. At the command-line prompt type:

      /sbin/fsck -fy

    3. Press Return. fsck will go through five "phases" and then return information about your disk's use and fragmentation. Once it finishes, it'll display this message if no issue is found:
      ** The volume (name_of_volume) appears to be OK
      If fsck found issues and has altered, repaired, or fixed anything, it will display this message:
      ***** FILE SYSTEM WAS MODIFIED *****
      Important: If this message appears, repeat the fsck command you typed in step 2 until fsck tells you that your volume appears to be OK (first-pass repairs may uncover additional issues, so this is a normal thing to do).
    4. When fsck reports that your volume is OK, type reboot at the prompt and then press Return.

    Your computer should start up normally and allow you to log in.

     

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.