Skip navigation

Cannot View or automatically download PDFs in Safari 7.0

6690 Views 44 Replies Latest reply: Mar 27, 2014 7:14 PM by akhannides RSS
  • stephan.zehrer Level 1 Level 1 (0 points)

    Hi

     

    I had the same problem, I "solved" it by removing and (re)installing of Adobe Reader.

     

    So now the reader plugin shows up in Safari.

     

    CU

     

    Stephan

  • Figgy Calculating status...

    I've been having the same problem as you since acquiring Safari 7.0 when I downloaded Mavericks. I have been following the replies and suggestions to your post ever since. I have implemented all the suggestions you received without success. In addition, I have tied a few "solutions" of my own, also without success.

     

    A few minutes ago, I noticed something unusual. In Safari Preferences>Advanced there is an option to "Stop plug-ins to save power". To find out more, I clicked on the "?" at bottom right. This brings up the Safari Help page which says"----

    Stop plug-ins to save power

    Freezes plug-ins after a brief time. You can click frozen plug-in content to start the plug-in for a website. The plug-in stays enabled for that website, though other instances of the same plug-in on the current webpage remain temporarily frozen until the page is loaded again. Safari automatically disables plug-ins for a website you don’t visit for a few weeks.

    To see a list of websites that currently start plug-ins automatically, click Details. Then remove websites from the list to save power.

    But the thing is there is NO button/link called "Details" on that page in Preferences, to click. I assume this option is mostly relevant for Laptops running on batteries rather than Desktops running on mains power - none the less, the option IS there in Safari 7.0 whether your using a Laptop or Desktop.

    Is this somehow contributing to the problem ?

  • Linc Davis Level 10 Level 10 (107,825 points)

    Read this whole message before doing anything.

     

    Back up all data.

     

    Quit Safari if it’s running. Then select

     

    Force Quit…

      

    from the menu bar. A small window will open with a list of running applications. Safari may appear in that list, even though you quit it. If so, select it and press return. Close the window.

     

    Step 1

     

    In the Finder, press the key combination shift-command-A to open the Applications folder. Select the Safari icon in that folder and press the key combination command-I to open the Info window. There’s a checkbox in the Info window labeled Open in 32-bit mode. Uncheck it, if checked. Close the Info window and the Applications folder.

     

    If Adobe Flash Player is installed, select

      

     ▹ System Preferences ▹ Flash Player Advanced

      

    and click Delete All. Close the preference pane.

     

    Hold down the option key and select

      

    Go Library

      

    from the Finder menu bar. Delete the following items from the Library folder (some may not exist):

     

    • Caches/com.apple.Safari
    • Caches/com.apple.WebKit.PluginProcess
    • Caches/com.apple.WebProcess
    • Caches/Metadata/Safari
    • Preferences/com.apple.WebKit.PluginHost.plist
    • Preferences/com.apple.WebKit.PluginProcess.plist
    • Saved Application State/com.apple.Safari.savedState

     

    Leave the Library folder open. Try Safari again. If it works now, stop here. Close the Library folder. If you still have problems, continue.

     

    Step 2

      

    Triple-click anywhere in the line below on this page to select it:

     

    open $TMPDIR../C

     

    Copy the selected text to the Clipboard by pressing the key combination command-C.

      

    Quit Safari again. Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Paste into the Terminal window (command-V). I've tested these instructions only with Safari. If you use another browser, you may have to press the return key after pasting. A folder should open. Delete the following items from the folder, if they exist:

     

    • com.apple.Safari
    • com.apple.WebProcess+com.apple.Safari

     

    Quit Terminal. Close the folder. Launch Safari and test.

     

    Step 3

     

    If Safari still doesn’t work right, quit, go back to the Finder and move the following items from the open Library folder to the Desktop (some may not exist):

     

    • Cookies/Cookies.binarycookies
    • Internet Plug-Ins
    • Preferences/com.apple.Safari.LSSharedFileList.plist
    • Preferences/com.apple.Safari.plist
    • Preferences/com.apple.Safari.RSS.plist
    • Preferences/com.apple.WebFoundation.plist
    • PubSub/Database
    • Safari

     

    (Note: you are not moving the Safari application. You’re moving a folder named “Safari.”)

     

    Try again. This time Safari should perform normally, but your settings and bookmarks will be lost. The default set of bookmarks will be restored. Delete them all.

     

    If the issue is still not resolved, quit Safari again and put all the items you moved to the Desktop back where they were, overwriting the newer ones that may have been created in their place. You don’t need to replace the files you deleted in step 1. Stop here and post again.

     

    If Safari is now working normally (apart from the lost settings), look inside the “Safari” folder on the Desktop for a file named “Bookmarks.plist”. Select

      

    File Import Bookmarks

      

    from the Safari menu bar. Import from that file. Recreate the rest of your Safari settings. You can then delete the items you moved to the Desktop.

     

    Note: This step will remove your Safari Extensions, if any, and their settings. If you choose to restore them, do so one at a time, testing after each step to make sure you haven’t restored the problem.

     

    If you don’t like the results of step 3, you can undo it completely by quitting Safari and restoring the items you moved or deleted in that step from your backup, overwriting any that were created in their place.

  • Linc Davis Level 10 Level 10 (107,825 points)

    If you're synchronizing Safari with iCloud, disable that and test. Also test after moving the following item from the user Library to the Desktop:

    • SyncedPreferences/com.apple.Safari.plist
  • Linc Davis Level 10 Level 10 (107,825 points)

    Did you remove all Internet plugins from the Library folder and relaunch Safari?

  • Linc Davis Level 10 Level 10 (107,825 points)

    That setting is stored in the Safari preferences file, which I suggested you move out of the way earlier. If you did that and relaunched Safari, then you would get the same result as from the shell command.

  • Linc Davis Level 10 Level 10 (107,825 points)

    Does this explain this strange behavior?

     

    No, because the shell command makes no changes to those files. It only changes the main Safari preference file.

  • stephan.zehrer Level 1 Level 1 (0 points)

    I can reproduce this behavior both in my account and in a new created accout. I removed now the Adobe Reader plug-in and got the same problem back.

     

    A work-around is to hold the option when you click on a pdf link, this lead always to a download.

    I didn't found another documentation yet how to enable pdf download.

     

    In general i think this is a bug and i would open a radar on it ... or did somebody else?

     

    PS: I found this bug report  https://bugs.webkit.org/show_bug.cgi?id=118858  it seems there is a new PDFPlugin.

  • ricf Calculating status...

    Try this solution found at  http://apple.stackexchange.com/questions/106660/how-make-safari-7-open-pdf-files -in-preview-instead-of-opening-them-in-page?rq=1

     

    At the terminal type   defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

     

    This worked for me

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.