Skip navigation

iMovie not showing as an upgrade in the Mac App store?

345 Views 3 Replies Latest reply: Nov 9, 2013 3:47 AM by Zerodeluxe RSS
Zerodeluxe Calculating status...
Currently Being Moderated
Oct 27, 2013 4:18 PM

Hi

 

I've upgraded to 10.9 over the weekend, and while my other iLife apps have shown as free upgrades, my iMovie isn't being recognised? I've tried restarting, quiting App Store, but still only showing a paid option.

 

Anyone know why this might be please?!

 

It's iMovie '08 - on 2012 MBP 2.4 i7. Thought maybe it was too old, but thought all 'legacy' apps were recognised?

 

Thanks!

 

Ben

iMovie '08, OS X Mavericks (10.9)
  • laundry bleach Level 5 Level 5 (6,875 points)

    Other users have reported being able to get the application for free (as they should be able to) by changing their system language to English, restarting the computer, and then trying to update. If you are not using English currently, try it. Of course you will want to switch back afterwards.

     

    Best of luck.

  • Eric D. Level 2 Level 2 (185 points)

    I'm having the same problem.  My system is already set to English so that's not the problem.  I have iMovie '09 installed on my systems and all the iLife applications have upgraded but iMovie is still showing as a $14.99 download.  Any idea how to get the App Store to recognize that I have iMovie already installed?  From my understanding, iMovie '09 qualifies for a free upgrade.

     

    Thanks,

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.