Skip navigation

Safari 6.1 won't play YouTube Videos, Java screaming

1376 Views 14 Replies Latest reply: Oct 29, 2013 5:14 PM by Daniel Gould1 RSS
Daniel Gould1 Level 1 Level 1 (15 points)
Currently Being Moderated
Oct 28, 2013 12:34 PM

Running OSX 10.8.5 Mountain Lion. Just updated to Safari 6.1 and the Java update via the App store updates. Since then neither my Mac Pro (2009) or iMac will play YouTube videos in Safari. I get a message that says "An Error Occoured" Strangley, the commercials will sometimes play at the begining of the video, but not the actual video I want to view.

 

In addition, both are seeing very high CPU useage (167%) due to Java. This only happens after launching Safari.

 

I restarted several times, ran permmissions and disk repair, and shut off Safari extensions.

 

YouTube play fine in Chrome!

 

Any ideas are welcome.

  • Carolyn Samit Level 10 Level 10 (84,160 points)

    Open System Preferences > Flash Player then select the Advanced tab.

     

    Click Delete All under Browsing Data and Settings

     

     

     

    Quit and relaunch Safari, try a video.

  • Carolyn Samit Level 10 Level 10 (84,160 points)

    Empty Caches and try troubleshooting Safari extensions ...

     

     

    From your Safari menu bar click Safari > Preferences then select the Advanced tab.

     

    Select:  Show Develop menu in menu bar

     

    Now click Develop from the menu bar. From the drop down menu click Empty Caches.

     

     

    Quit and relaunch Safari. If you still have problems, try troubleshooting Safari extensions.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. I

     

    If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

  • Linc Davis Level 10 Level 10 (107,810 points)

    Java is irrelevant to YouTube. You should disable it.

     

    From the Safari menu bar, select

            

    Safari Preferences Extensions

         

    Turn all extensions OFF and test. If the problem is resolved, turn extensions back ON and then disable them one or a few at a time until you find the culprit.

     

    If you wish, you may be able to salvage the errant extension by uninstalling and reinstalling it. Its settings will revert to their defaults. If the extension still causes a problem, remove it permanently or refer to its developer for support.

  • Carolyn Samit Level 10 Level 10 (84,160 points)

    Maybe an incompatible Safari 6.1 plug-in ...


     

    Safari > Preferences > Security

     

    Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

  • Linc Davis Level 10 Level 10 (107,810 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, or by corruption of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled on some models, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and Wi-Fi on certain models.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Linc Davis Level 10 Level 10 (107,810 points)

    On the accounts where YT will not play, the player within YT has a warning that Acrobat is not installed.

    Please post a screenshot that shows what you mean. Be careful not to include any private information.

    Start a reply to this message. Click the camera icon in the toolbar of the editing window and select the image file to upload it. You can also include text in the reply.

  • Linc Davis Level 10 Level 10 (107,810 points)

    That message refers to Flash, not Acrobat. Are plugins enabled in Safari's preferences?

  • Linc Davis Level 10 Level 10 (107,810 points)

    If you're sure you've installed the latest version of Flash, take each of the following steps that you haven't already tried. After each step, relaunch Safari and test. For a "missing plug-in" error, start with Step 5.

    1. If you're only having trouble with YouTube videos, sign in to your YouTube account and load this page. You may see a link with the text "Leave the HTML5 Trial." If so, click that link.

    2. If you're getting a "blocked plug-in" error, then from the menu bar select

     

     ▹ System Preferences… ▹ Flash Player Advanced

    and click Check Now. Quit and relaunch your browser.

     

    3. Triple-click anywhere in the line below on this page to select it:

    /Library/Internet Plug-Ins
      
    Right-click or control-click the highlighted text and select
      
    Services ▹ Open
      
    from the contextual menu.* A folder should open. Delete the following item, or anything with a similar name, if present:
    • Flash Player (failing).plugin  
    You may be prompted for your login password.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combinationcommand-C. In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

      
    4. Re-download and reinstall Flash. Download it from this page:
       
       
    Never download a Flash update from anywhere else.
        
    5. If you get a "missing plug-in" error, select
     
    Safari Preferences... Security
      
    from the Safari menu bar and check the box marked Enable plug-ins.

     

    6. Select

    Safari Preferences... Extensions

    from the Safari menu bar. If any extensions are installed, disable them.

    7. In the Safari preference window, select

    Privacy Remove All Website Data

    Close the window. Then select

     ▹ System Preferences… ▹ Flash Player Advanced

    and click Delete All. Close the preference pane.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.