Skip navigation

Mavericks Mail App and Gmail folders

100687 Views 407 Replies Latest reply: Apr 10, 2014 12:33 PM by GeneticsResearch RSS
  • Niko Nyman Level 2 Level 2 (270 points)
    Currently Being Moderated
    Oct 29, 2013 4:53 AM (in response to peterfromtelford)

    I had the same experience as peterfromtelford: just by making All Mail folder visible to Mail.app and living with mails not filing properly for two days, the problem seems to have cleared itself.

     

    In addition to Gmail now working correctly, rather strangely Mail feels noticeably faster although I now have ≈100.000 IMAP emails cached on my Mac, rather than the ≈10.000 local emails I used to have in the old setup.

  • Gattopardi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 5:31 AM (in response to Barney-15E)

    You're right, my problem is not universal. But if Apple decides not to take anymore account of the operation of Gmail to update Mail, it must keep its customers informed. Especially since Google configuration is always available in Mail preferences.

  • Doug Lerner2 Level 4 Level 4 (1,030 points)
    Currently Being Moderated
    Oct 29, 2013 8:43 AM (in response to neilstaite)

    It's such a mess. Messages are not coming in reliably (there are a whole bunch sitting right now on the Gmail server that just won't come in to Apple Mail). Red flag settings are not being observed. Read mail is not being marked as read - even locally. Mail which has been moved to folders in iOS 7 mail are not syncing and moving in Mavericks Mail.

     

    It's just unusable.

     

    doug

  • cwilsn1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 12:45 PM (in response to neilstaite)

    I have this problem as well (along with the rest of the world). My "all mail" is already turned on and always has been, yet still having this problem.

  • rhimac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 6:19 PM (in response to neilstaite)

    Wow, this is an impressive discussion. How about possible solutions or a temporary fix?

    I happen to have two gmail accounts set up on the same Mac (10.9), neither of them set to "all mail" (both with IMAP path fix set to "IMAP").

    Interestingly, one is affected by the reappearance bug after deleting the message, whereas the other one works totally well with Mavericks, as it did before with ML. That doesn't indicate to me that this is a total desaster from the side of Apple or Mavericks. It looks like there is some minor assigment problem that might be easily fixable once figured out.

    Also, a simple solution that works perfectly well for me has been posted here but it seems to have gone widely ignored.

     

    Just use "option backspace" for now and the selected message is deleted permanently and doesn't reappaear any more (after quitting, chnaging accounts or whatever).

    That's it. There was no need to change any other settings with this one. I have tried this for several days now.

     

    Full credit goes to

    RCSman

    Re: Mavericks Mail App and Gmail folders

  • Niko Nyman Level 2 Level 2 (270 points)
    Currently Being Moderated
    Oct 29, 2013 7:44 PM (in response to rhimac)

    This makes me think something must be different in the Gmail settings of your two accounts. Have you checked if in both of your Gmail accounts all the IMAP and label related settings are identical? Auto-expunge settings etc.

  • rhimac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 7:54 PM (in response to Niko Nyman)

    You are right. There is a difference in settings.

    Mailbox Behaviors, Trash, "Store deleted messages on the server" is unticked in the working account, but ticked in the set-up with the issue. Unlike in ML, these settings are greyed and I can't change them to check this out.

  • virtualAThome Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2013 1:53 AM (in response to rhimac)

    There are two problems, the one where the message is returning to the inbox after it's been deleted and the other one where the message stays in the inbox when it's moved to another folder through some other mail app. Both are the similar, Mail.app doesn't synchronise with the gmail inbox.

     

    When you unchecked "Store deleted messages on the server" that only meant that Mail.app didn't check gmail to see the changes in the inbox, it just locally changed the inbox which is not the solution. The inbox has to be synchronised with gmail all the time or all other devices will have the different mails in the inbox.

  • JanRezab Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2013 2:40 AM (in response to virtualAThome)

    The sync thing here is truly a horrible thing, the "ALL MAIL" fixes moving, but it doesnt fix the inbox. The inbox is prehaps even a worse issue, as it really syncs "ocassionally", and I dont even know the rule to actually make it or force it to sync. Apple should release a fix ASAP.

  • rhimac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2013 3:51 AM (in response to virtualAThome)

    Well, it is not locally restricted to the one Mac where I deleted the message. It does get removed from the inbox of my other Mac as well. However, this is not consistent behavior over IOs devices. It doesn't disappear from my ipad's inbox. For the time being, I am happy with keeping my desktop inbox clear, but those inconsistencies make it very difficult to sort it out.

  • Duncan Pugh Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 30, 2013 3:58 AM (in response to neilstaite)

    I have a similar problem but with my icloud emails. Deleting unread ones and returning deleted ones to the inbox. What an absolute nightmare.

  • Dean Suhr Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 30, 2013 9:51 AM (in response to neilstaite)

    I'm into my 3rd day of synchronization ... and by the looks of things it could be a while (see pic).  FWIW, this did settle down to a more reasonable number after a while.  There are close to 600,000 messages across 7 accounts (5 of which contain 99% of the messages and are all Gmail accounts) and probably 8G of "new" archive/all mail to download.

     

    I sent in a suggestion to Apple that ARCHIVE/ALl messages be able to be confgured as ignored when searching Mail.

    Screen Shot 2013-10-29 at 5.33.25 PM.png

  • lynjon1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 30, 2013 9:58 AM (in response to neilstaite)

    I haven't been able to read the whole of this thread, but I have discovered a quick way to delete (i.e. in Google jargon "archive") Gmail emails from the inbox which is to hit CONTROL-COMMAND-A. Works for me every time.

  • John Ulmschneider Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2013 12:26 PM (in response to neilstaite)

    The solution that has emerged from several posts and threads -- making All Mail visible in Gmail, then waiting for the mail to reload on Mail -- seems to work and has cleared up my problems.

     

    There is one annoying consequence of the fix. When I use the Mail search box, it finds messages which match search criteria that are filed in folders, as it should.  BUT, it gives their location only as "Archive -- (account name) All Mail". Search no longer gives the folder name! I guess that's because the mail message has two labels -- "All Mail" and "folder name" -- but it's frustrating. I can access a found message but I don't know where I filed it, unless by some miracle I remember its folder name. The Search results only list "All Mail" as the location.


    If anyone knows of a way to have Search results show the folder in which a found message resides, I'd love to hear of it.

  • rusto Level 2 Level 2 (215 points)
    Currently Being Moderated
    Oct 30, 2013 12:36 PM (in response to John Ulmschneider)

    Try forcing a re-indexing of your mail:

     

    • Quit Mail if it’s open.
    • In ~/Library/Mail/V2/MailData, delete any file that begins with “Envelope Index,” such as Envelope Index or Envelope Index-shm.
    • Your home Library folder is hidden by default. To display it, choose Finder > “Go to Folder” and then enter “~/Library.”
    • Open Mail.
    • Mail creates new Envelope Index files. This process may take a few minutes, depending on how many messages Mail is reindexing.
1 ... 6 7 8 9 10 ... 28 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.