2 Replies Latest reply: Nov 18, 2013 7:13 AM by koa_noise
koa_noise Level 1 Level 1 (0 points)

Mountian Lion Server 10.8 as a file server

Windows 7 64 bit as the client running Solidworks

 

Issue: mapped drive in Windows client looses connection with OS X Server after upgrading from 10.6 Snow Leopard Server to a new 10.8 Mountain Lion Server. This lost connection happens after a short period of time of initiating the connection after a Windows reboot. These settings were added to the Regestry and seam to have fixed the problem. It apears that OS X 10.7 and up SMB service does not responding when Windows checks the network connection so you have to tell Windows to maintain the connection. The SMB1 and SMB2 settings may not be needed but were used to test different scenarios and have not been removed. The added regersty settings are below.

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Paramete rs]

 

"keepconn"=dword:0000ffff (65535)

"sesstimeout"=dword:0000ffff (65535)

"SMB2"=dword:00000001

"SMB1"=dword:00000001

"autodisconnect"=dword:0000ffff (65535)


Mac mini, OS X Mountain Lion (10.8.5), Server
  • 1. Re: Solidworks on Windows 7 with OS X 10.8 Files Server
    koa_noise Level 1 Level 1 (0 points)

    I need to make an addition to this. Windows Explorer must be opned to the mapped drive and must stay there for this to work. For instance if you have a Z: drive mapped to an OS X share the share must be open in Windows Explorer at all times or the share connection will be lost.

  • 2. Re: Solidworks on Windows 7 with OS X 10.8 Files Server
    koa_noise Level 1 Level 1 (0 points)

    So I need to make another update. The items above helped but didn't fix the problem completely. This may be the magic bullet. I removed the items from the original post from the registry and replaced them with this...

     

    "OpLocksDisabled"=dword:00000001

     

    This seams to work well even after days of putting the computer to sleep. It's not supposed to work under SMB2 but so fare I left the SMB settings to default. One thing that may be a side effect is I can't map Windows to the Mac server share anymore. I don't know if this is because of the changes I have made or a coincidence and the Mac Share is acting up. Either way I just used the share that VMWare supplies and all is working good.

     

    Sorry for the updates but I hope this help others get this fixed.