Skip navigation

Can't import data-only Excel doc into Numbers 2013

1141 Views 5 Replies Latest reply: Oct 30, 2013 12:46 PM by Jerrold Green1 RSS
Fritz Anderson Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 30, 2013 9:10 AM

This is a disaster.

 

I just downloaded two .xlsx Excel documents, and attempted to open them in the new (2013) Numbers.

 

These were the simplest possible documents. 101 rows, 17 colmns, no header/side labels. I don't think it included any calculations at all. My coworker used Excel simply to format her data as a table.

 

The imported Excel table is almost completely blank. A column of dates, and a couple of columns of literal numbers survived. It lost all of the text. I'm sure the column widths were lost. If you try to edit a cell, the editing bar at the bottom does nothing; it has no content, it does not respond to keys or clicks, it stays blank and unresponsive when you select a cell. If you type an = in a cell, there is no expression builder, and clicking in other cells to add them to a calculation merely changes the selection to those cells.

 

In iWork 2009, the apps posted a notice when they couldn't make a 100% faithful import — and in my usage, those were for missing fonts, not absent functionality. No such notice here.

 

My question:

 

Is there any way I can read at least a spreadsheet that makes no use of Excel features?

 

 

Further remark, but not a question

 

I had heard that the days were gone when people had to install Office because that's what they use at work. I managed to get away without using Office from 1989 to this day. I think it's ironic that at the moment Microsoft lost its lock on productivity tools, I am now forced to install Office.


MacBook Pro with Retina display, OS X Mavericks (10.9)
  • Jerrold Green1 Level 7 Level 7 (28,215 points)

    Fritz,

     

    If Numbers worked for you in the past, it will continue to work for you for at least the short term by continuing to use version 2.3. Maybe things you can't do without will be added back into version 3.0. You don't have to board that ship right away.

     

    Jerry

  • keg55 Level 5 Level 5 (5,615 points)

    Fritz Anderson wrote:

     


    If I did have the DVD, it would not contain version 2.3. 2.3 came from an Apple update I downloaded from the support site five years ago. I challenge you to give me a live URL for that updater.


     

    Here is a link to download iWorks 9.3 update which includes v2.3 of Numbers. Hope this helps!

  • Jerrold Green1 Level 7 Level 7 (28,215 points)

    Fritz,

     

    Unless you moved or deleted the old version it is still right where it used to be: Applications > iWork '09. It is not true that there was an automatic deletion.

     

    Take a look there.

     

    Jerry

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.