1 2 Previous Next 18 Replies Latest reply: Jan 31, 2014 8:59 AM by MrKitty
AlphaPo Level 1 Level 1 (0 points)

With the updated Mail program in 10.9, the first time I opened Mail it presented the "Welcome to Mail" screen. I clicked continue and it completed it's processing of whatever it needed to do. However, when I open the program now, it displays it every time, though clearly, the process is complete, as it instantly *dings* after I click continue and goes to my mail.

 

Why?


MacBook Air, OS X Mavericks (10.9)
  • 1. Re: Continuous "Welcome to Mail"
    Rossiter/SATX Level 1 Level 1 (10 points)

    Same problem on mid 2010 15" MacBook Pro. No solution found yet.  I upgraded two 2011 mac mini's and a 2007 iMac without issue, but have the persistant "Welcome to Mail" on the MBP.

  • 2. Re: Continuous "Welcome to Mail"
    alovelyladybird Level 1 Level 1 (0 points)

    I, too, have this issue and it is driving me NUTS. If anyone out there can help I would appreciate it enormously!

     

    Screen Shot 2013-10-29 at 10.59.30 AM.png

  • 3. Re: Continuous "Welcome to Mail"
    Greg_Priestley Level 1 Level 1 (0 points)

    Same here.  MacBook Pro 15" with Retina Display.

     

    Tried repairing security permissions - no change.

     

    Tried rebuilding mail by deleting the envelope files as follows, but no change:

     

    "You can rebuild the Envelope-Index by throwing it away, it's located at ~/Library/Mail/V2/MailData/

    1.Your Library folder is hidden by default. Select Finder (in the dock) > “Go to Folder” and then enter “~/Library.”

    2.In ~/Library/Mail/V2/MailData, delete any file that begins with “Envelope Index,” such as Envelope Index or Envelope Index-shm.

    3.Mail will rebuild the Envelope index when it is reopened. It will take a few minutes to rebuild the entire index."

     

    I have multiple accounts, so I went into Mail, Preferences, Accounts and disabled all but one account to try and isolate it.  This then worked OK. 

     

    So I re-enabled one account at a time and each time checked whether it worked. One by one they were re-enabled and worked OK.

     

    In the end I had re-enabled all of the accounts that I disabled, and it was working.  Can't explain it.

  • 4. Re: Continuous "Welcome to Mail"
    Coruway Level 1 Level 1 (0 points)

    Same issue: Welcome to Mail evry mail stratup. MBP 13" 2012 i7. Have tried to isolate by disabling accounts and rebuilding mailboxes, but still it goes on. So far Mail working outside of this annoyance.

  • 5. Re: Continuous "Welcome to Mail"
    martinv040 Level 1 Level 1 (0 points)

    Same here, on a Mac mini Mid 2011.

  • 6. Re: Continuous "Welcome to Mail"
    Rossiter/SATX Level 1 Level 1 (10 points)

    Greg, I tried your solution. No Joy! I guess I'll have to look elsewhere for an answer. I'm glad it worked for you. One exception to your method; I didn't delete the Envelope Index files, I just renamed them. As it turns out, this was a good safety measure as after the index rebuild only a handful of recent emails were accessable. Restoring the original files returned the database.

  • 7. Re: Continuous "Welcome to Mail"
    FMALCK Level 1 Level 1 (10 points)

    Here is a solution:

     

    1. Start OS X Mail

    2. Go to: Preferences ▸ Accounts

    3. Turn off all your mail accounts with „Enable this account”

    4. Quit Mail

    5. Restart Mail

    6. Go to: Preferences ▸ Accounts

    7. Activate all your mail accounts with „Enable this account”

    8. Quit Mail again

    9. Restart Mail

    "Welcome to Mail" has now disappeared!

     

    Thanks to http://www.appletips.nl/genius/discussion/122/startscherm-welkom-bij-mail-blijft -terugkomen#Item_1

  • 8. Re: Continuous "Welcome to Mail"
    XnLiberty Level 1 Level 1 (0 points)

    Thanks FMaclk, that worked for me!

  • 9. Re: Continuous "Welcome to Mail"
    Rossiter/SATX Level 1 Level 1 (10 points)

    Tried disabling accounts/stopping mail/restarting mail/enabling accounts as suggested.

    Still "No Joy!"

    I wish one of these solutions would work on my MBP

  • 10. Re: Continuous "Welcome to Mail"
    alovelyladybird Level 1 Level 1 (0 points)

    Thank you! This worked for me

  • 11. Re: Continuous "Welcome to Mail"
    Robb Allan Level 2 Level 2 (340 points)

    I didn't find that this worked quite as advertised. I had two disabled accounts that had not been "downloaded" during the initial launch of Mavericks Mail. Disabling all the active accounts as described above didn't eliminate the opening dialog box; only when I activated the two disabled accounts, let them begin to download, quit, and relaunched did the initial dialog finally disappear. I infer that Mavericks Mail keeps a list of all accounts that have been (even partially) downloaded, and as long as as any account remains uninitialized, the dialog will continue to appear.

  • 12. Re: Continuous "Welcome to Mail"
    Coruway Level 1 Level 1 (0 points)

    That did it for me. I had an old account that was disabled. I eneabled it, allowed the messages to be imported, disabled. Quit and restarted. No more dings. Thanks Robb!

  • 13. Re: Continuous "Welcome to Mail"
    FMALCK Level 1 Level 1 (10 points)

    Sorry for the misunderstanding: It is in the words: turn off all, and turn on all

  • 14. Re: Continuous "Welcome to Mail"
    Rossiter/SATX Level 1 Level 1 (10 points)

    Success! Thank you all for the support you have provided. The key was in renabling ALL the accounts. I had only been renabling the accounts I routinely send/receive from/to, as the other accounts forward to them. Now that all is well, I have once again disabled the forwarding accounts and Mail is behaving.

1 2 Previous Next