Skip navigation

Imovie update problem after Mavericks

2369 Views 9 Replies Latest reply: Oct 30, 2013 11:30 PM by giampierocialini RSS
giampierocialini Calculating status...
Currently Being Moderated
Oct 23, 2013 11:04 PM

After Mavericks istallation ,Iphoto update  correctly but Imovie have update problem , now on AppStore download until 90% and it stop with message  "impossible download go to the purchased app" but nothing happen. How can I resolve it ?

Thank you

iMac (21.5-inch Mid 2011), OS X Mavericks (10.9)
  • Nanoparticle Calculating status...
    Currently Being Moderated
    Oct 28, 2013 12:13 PM (in response to giampierocialini)

    I also nve thsi problem and this solution DID NOT solve my problem.  But my problem is slightly different.

     

    After upgrading to Mavericks, I updated bot iLife and iWorks (long time user of both).  iMovie did install but would not run (simply stopped responding despite repreated attempts to start up and repeated restarts on my iMac).  I deleted iMove (note tha old version 9.x) i ssti on my computer.  When I went to the OSX App store it shows iMovie installd and there is no way to re-install it?

  • Nanoparticle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2013 11:20 PM (in response to giampierocialini)

    English.  I tried the suggestion above - several times actually, once just re-entering English and another time changing to French and then to English.  Neither one helped after reboot.

  • Nanoparticle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2013 11:23 PM (in response to giampierocialini)

    In addtion, I have also submitted now a iTunes troublshooting ticket from my purchases within my Account.  I received an automated reply from Apple with advice that they would contact me back within 48 hours.

  • Nanoparticle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 8:20 AM (in response to giampierocialini)

    Thank for very  mcch your help and assistace.  I think my issue is different because the initial iMovie ugrade downloaded, but then the program wouldn't open.  I tried to resolve that issue by deleting and reinstalling the app (same as I would for any iDevice, but apparently the OSX app store works completely different from iOS).  iTunes has flagged that I have ugraded and that flag needs to be reset at Apple in order to provide for another download/install.  FYI, the older version (iMovie 9) is automatically saved in its own folder (as are all of the old iWorks programs - this to assist with features that were removed (such as Apple Script support (bad move Apple) and  a host of others)), which make backward compatibility difficult.

     

    I will leave this link open and will update once I hear back from Apple.

  • Nanoparticle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 11:35 AM (in response to Nanoparticle)

    OK, as of this morning Apple had reset iMovie within OSX App Store and it was available as a download.  I've downloaded it, it installed and I was able to open it.  I don't see any of my previous iMovie edits, but that is a learning curve for me with an upgraded program, which I will takle this weekend.

     

    The take away for me - any issues with the OSX store are reflected within iTunes purchases (from within your account area) and can be resolved by "report a problem" back to Apple from the log of iTunes store purchases.

     

    Thanks for your help again.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.