1 2 Previous Next 19 Replies Latest reply: Mar 18, 2014 10:58 AM by kleinholz
Bob_Hamburg Level 1 Level 1 (0 points)

I've been using group mailing lists for forwarding mails from our answering machine to a number of users. The answering machine (Fritz!Box) generates wav-files for every incoming message and sends it as a regular mail to a group on the server. After upgrading to Mavericks Sever 3 those mails don't come through anymore.

 

listserver.log reads:

list_server_post[7750] <Info>: message: xyz.msg from: user@domain posted to: group (size=184314)

list_server_mgr[8254] <Info>: list manager wake event: xyz

list_server_agent[7754] <Info>: list agent started for list ID: xyz

list_server_agent[7754] <Error>: message: abc.msg exceeded maximum message size: 184314 > 40960

list_server_agent[7754] <Info>: moved message: abc.msg to: /Library/Server//Mail/Data/listserver/messages/hold

list_server_agent[7754] <Info>: list agent sleeping for 60 seconds

list_server_agent[7754] <Info>: list agent exited

 

The maximum message size for mails set using serveradmin is 10MB. Does anyone know of a way to incerease the list_server's maximum message size?


Mac mini, OS X Server
  • 2. Re: How to increase group mailing list maximum message size?
    Bob_Hamburg Level 1 Level 1 (0 points)

    Thanks for pointing this out. I found it set to the 10 MB limit, so there must be another setting for list_server.

  • 3. Re: How to increase group mailing list maximum message size?
    andipilz Level 1 Level 1 (0 points)

    Hello both,

     

    I have the same problem and started a parallel thread here: How to change listserv message size

     

    The settings for postfix do not help, I can confirm. The settings pointed out in the other thread do not work, so I need to assume (and only assumption) that Apple has not packaged LSoft's ListServ with Mavericks.

     

    Anyone has additional hints?

     

    Regards

     

         Andi

  • 4. Re: How to increase group mailing list maximum message size?
    raimattern Level 1 Level 1 (95 points)

    From another thread:

     

    In 10.8 the GUI option to send thru ISP worked ok. I’ve found that in 10.9, Server Admin correctly configures /Library/Server/Mail/Config/postfix/main.cf but for some reason postfix does not get the parameters correctly. Another parameter that is not gathered is the max message size.

     

    To make it work I had to manually add the smtp_sasl related options to /etc/postfix/main.cf file. Just copy the specific entries from the /Library/Server/Mail/Config/postfix/main.cf file.

     

    Didn't check by myself.

  • 5. Re: How to increase group mailing list maximum message size?
    andipilz Level 1 Level 1 (0 points)

    Dear raimattern,

     

    the max message size from main.cf for postfix is pulled by postfix correctly, as this was my first assumption and that I tested with detail. So this cannot be it.

     

    The error in the system.log and listserver.log files is recorded from list_server_agent and not postfix!

     

    Any more insights?

     

    BR Andi

  • 6. Re: How to increase group mailing list maximum message size?
    Philip GW Level 1 Level 1 (5 points)

    I just spoke with Apple Enterprise Support and they informed me that there is a hard-coded message size limit of 40,960 (bytes I think), and that there is no fix for it at this time.  However, he also indicated that it is a known issue, so hopefully they will fix it quickly on an upcoming patch.

     

     

    I don’t want to revert back to 10.8, so my workaround was to:

    1.          Delete all the list groups, but write down the group name and members first

    2.          Add all the group names as short names of a single user’s account using Workgroup Manager

    3.          In that user’s account, configure Mail rules to redirect the message to the group members, and leave mail up running all the time.

     

    Not a great solution, but hopefully it will get me by until they fix it.

  • 7. Re: How to increase group mailing list maximum message size?
    andipilz Level 1 Level 1 (0 points)

    Thanks Philip GW,

     

    that's where I am now also. I thought, I'd never be back with huge /etc/postfix/aliases-like files ... ;-)

     

    Thanks for sharing, and let's hope for a fix soon.

     

    Thanks

     

    Andi

  • 8. Re: How to increase group mailing list maximum message size?
    Lynda Leung Level 1 Level 1 (0 points)

    Don't think that is the problem.  None of our messages were more than a few lines of plain ascii text.

    The list services simply gets wedged, not just a single over sided mail that gets held.

     

    I hope Apple publishes a fix soon, the bug list on this is getting longer and longer!

  • 9. Re: How to increase group mailing list maximum message size?
    Philip GW Level 1 Level 1 (5 points)

    Just wanted to pass on that I just got an email from Apple Support that they have setup a test environment and have been able to recreate the issue.  It is actively being diagnosed.  They are working on both the issue requiring a restart of the email service / list_server and the issue where large attachments sent to a list group are truncated.  I will keep everyone informed when I hear more.

  • 10. Re: How to increase group mailing list maximum message size?
    davidfromdeerfield Level 1 Level 1 (0 points)

    Philip GW wrote:

     

    I just spoke with Apple Enterprise Support and they informed me that there is a hard-coded message size limit of 40,960 (bytes I think), and that there is no fix for it at this time.  However, he also indicated that it is a known issue, so hopefully they will fix it quickly on an upcoming patch.

     

     

    I don’t want to revert back to 10.8, so my workaround was to:

    1.          Delete all the list groups, but write down the group name and members first

    2.          Add all the group names as short names of a single user’s account using Workgroup Manager

    3.          In that user’s account, configure Mail rules to redirect the message to the group members, and leave mail up running all the time.

     

    Not a great solution, but hopefully it will get me by until they fix it.

    I have a single group with two members that we use to receive messages and distribute.  I don't understand the steps above.  Can you repost in greater detail or contact me privately at david-ferri at wordmaster.com?

  • 11. Re: How to increase group mailing list maximum message size?
    Philip GW Level 1 Level 1 (5 points)

    David: 

     

    The way I look at it, a list server has two components:  It creates an arbitrary email address for your domain and it also allows you to use that email address to send to multiple users.

     

    To replace both these components, you will need to select a user that you want to use as a catch all email address. This can be an already existing user or a new user.  Any user can have multiple “short names" or "aliases".  A short name is a name they can login with and also receive email at.  For example, create a user called listman.  Its email address would be listman@yourdomain.com. Now lets say you want to have other email accounts like sales@yourdomin.com and info@yourdomain.com. You can add “sales” and “info” as Short Names or Aliases to the user listman.  This way any mail sent to sales or info will go to listman.  To do this, using the Server app, go to Users and right click on the listman user you created.  Then select Advanced Options and add sales and info to the Aliases field, separated by commas.  Now listman will receive mail when sent to listman, sales, and info.

     

    The next component is to distribute that mail to the other users.  The way I do that is to use the Mail app.  Pick a computer that you can leave up all the time with the Mail app running.  Create an account for the listman user, so the Mail app will receive all that user’s mail. Then setup rules to distribute the mail to the people you want.  To do this (after setting up the user's mail account), go to Mail > Preferences > Rules > Add Rule.  Fill out the fields like this:  Description:  Sales, if ALL of the conditions are true, To Contains sales@yourdomain.com,  Perform these actions:  Redirect Message to user1@yourdomain.com user2@yourdomain.com.  Then add another rule for info, and so on.

     

    So by doing this an incoming message send to sales@yourdomain.com will be sent to the user listman.  Then, the Mail app will redirect this message to user1 and user2 as long as the Mail app is up and running all the time.  I know, not the best solution, but it works for me until they get it fixed.

     

    It is important to use Redirect instead of Forward.  This is so that you maintain the original sender in the email.  Otherwise, it would say it is sent from listman.  Also, Redirect properly forwards attachments and Forward does not (for me anyway).

  • 12. Re: How to increase group mailing list maximum message size?
    davidfromdeerfield Level 1 Level 1 (0 points)

    Philip,

     

    It may be a candidate for a Rube Goldberg award, but your technique works!

     

    Thanks for the help and please let us know if and when you hear back from Apple about a resolution.

     

    Regards,

    David

  • 13. Re: How to increase group mailing list maximum message size?
    Philip GW Level 1 Level 1 (5 points)

    Just FYI:  I got another email from Apple Support, and the issue has been escalated again.  Now it's at the level where it will be in a future update. Hopefully the next one!

  • 14. Re: How to increase group mailing list maximum message size?
    kleinholz Level 1 Level 1 (15 points)

    I encountered the same situation. Apple Enterprise Support sent me a solution to this problem:

     

    • Ensure you are using the latest OS X and server.app versions.
    • Stop the mail service in server.app
    • Backup /Library/Server/Mail/Config/MailServicesOther.plist
    • Open terminal and use the following command:

      Replace <mydomain.com> and <size_in_kilobytes> with your domain name and the maximum allowed message size.

      sudo defaults write /Library/Server/Mail/Config/MailServicesOther.plist list_server -dict-add dest_domain <mydomain.com> max_message_size -int <size_in_kilobytes>

    • Transform the setting with:

      plutil -convert xml1 /Library/Server/Mail/Config/MailServicesOther.plist

    • Start the mail service in server.app.

     

    Messages should not get stuck in the message queue anymore because of the message size limit. Maybe you need to move old messages in the hold folder which you can find in /Library/Server/Mail/Data/listserver/messages.

1 2 Previous Next