Skip navigation

Can't install mavericks because apparently my disk is damaged

26159 Views 92 Replies Latest reply: Feb 3, 2014 6:01 AM by tonybonez RSS Branched to a new discussion.
  • Tim Durbridge Calculating status...

    Hi Petermac, Thank you for helping out here with the Maverick installation disc damage problem.

     

    Some have advised this is due to hardware issues with the HD. Replacing the HD would no doubt solve the problem as this would ensure a clean installation.

     

    But this drastic action seems unnecessary because some have been able to clear the "damage" with a 3rd party app, and then install Mav successfully.  Others have been able to install after their HD has merely been erased.

     

    It seems that Mav installation is sensitive to some aspect of the code sometimes somewhere present on ML running machines, and as a consequence the HD becomes "damaged".

     

    After erasing, I did a download of ML in recovery mode (rather than Mav), and there were no problems with this install. Disc utility found no faults with my HD.  I then opted to restore ML and my data, as was, from my time machine, so I am fortunate! Thank goodness Apple introduced recovery mode in ML. I won't try to install Mav until this issue has been sorted.

     

    There are those without a backup, who deserve clear advice on the steps they might use to be able to recover their data to an external whatever. Some of this is scattered through this thread and the many other threads concerning Mav installation problems.

     

    For those that did backup before the damage was done, it would help if you could give clear instructions to the baffled about recovery mode and restoring the system to ML from a backup.

     

    Thanks Tim

  • petermac87 Level 5 Level 5 (4,065 points)

    Tim Durbridge wrote:

     

     

    There are those without a backup, who deserve clear advice on the steps they might use to be able to recover their data to an external whatever. Some of this is scattered through this thread and the many other threads concerning Mav installation problems.

     

    For those that did backup before the damage was done, it would help if you could give clear instructions to the baffled about recovery mode and restoring the system to ML from a backup.

     

    Thanks Tim

    Luckily for them these instructions have been posted on these forums about fifty times in the last few days. I advised replacing the disc if it died. Not if it could be repaired with DiskUtility. If a disc has come up as damaged and still used for an install, then personally I would never trust that drive again. But some do, and that's their business/problem.

     

    I am not sure what third party app you are refering to, but I don't use of them for diagnostics/repair. Perhaps DiskWarrior would be the only one.

     

    I am sure if users with the backup/restore problems post then they will be given advice on how to do it. This is not the User Tips sections.

     

    Cheers

     

    Pete

  • Peter Moyer Level 4 Level 4 (1,315 points)

    Well, I am one of those users that has done just about everything. Ironically I did a verify and repair disk permissions with disk utility before I attempted the upgrade. Old habit. I got the message at the beginning of the install that my disk was damaged and could not install. I have tried Internet R, disk utility, reloading ML to no avail. During the process I ended up in a loop where my computer displayed a blinking folder with ?  So it cannot locate the disk? I tried downloading ML to a external disk but that disk was not formatted right and when I tried to reformat, that disk was greyed out. Disk Utility reports show that my partition is full and cannot be fixed due to it being encrypted. I had File Vault 2 on and encryption enabled. That may have been my problem.

     

    I do understand that upgrades might fail a disk that was on the verge. I am hoping that next week I will find out if this can be fixed software wise or if the disk is truly dead. Unfortunately I am in SE Asia and not near any Apple Store. They have a chain here called iStore that supposedly is a authorized dealer. Repairs are not done in store but rather shipped out which I am not planning to do if it comes to that.

     

    If there is anything I haven't tried I would appreciate any suggestions.

  • zeles Calculating status...

    If you are seeing the following

    • The prohibitory sign when you try to boot
    • If you try to boot in verbose mode, you see the message that it can not find the root device
    • If you try disk utitlity, and it tells you your drive is MS Data, needs to be repaired, but can't repair it.
    • If the error you are seeing in disk utility when trying to repair contains "Invalid bs_jmpBoot in boot block: 000000"

     

    Then the disk is not really damaged and the installation actually completed.  For some really stupid reason, at the very end of the installation, the type of your main partition got changed from HFS+ to Microsoft Data.   This is not a purely ML->Mavericks issue.  It happened to me when migrating from Lion, and I'm pretty sure I actually had the same issue when going from SL->Lion.  It's possible that having a Boot Camp partition might have been at fault.  Maybe doing anything which changes the partition table away from being just HFS+ partitions does it.

     

    There are 2 third party programs which I've seen mentioned that can resolve this issue.  They have been mentioned numerous times in this thread, and others.  These are TeskDisk and gpt_surgeon.py.  Using them though is tricky.  You will need to make yourself some sort of boot disk.  TestDisk can be downloaded in actual binary self contained form which you can copy to your boot disk, but honestly even trying to follow some of the instructions available on the web, I found it so difficult to use I gave up on it.  The usage of gpt_surgeon.py is way more easier.  For that, you have a couple of choices.  Make your own boot disk that has python installed on it, or download one that already has it.

     

    Personally, what I did was while on the website for TeskDisk I went to the LiveCD's available for TeskDisk, http://www.cgsecurity.org/wiki/TestDisk_Livecd, and downloaded the Ultimate Boot CD since I had used that disk in the past to recover various NT systems.   When I booted off this cd, I chose to run TestDisk which is under HDD / Data Recovery.  Just ran it with the default selections which booted me into a gui Partition Magic Linux installation which has python already installed.  Instead of actually running TeskDisk at that point, I fired up a web browser, and went to http://steelpangolin.wordpress.com/2009/03/15/invalid-bs_jmpboot-in-boot-block-0 00000/ .  I downloaded gpt_surgeon.py from there, opened up a Terminal window, did a cd into the Downloads folder, a chmod u+x gpt_surgeon.py to make the python script executable, and after that just followed the instructions on the website.  For me, my hard drive was /dev/sda I believe. You should be able to find that with either the fdisk or df command. So the commands ended up being ./gpt_surgeon list /dev/sda    and ./gpt_surgeon repair /dev/sda 1.  After that, I just rebooted, Mavericks fired right up and I was asked the last couple of questions to complete installation.

  • Peter Moyer Level 4 Level 4 (1,315 points)

    I ended up doing a complete erase and reinstall of ML via Internet R. In order to get to that point, I had DU erse the HD. I had a TM backup. When that was finished, I got a message that the erase had failed due to a partition error. I was then able to click on the partition tab, reduce the size of the partition by 30g and then go from there. The HD verified okay and I reinstalled ML.

     

    I found this post by Kappy on another thread which helped me immensely.   https://discussions.apple.com/thread/5507734

  • Stuka87 Calculating status...

    To those formatting their hard drives, Disk Warrior will fix just about every issue out there. Including the issues that I had.

     

    It will no boot the latest Macs however (Appls fault, they have not released a version of the OS that devs can use to boot machines since 10.6). So you have to run it from another computer via target disk mode, or boot off another hard drive.

     

    To fix my machine, I booted from an external drive, and installed disk warrior 4.4 onto that drive, and then repaired mymain drive. It is now working perfectly.

  • Hanan-M91 Level 1 Level 1 (0 points)

    So what to do now it keeps saying a S.M.A.R.T hardsisk failure thy have ruined my Mac it was working fine actually perfect and now all my stuff are gone wth! Please don't tell ,

    Me I lost all my data someone tell me that there is a way what is wrong with apple they always figure out away to miss the laptops thy don't do good please please please help i'v work To finish

  • Stuka87 Level 1 Level 1 (0 points)

    Your best bet to recover the drive is Disk Warrior. If your machine was made in the last 1.5 years, you will need a second Mac, or an external HD to repair it however. As the current version of disk warrior will not boot current Macs (Apples fault, not Alsofts).

     

    However, with SMART failures, its typically a hardware issue. This is why backups are very important. Chances are your drive had issues before hand. It may have run ok, but the installer found them.

  • j2nh Calculating status...

    Start the Mac in Target Disk Mode and pull your data to another computer.  About all you can do.  I had this problem as well and was able to recover what was not backed up.  You will then have to reformat your drive and start over.  Experience has shown me that it is possible to recover data using this method.  Good luck.

  • petermac87 Level 5 Level 5 (4,065 points)

    Stuka87 wrote:

     

    As the current version of disk warrior will not boot current Macs (Apples fault, not Alsofts).

     

     

    How do you figure that?  I just ran DiskWarrior yesterday on Mavericks. It worked fine. If it had not of then I would be thinking Alsofts fault, not Apples. Hoe did you come to YOUR conclusion?

     

    Pete

  • mmand Level 1 Level 1 (0 points)

    Some people here seem to have the same problem as me: Mavericks installation fails, both Mavericks and 10.8 installer won't recognise the HD (greyed out / with exclamation mark sign in installer).

     

    My solution is described here:
    https://discussions.apple.com/thread/5528303

  • eternaloptimist Level 1 Level 1 (0 points)

    I noticed that you are running a Seagate SSHD from your post.  I'm interested in using a Seagate 2TB SSHD in my 2009 Mac Pro. I am presently running Mavericks and Windows 7 (64 bit) natively in Bootcamp.  I am considering moving to a 2TB Seagate SSHD.  Will that work on my Mac Pro, and will Windows 7 benefit from the SSHD speed bump?  Can I clone the partitions to the SSHD drive or is it better to do a clean install?  I really don't like Windows running in Parallels because of the lag and other irritations, and am hoping that an SSHD will at least reduce the lag so that I can run Windows virtually. 

     

    Any thoughts on these issues would be greatly appreciated.

  • ecojim Calculating status...

    I am having a version of the same issue.  With a new Apple TV, I advised my daughter to upgrade her OS from Lion.  I found that the Upgrade to Maverick was free so I jumped on it.  Unfortunately, I did not back up her data.

     

    Initially, I got the "Install Failed.  OS X could not be installed on your computer" error.  There was no defining reason.  I restarted and it happened again.  I successfully repaired "Partition map needs to be repaired" errors in disk utilities.  It shows no further errors with "verify."

     

    I'm still stuck in the Install Failed loop for OS X. 

     

    Unfortunately, my daughter does not back up and is in the middle of a college term.  Please let me know what you suggest that has the best chance on not deleting her school work.

  • ecojim Level 1 Level 1 (0 points)

    I am now "reloading" OS X from the Disk Utilities page.  I will be monitoring this site during the process for your ideas.  She is planning to go back to college tomorrow morning early. 

  • ecojim Level 1 Level 1 (0 points)

    Hey Mac fans, patience is a virtue.

    1.  Got stuck in "install Failed" loop trying to upgrade to Maverick

    2.  Fixed disk errors via disc utilities.

    3.  Reinstalled OS X.  Looked good up until "Less than a minute" message.

    4.  Waited 30-60 minutes.  Finally cleared. Have patience.

    5.  Another long wait (less than above) in "Completing Installation" (stuck a post it on screen to see if the bar was actually moving).  Can we adopt a new adage, "a watched bar never grows"?

     

    Finally everything is working. (as far as I can tell)

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.