2 Replies Latest reply: Nov 1, 2013 2:20 AM by RMArmstrong
RMArmstrong Level 1 Level 1 (0 points)

Have OSX 10.5.8 and need OSX 10.6.8 to update iTunes so I can synk my iPad. Is this possible? I can't afford to buy a new computer at this time.


MacBook (13-inch Early 2008), Mac OS X (10.5.8)