Skip navigation

Thunderbolt Pegasus R4 Experience?

91457 Views 438 Replies Latest reply: Apr 10, 2014 11:14 AM by Douglas Harris RSS
  • Matchless297416 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 1:50 AM (in response to Infotech 24 7)

    "My advice? Seek other solutions....Promise is not one of them"

     

    Reluctantly, I have to agree: a lot of fuss, Apple endorsement, good

    looks and high price may be misleading sometimes, and this is just

    the case.

     

    The self-ejecting problem is here to stay and Messrs. Promise seem

    not to care about it.

  • ke3z Calculating status...
    Currently Being Moderated
    Nov 1, 2013 1:53 AM (in response to Matchless297416)

    Does anyone know of a competing solution that has proven reliable? My R6 is working flawlessly, but I haven't upgraded to Mavericks after seeing the problems reported here. Eventually, I'm going to want to do so.

  • martinfrompoole Level 1 Level 1 (140 points)
    Currently Being Moderated
    Nov 1, 2013 2:08 AM (in response to ke3z)

    Folks,

    Before pointing the finger of blame at Promise, WD have emailed all registered customers warning of data loss/corruption with external hard drives after upgrading to Mavericks; while there may be issues with the Promise drives there may also be issues with Mavericks.

  • LyndonKL Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 2:12 AM (in response to LyndonKL)

    Promise finally advised me that a replacement will be sent...next week.

    If this one works and with Mavericks (the 'eject' problem started well before the update) I will so advise in this post. Hopefully all will work notwithstanding the WD issue.

  • ke3z Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 1, 2013 2:13 AM (in response to martinfrompoole)

    My understanding is that the WD issues have to do with the WD-supplied drivers, not the disks themselves. While that may be part of the problem in the Pegasus case as well, problems with these units predate Mavericks and have been widely experienced, as the length of this thread shows.

     

    I did notice, however, that I'm not running the latest firmware and am wondering if those who have experienced Mavericks problems have ensured that they are using the most recent Pegasus firmware?

  • Matchless297416 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 2:21 AM (in response to Infotech 24 7)

    The WD drives problem is separate and peculiar to this brand, I think.

     

    My Pegasus RS is equipped with Hitachi drives from its origin, was updated to the new firmware before Mavericks came out and the self ejecting problem was there before the firmware update and before Mavericks, and is stil present after the firmware update and after Mavericks.

     

    The problem began being reported by user since mid 2012 and is not related nor cured by the firmware update.

  • LyndonKL Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 2:26 AM (in response to Matchless297416)

    Seems to me from what I have experienced and what others are reporting the issue is not directly related to drivers, firmware, or OS version, as all combinations are present in the failure.

    The issue is deeper and points to either the iMac (is the problem reported with other Macs??) or just isolated to and within the electronics of the R4?

  • Matchless297416 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 6:48 AM (in response to Infotech 24 7)

    The iMac is not the issue.

     

    Self ejects have been reported with other machines as well.

  • Bosto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 7:42 AM (in response to Matchless297416)

    Agreed.  We have a small network of iMacs, all with Promise Pegsus R4's.  And, three of us bought identical units for home (it is much easier to use mirror-like systems).  The iMacs are loaded, and have 3 27" Thunderbolt monitors as well, and in addition have 3 TB USB drives too.  Everything worked flawlessly for over a year on all systems then we did a universal (except for my home iMac) update to Maverick.  The R4's on everything Maverick went south in a casacde and we've tried everything suggested by numerous threads here, and NO help at all from promise or Apple (except for these community threads).

     

    So:  1) it is NOT the iMac.  2) the R4's worked fine BEFORE Maverick for a year or more - no issues at all.

     

    Others may have had R$ issues, but we have not, so this multiple-system (all independently run, just on a hospital LAN) all show the same issue, and so do the home units (except the one NOT updated to maverick.

     

    It is possible, jumping through many hoops, deleting the time machine .plist file, hard starting everything, yanking an replacing cables, unplugging and replugging, re-installing Maverick etc, to get the R4 to do one initial Time Machine backup... but it will fail on the first incremental.

     

    My bet is an incompatible driver or handler embedded in Maverick that Apple is silently puzzling over.

  • Guarino.R.Colli Calculating status...
    Currently Being Moderated
    Nov 1, 2013 12:56 PM (in response to ke3z)

    After returning the Promise Pegasus to Apple and getting a refund, I'm now using a Seagate Business Storage 4-Bay 16TB NAS, which is working flawlessly since day 1, albeit slower than the Pegasus drive. It also costed 2/3 of the Promise and has 4x more storage room!

  • Matchless1895 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 4:03 AM (in response to Infotech 24 7)

    I am happy to know that you succeeded in getting rid of your Promise Pegasus and that the NAS you got is suiting your needs, but unfortunately, for the most part of Pegasus users a NAS would not be the answer.

     

    The fora seem to grow every day with complaints about the Pegasus malfunctions, and again most of the persons involved are stuck with a piece of equipment out of warranty, or with service unavailable, which cannot be returned notwithstanding the steep price paid for it in the assumption that it was a reliable and durable investment.

     

    Just bad luck or bad faith?

  • Bosto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 1:38 PM (in response to Bosto)

    YAY: finally, kudos to 3 guys at Promise (Jerry, Stephen and Victor) (i hope, but everything seems to be working again, although i did lose all my older backups).

     

    NUMBER ONE PROBLEM: MY IMAC DID NOT HAVE THE PROMISE UTILITY INSTALLED. I INSTALLED THAT FROM THEIR SITE DOWNLOAD CENTRE, BUT THEY ALSO SENT ME A LINK TO IT.

     

    granted, they haven't quite released the fully-functional mavericks (osx 10.9) version yet, but the older one does work in command mode to get reports out of it.

     

    AFTER THAT, IT WAS NOTED THAT MY FIRMWARE VERSION WAS OUT-OF-DATE, AND IT REQUIRES THE LATEST ONE TO WORK WITH MAVERICKS (PERMISSION ISSUES, SOMETHING I ALREADY SUSPECTED WAS HAPPENING BUT APPLE ERROR MESSAGES ARE GETTING TO BE LIKE MICROSOFT IT SEEMS)

     

    NEXT ITEM, MAC USERS CAN'T DOWNLOAD THE FIRMWARE UPDATE FROM PROMISE AND EXPECT IT TO WORK, THE .IMG FILE THEY HAVE WON'T WORK UNDER MAVERICKS (APPLE'S NEW PROPRIETARY FILE FORMAT BS AGAIN I SUSPECT).

     

    SO, YOU MUST-MUST-MUST HAVE THAT PROMISE UTILITY INSTALLED AND THEN 'CHECK FOR UPDATES'.  THEN INSTALL THE UPDATE VIA THAT UTILITY.  THE INSTRUCTIONS SAY TO POWER CYCLE YOUR PEGASUS OR REBOOT YOUR SYSTEM... YOU MUST-MUST-MUST DO BOTH.

     

    THEN, GOD, DEMONS, AND OTHER ASSPORTED SAINTS AND PROPHETS (PROFITS?) PERMITTING, YOU'RE UP- AND-RUNNING AGAIN.

     

    I SURE WISH THE **** SOMEONE HAD SAID ALL THIS A WEEK AGO INSTEAD OF 'OH YAH, WELL WE TESTED EVERYTHING AND OURS WORKS'

     

    GET THE WORD OUT TO PROMISE USERS GUYS AND GALS... GET THAT PROMISE UTILITY AND DO YOUR DUE DILIGENCE!!!

     

    AND IF YOU CAN'T GET THAT HD TO WORK... THEY WILL SEND YOU THEIR EMAIL ADDRESSES - THESE GUYS DO GET IT DONE (BUT ONLINE SUPPORT AT PROMISE.COM... PAH)

  • Liv4icetime99 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 4:52 PM (in response to Bosto)

    Pegasus R6 user here who just got through a disheartening battle but WON!

    Bosto's recent post helped a ton.

     

    After reading page 14 through 27 on this forum and trying countless things to fix our Pegasus R6 issue we've encountered today, after updating to Mavericks, I made nearly no progress after hours of troubleshooting.

     

    Our setup: 2013 iMac OSX 3.2 ghz i5 and two Mac Pros all connected to a chasis and sharing with the iMac that is directly accessing the Pegasus.

    We've been using this setup for over 8 months now with virtually NO PROBLEMS. It's been awesome. We have a total of 10TB filled on our 15TB's. Using all three computers at once almost everyday.

     

    After a crash in Filemaker Pro accessing a file from the Pegasus, we could not access the Pegasus any further. It just locked up. And since it was on the iMac we knew that the other two wouldn't be able to get any better results. The two Mac Pros had just finished updating to Mavericks and the iMac had downloaded the software but we were waiting to finish with this Filemaker file before saving, exiting, and engaging the install. Since it crashed, we decided to restart everything, see if it would open, and then go from there.

     

    The restart automatically engaged Mavericks to begin installing on reboot. Understandable, we forgot it was ready to do this. We thought, no big deal.

     

    When the install was finished, the iMac opened up just fine in Mavericks. It accessed Pegusus correctly and in fact, all three computers were back to normal with fast connections. Okay, now to this Filemaker file problem. Tried to open it back up, again it failed, just locking up. Same exact way. Couldn't do anything. So, again, we had to restart all three computers (because if we just shut down the iMac it would obsructively eject from the other two without warning).

     

    On this reboot a red light appeared and the Pegasus wouldn't mount... In which all of us tensed up a bit.

    It wasn't even in disk utility. Though, I could open Promise Utility and it reported a dead drive.

     

    I then followed Bosto's steps (post above mine in all caps) and ureika, the red light disappeared and the Pegasus is mounting on all three computers.

     

    As far as the crashed Filemaker file... I think I'll count my losses here if I can't recover. Either way, not nearly as frightening as our R6 crashing.

     

     

    BUT P.S. We have everything backed up on G-Drives stored in a deep dark dungeon nowhere but a select few have the keys to. Everyone should do the same. No matter how large, fast, or up to date these drives get... They'll fail... But just speak nicely to them and they may last a little longer than usual.

     

     

     

    THANKS AGAIN BOSTO

  • Cowboooy Calculating status...
    Currently Being Moderated
    Nov 6, 2013 1:58 AM (in response to Bosto)

    Good post thanks for that, I am running my R4 with no utility software installed or updates since i purchased it, there have never been any issues related directly to the unit, it just works under mountain lion.

     

    I will follow your advice come Mavericks time

  • Bosto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2013 6:03 AM (in response to Liv4icetime99)

    Live4 and Cowb... you are very welcome. Truly though, those 3 guys at promise deserve the accolades, all I did was delve into *** could be the probelm and then make enough noise to get noticed by Promise because their online support dropped the ball and some marhetter posted that obnoxious and unusful adware saying they had no problems., and then post the solution we arrived at. I think too many post, then just see something shiny and wander off silently after they actually get a solution that just might help someone else too. I posted the same on 2 other threads as well, and there seem to be several complaining about this same issue.  I wonder if other HD users are also facing similar issues.  Too bad someone didn't post a: "Please ensure you have..." as a fitrst response.  Honestly, the R4 worked right from plug-in on Mountain Lion so I had no idea there even was a Promise utility required or firmware updates required through it.

     

    And yes, full backup with Time Machine at a good speed, and successful incrementals accomplished!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (18)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.