Skip navigation

iPhone will not sync music, movies etc since upgrading to Mavericks...

4386 Views 12 Replies Latest reply: Feb 16, 2014 7:55 PM by jypsilantis RSS Branched to a new discussion.
wrecker72 Calculating status...
Currently Being Moderated
Oct 24, 2013 6:16 PM

Upgrade to Mavericks on Tuesday.  I also upgraded to iTunes 11.1.2 and iOS 7 7.0.3.  Since this time iTunes will not sync my music movies or TV shows to my iPhone five. I have tried everything  can't find a solution. Is anyone else having this issue?

  • 1000dinge Calculating status...

    Same here, can not sync music any more. iTunes 11.1.2, iOS 7.0.3, iPhone 5 and Mavericks.

  • kaitlinkelly89 Calculating status...

    iTunes 11.1.2, iOS 7.0.3, iPhone 4s.


    I was having a **** of a time with this; after upgrading to Mavericks, not only could I not sync music anymore, but anytime I plugged my iPhone into my computer, it would spontaneously delete music. I tried restaring my computer, restarting the phone, etc. Nothing helped


    What (seems to have) fixed it is doing a full restore of the iPhone. In fact, as soon as it started downloading the restore, music simultaneously began syncing (not all of it, though). I let restore go through, then restored from backup through iTunes, and all of my music began syncing.


    It's a pain in the ***, but at least it allowed my music on. Hopefully it works for you.

  • Jonathan Rayson Calculating status...

    I was having the same syncing problem with my 4S, iTunes 11.1.2 and iOS 7.0.3. Time after time, it would hang up during the "Finishing Sync" process. No new music would be added, nor would playlists be updated.


    I went to the Music tab and unchecked "Sync Music." When I did, I got the warning asking me if I wanted all music to be removed from the device. I said yes and did another sync. After doing so, it still was getting hung (although the sync button became active again), and there were still a couple of playlists and songs left on the device (as well as an audiobook). I went to the Books tab and unchecked "Sync Audiobooks" and clicked "Apply." After the sync, once again it was hanging and the sync button became active.


    Here's what I think helped: On the iPhone, I deleted the remaining playlists and songs by swiping over them (just as you would delete an email). From then on, when doing a sync, it didn't get hung anymore...Completed the sync process very quickly.


    I then re-checked "Sync Music" and "Sync Audiobooks" on their respective tabs and re-selected the playlists and music that I wanted to sync, and everything synched as normal. All new music was added and playlists were updated upon re-uploading.

  • Jonathan Rayson Level 1 Level 1 (15 points)

    Well...last night, I thought I had it all figured out. I had several successful syncs after I used the method in my post above. Even when making changes to playlists, everything synched successfully every time.


    Tonight, however, it's back to the same crap. Hanging on "Waiting for changes..." and no changes being made. Sometimes iTunes crashes in the process.


    The only thing that seems to complete correctly is the backup, as it logs it correctly under "Latest Backup"...but ****, who knows if THAT'S even working right.


    Really frustrated, Apple. And yes...I've sent detailed iTunes feedback here and via the error box that pops up when iTunes crashes.

  • andrewfromwycombe Calculating status...

    I am also having the same issue, OSX Mavericks, Ios7.03, itunes states 'waiting for changes to be applied' but does not load music or playlists to iphone. Have tried deleting all music from iphone and now I cant get it back. Using USB - lightning cable...

  • andrewfromwycombe Level 1 Level 1 (0 points)

    Well this sorted it for me:

    From within iTunes - Iphone device tab - Music

    De-selected - 'Entire Music Library' and instead selected a single song to load onto iphone.

    Applied that which worked and added single song to iphone.

    Then changed back to Entire Library

    Click Apply

    Music Began to load successfully back onto Iphone

  • ngherbert Calculating status...

    I'm also having the same issue after I have updated iOS 7.0.3

    Any idea how to make it right again? So stressful that I couldn't sync new movie but non iTunes content.

  • Ma2PA Calculating status...

    I tried deleting all my music directly from my iPad as someone suggested on here and then synced it via a cable and over wifi seperate times. Both times I got the same playlists and exact same files that were on the ipad orginally. I had made voice notes to upload to my iPad to use for studying for a class and now my test is in 2 days and I wont be able to use them like I wanted thanks to Mavericks. I am hoping to have a full day to figure this out since two nights of 3 hours each night hasn't been enough. I suppose I will try the idea of totally reverting my iPad back to new and starting from scratch, after backing it up to the cloud that is.

  • KaymanIsland Calculating status...

    Had the same problem with my 4S.


    What worked for me:

    Instead of synchronising through the cable, I activated WiFi-Sync. Then I synchronised (it hung a couple of times but went through) and deactivated WiFi-Sync again. Since then, all syncs via cable work fine again.

  • nathaliejit Calculating status...

    Devices failed to appear in itunes and I could not wi-fi synch my iphone (4s) and ipad (2) since upgrading the imac to mavericks. Connecting devices physcally using the usb cable did work though. Only, as soon as I disconnected the cable the devices became invisible to itunes whereas this used to work prior to mavericks.


    In my case, what solved my problem after some searching was to enable the IPv6 "link-local only" mode on the imac (go to System Preferences > Network > Advanced > TCP/IP > Configure IPv6). My IPv6 default config was set to 'off' or 'disabled' since IPv6 first appeared years ago on osx.


    Restart the imac and voila!, the devices magically appeared in itunes again and I could synch music, apps, contacts, calendar etc ... It's all working flawlessly via wi-fi synch again.

  • Allan Clark Level 1 Level 1 (10 points)

    There's some related discussion over at -- we're finding that sometimes a voodoo-like action like toggling IPv6, or rebooting, can change behavior.


    I've found that there's a "refusing to notify duplicate attach" message when there is no dupe.

  • jypsilantis Level 1 Level 1 (0 points)

    I have run into the same problem. However, in my case it appears to be limited to recent movie purchases through Itunes. Not sure about timing but I think that purchases made with the current version of Itunes fail to sync, but anything that I purchased with any of the earlier versions will sync successfully.


    The problem is not isolated to iOS7. I have two old iOS6 devices and the problem occurs on those as well.


    I suspect that the latest iTunes may be the culprit...


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.