Skip navigation

Various Apple apps not working after upgrading to Mavericks

1614 Views 21 Replies Latest reply: Jan 19, 2014 12:03 PM by stingaaa RSS
1 2 Previous Next
rcworship Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 1, 2013 10:38 AM

Some time after updating to Mavericks many of the native Apple applications started acting up.

 

Immediately the App Store would only show updates and only gave the spinning "loading" circle or blank screen in "featured" or "top charts," but all is well with "categories" and "purchases." 

 

Notes gives me nothing; as soon as I click in an existing note to add text, or create a new note, it simply locks up and shows me the spinning beach ball with no end in sight.

 

Itunes seems to work generally well, but when listening to itunes radio, it'll get through about one song, but if I click the star to edit preferences (play more, don't play this), the song status bar stops and the app becomes unresponsive.

 

Messages will not open; "messages quit unexpectedly." Every attempt to reopen goes directly to the same message.

 

I have tried:

     booting to recovery console/disk utility, all disks/partitions are good, don't need repair. Checked and fixed permissions.

 

     I have deleted a couple cache/preference items suggested on another apple discussion, with no fix.

 

     I tried time machine to go "back in time" (Marty!), but for some reason the last available backup was after the upgrade. There is one instance on the 21st of      Oct, but it's purple and cannot be accessed. I chose the 25th and saw no difference.

 

     I reinstalled Mavericks twice from recovery boot without deleting anything. No dice.

 

None of these problems existed before Mavericks. My wife's 2008 MacBook Aluminum Unibody is doing fine. Iwork seems good. Safari is good. I just created a new user account and will try that then report back. HELP!!!

MacBook Pro, OS X Mavericks (10.9), Mid-2009 MacBook Pro 13" 8GB Ram
  • Joe Bailey Level 6 Level 6 (12,050 points)

    You have already started on a good troubleshooting step by creating the test account. Another test to try is booting in Safe mode in case there is an incompatible kernel extension.

  • Eric Root Level 6 Level 6 (14,000 points)

    If the problem is still there, try booting into the Safe Mode using your normal account.  Disconnect all peripherals except those needed for the test. Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application un-installer. For each disable/delete, you will need to restart if you don't do them all at once.

                   

    Safe Mode

     

    Safe Mode - About

  • Eric Root Level 6 Level 6 (14,000 points)

    Make sure you got all of the files related to Avast removed,

     

    Avast! Uninstall

     

    Please post the error messages using copy and paste. Screen shots can be hard to see.