Skip navigation

Can I install Snow Leopard on the new Mac Mini

161297 Views 657 Replies Latest reply: Apr 13, 2014 12:43 AM by Mea Culpa RSS
  • mesa3077boogie Calculating status...
    Currently Being Moderated
    Aug 23, 2013 8:33 AM (in response to Jesionblue)

    I got your reply I'm at work now so give me a while and I'll get back with you later.

  • Jesionblue Calculating status...

    hey

    I asume you're located in USA and I live in Ireland(Dublin) so my friend who's network engineer(microsoft/windows minded unfortunately;) said he can get you his server FTP account to transfer those files if you know how it works!? otherwise I've got friends in Chicago and they can manage to mail you jump drive or sd card and some funds to mail it back to me if that's Ok!?

    thanks again for your help! I really appreciate it!

  • markfromsherman oaks Calculating status...
    Currently Being Moderated
    Aug 23, 2013 9:12 AM (in response to Jesionblue)

    If the 10.7 does fork for you, let me know. And can upload a DMG for you.

  • Jesionblue Level 1 Level 1 (0 points)

    10.7 should work for me;) what's the way to upload it or download from my end?

    get back to me please and thanks a lot for your help

  • mesa3077boogie Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 23, 2013 5:55 PM (in response to Jesionblue)

    I'm not sure how Pro Tools or Mac savvy you are based off of your last post so I will start with some of the basics and help you make some clarity out of all of it.

     

    FYI pro tools 9.0.6 is fully qualified to run on Lion up to version 10. 7. 4. Here is the proof:

    ____________________________________________________________________

    http://avid.force.com/pkb/articles/en_US/download/en428011

    Pro Tools 9.0.6 Update

    November 29, 2011

    For Pro Tools 9.0 and Pro Tools HD 9.0 on Mac OS X and Windows

    The updates available for download on this page require previous installation of Pro Tools 9 software and your Pro Tools 9 iLok license. See below for more information.

    Pro Tools 9.0.6 is an officially qualified and recommended update for all Pro Tools 9 and Pro Tools HD 9 users on Mac OS X 10.6 (Snow Leopard) through 10.7.4 (Lion), and Windows 7.

    ______________________________________________________________________

     

    Frst off let me start by saying that I purchased the 2011 Mac Mini to be a dedicated Pro Tools machine.
    Seeing that every major label studio runs Pro Tools off of a Mac and avid even seeming to prefer Mac OSX , made purchasing the 2011 Mac Mini a no brainer.


    I would highly recommend you focus on running Pro Tools 9 on lion vs running Pro Tools 9 on Snow Leopard.


    As you might know getting a solid running Pro Tools system on a Mac is half of the trouble in itself. Most novice users will spend more time setting up and tweaking their system than they will ever writing or recording actual music. Seasoned pro tools users realize this and have come to the conclusion that once you get your system to run solid you just stay put! You don't make any updates with Pro Tools or Mac for a long time as the consequences of doing so may cost you lots of time and frustration.


    With that being said let me tell you that I spent at least 6 months trying to make a solid running pro tools 9 system on this 2011 Mac MinI. I succeeded in installing Snow Leopard on my 2011 Mac Mini several different ways. and let me say it very clearly that none of them ran well.


    Moving on. if you read through the previous posts you will find that there is a series of steps that you need to take in order to get snow leopard to run on your 2011 Mac Mini. Keep reading, and you will find that the New Found Glory package installer has summed up all of those rigorous steps into one simple installer file making it easier for the rest of us trying to accomplish installing Snow Leopard on the mini.

     

    One cannot merely "install a .dmg file" of an earlier version of OSX on your machine to revert to a previous OSX version. This is something that apple has been doing for as long as i have been using macs and its bogus. They claim that their updates, update the hardware as well as the operating system and not just the OS and thats supposedly why you cant just revert.  That just BS, and their are working work arounds. The actual reason is that apple wants to keep things constantly moving forward and updating OSX so you have to constantly purchase new hardware if you ever want to stay on top of the game. Another reason to stay put once you get pro tools up and running.

     

    Familiarize your self with the disk utility in OSX. With disk utility you can clone your OSX  versions and use them as future backups.

     

    Heres an example: My 2011 mini was born with 10.7.4. I used disk utility to make a 10GB partition on the second internal drive of the mac mini. (You can actually use any drive for this) The, I re-booted , held option and booted from the "recovery" partition. (The recovery partition took the place of OSX install DVD's) Then I selected the "install lion" option and chose the 10GB partition that I created. Now I have a version of 10.7.4 on a partition that I could either clone onto my main drive in the future (using disk utility) or boot from it , and use for experimentation purposes. This way if you dont like 10.7.5 or 10.8.X or its not sitting well with ProTools you can simply start fresh and re clone 10.7.4. I now make a new partition for every OSX update now.

     

    You doing this would have really helped in your situation.

     

    I am offering to clone 10.7.4 onto an external drive and send it to you so you can clone it onto to your machine, does that make sense?

     

    I also cloned 10.6.8 onto a partition as well. But with 10.6.8, I already set up a user name with it so when you boot from it, you will log right in. Whereas with the 10.7.4 partition it would be like booting from a brand new machine that would need to be set up,,

     

    You are still welcome to nstall SL as per this thread.

     

    Yes I am in the US. I can purchase a jump drive or SD card , probably aroung 20GB and you can just paypal the amount and I will mail to you. The smallest partition for SL or Lion is like 7GB btw. 

     

    Theres no file sharing options that I know of that can transfer a file of this size but there may be other options ofther than just the mail..  Im not sure if the image of SL or Lion is able to made into a torrent file that can then be made back into a disk image after transferred that can be booted from on your end. But i can do some research. If that was possible I would just post  the image  of 10.6.8 publically for other users and then they could just clone it onto their 2011 mini to avoid all of the hassle of fooling with the kexts.. 

     

    Sending you an image is only possible because we share the same machine, so all the kexts and drivers are the same..

     

    Let me know if you have questions.

     

    mesa3077boogie

  • Jesionblue Level 1 Level 1 (0 points)

    thank you very much for clarify few things! I really apreciate your help and professionalism!

    Im a beginner sound engineer and pro tools operator as well and mac user for last 3 years:) I can transfer some money to your paypal no problem at all! Im new to this apple-discussions and can't see if there's a chance to send a private message!? so, here is my email jesion@interia.eu to exchange paypal details

    thanks a lot! you're life saver!:)

  • mesa3077boogie Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 24, 2013 10:04 AM (in response to Jesionblue)

    Hey no problem at all man I will get back with you later by email.

     

    And to the others following this thread, sorry to vwere so far off the original topic.

  • leandrodafontoura Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2013 6:58 AM (in response to John Fair)

    Friends, has anyone come up with a way of installing Snow Leopard on a 2012 MacMini already? Server or normal version?....Currently I own the 2012 MacMini with Mountain Lion, a 2010 MacMini and a 2010 white macbook, both running Snow Leoapard and I have all DVDs..

     

    If not possible, I might try to get a refurbed 2011 mini, but I would like to have this in the 2012 model.

  • iXod Calculating status...

    I've been running SL on my 2011 for 2 years. Today is the first time I've had to reinstall SL and restore from Time Machine backup (located on an external USB drive).

     

    Because the 2011 mini can't boot the SL Install DVD (the 2011 can't boot anything earlier than 6.3 if I recall), I put the 2011 into Targer Disk Mode and connected it to a 2006 mini via Firewire. I then booted the Install DVD and did a clean install.

     

    When it comes time to restore from Time Machine backup, I get the message "This backup can't be used because it is from another computer." Remember, I'm running the 2006 mini and trying to restore the 2011 image to the 2011's boot drive via TDM.

     

    Normally I'd boot the install DVD on the 2011 but this can't be done (see above).

     

    How does one resotre a TM backup to the 2011 mini under SL?

     

    Thanks,

    iX

  • timjomartin Calculating status...
    Currently Being Moderated
    Nov 1, 2013 1:26 AM (in response to iXod)

    It seems there are two problems wrapped here.

     

    Booting

    Restoring ™

     

    On Restoring - I’m not a ™Time Machine user - so I cannot advise - I rotate bootable clones for testing, backup & security

     

    I’m running a mid-2011 Dual boot system with 2 separate installs of legacy Snow Leopard on the built in HD and current Mavericks(was L then ML) on an external 2TB HD - Thunderbolt connected Seagate DockPlus adaptor. I partitioned the internal drive before installing Snow Leopard 750GB threeway-split 630/100/12 for 2 Snow Leopard installations and a hidden emergency/recovery partition. (My Thunderbolt 2TB external also has a 12 GB emergency/recovery partition).

     

    This is my legacy of cautious (fully successful) exploration of Snow Leopard on this machine - but it gives me multiple boot/recovery options - I have also created bootable installers on USB sticks for Lion, Mountain Lion and Mavericks and I have SL DVD and the Apple USB Optical external.

     

    Do let us all know how you get on many people look to this thread for advice not readily available elsewhere. Apple NB!

     

    Tim

  • iXod Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 10:54 AM (in response to timjomartin)

    So, Tim, you do not use TM at all? Do you use any kind of hourly backup? Or just clones (daily?)?

     

    Someone before me must have run into this conundrum...

     

    iX

  • cruttis Level 1 Level 1 (0 points)

    All over Apple discussions there are may disgruntled Mac Users, used to the veracity of the "Mac Platform,' having minimal interest in iOSx!

     

    I have been using L/ML/Mavs on FW running SL internal, my preference. Mavs is 'nice?' It integrates all that Gen ? wants, indoctrinated to text to each other at parties instead on conversing. BUT sells!

     

    Accidently I came here -- many other threads are relevant.

     

    IMHO: providing your Mac is based on Sandy Bridge an 'upgrade' Snow Leopard (faster only?) is viable as dedicated posters here  have verified.

     

    If  your Mac is Ivy-Bridge or Haswell it will not work, IMHO. Hardware changes.

     

    I find it amazing that 100,000 users requiring Rosetta and at $50/payment for it has been not thought of by Apple. Maybe just, 'Tea-money?' I do not know.

     

    But, again, IMHO, if getting a 2011 Mac Mini to work at some 3 times the speed using Snow Leopard, there is something wrong with Lion et-alia, apart from dropping Rosetta?

     

    By doing the things that many people have done herein it shows that the Mac platform needs improvement inasfar as speed? IMHO it will not happen as iOS = $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

     

    Some Mac users have now been forced into, 'kext-manipulation' et-alia and it will be not long before they depart to the, 'Hackintosh,' to get the best performance required noting that Ivy-Haswell offers minimal USER improvements, apart from MacBook battery-life, but is used by Apple to sell iOS.

     

    Just my HO.

  • MlchaelLAX Level 4 Level 4 (1,530 points)
    Currently Being Moderated
    Nov 12, 2013 5:53 AM (in response to cruttis)

    cruttis wrote:

     

    I find it amazing that 100,000 users requiring Rosetta and at $50/payment for it has been not thought of by Apple. Maybe just, 'Tea-money?' I do not know.

    Apple's license to the underlying technology to Rosetta expired with the release of OS X Lion.  This technology is now owned by IBM so it is unlikely that Apple could have relicensed it at a reasonable price, even if they wanted to.

  • cruttis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2013 4:17 AM (in response to MlchaelLAX)

    Thank you Michael. Yes, a long time ago I used Parallels attempting to configure for SL. Apple had banned it! I used the Server and a hacked SL 10.7.8 OS and got both functioning. Never tried Mavs.

     

    I understand licensing but still ask Apple why they support Windows QT for embedded MIDI yet no support is offered for the Mac Platform that depends on Rosetta?

     

    Yes, I can add webpages and invoke Parallels to check embedded MIDI's functionality. Normally termed, 'a Workaround.'

     

    I have been a, 'Fanboi,' for decades. My iPad is unused, maybe I am too old to understand how useful it is?

     

    The way things are going I believe anyone wanting an Apple DT will find these items slowly becoming unavailable, just like Rosetta.

     

    It's called, 'Evolution,' perhaps?

     

    Most Advanced Version Excluding Rosetta, Ipad Compatible, Kludgy & Sinister?

     

    Acronyms often display the intention??

  • newfoundglory Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 21, 2013 5:24 AM (in response to cruttis)

    Since discovering a fix for this some time ago (back on page 19), I very recently re-installed 10.6.8 on my 2011 MacBook Pro - at the time I did this I discovered why I was able to get 10.6.8 working so well on the 2011 Mini.

     

    There are a few extra packages (eg thunderbolt updates, which contain required kext's), which I was not aware of at the time which are specific to certain Mac models.  These packages are available for and install on the MacBook Pro, but obviously not on the Mac mini 2011.  Then when I cloned from MBP to Mini, everything just worked.  I then created the update package which was posted on here without really knowing where these newer updated drivers had come from.  I could not find them in any of the larger OS updates.

     

    If you try and install these extra required Apple updates *manually* on the Mac mini it wont work without some effort, as they were designed for certain mac models, which doesnt include the 2011 mini.  The updates can be integrated in Mac OS X before installation.

     

    All the tools and bits you need to create a full functioning Mac Mini 2011 image, from an original 10.6 DVD for example, are actually available free from Apple.  AND, the best bit is you dont need a Macbook Pro to do it!  Anyone can create a clean image for the Mac mini 2011 using any Mac which already has 10.6.8 installed on it.

     

    All you really need is System Image Utiltity, which is included as part of the free Server Admin Tools 10.6.8 from Apple.  You must install this only on a mac running 10.6.8.  SIU is cabable of creating an integrated Mac OS X image with all the component parts and updates you want already baked-in.  It is commonly used by sys admins to create updated Mac OS X images for deployment in large enterprise environments.

     

    At the end, you get a never-booted-before clean image and installer of Mac OS X with everything working for the 2011 mini.  You can just install it on your 2011 Mini with no further modifications.

     

    Could detail the exact steps if anyone is still doing this, as I guess you could get a bit lost in the process if you arent familar with SIU, disk utility and package maker.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (19)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.