Skip navigation

Mail unusable in Mavericks

874 Views 11 Replies Latest reply: Nov 28, 2013 7:11 AM by avmatso RSS
cryptorchid20 Calculating status...
Currently Being Moderated
Oct 29, 2013 5:35 AM

Hello everyone,

 

Since upgrading to Mavericks I cannot use mail. I have tried all the suggesions I can find on the board but neither works (moving stuff from V2 folder, deleting colorpanes in the terminal and turning on all mail in gmail).

 

My symptoms.... takes ages to open mail (sometimes an hour) and even when it does open constantly hangs. When mail is open it eats around 100 to 110% cpu. When I try to close it the only suceesful way I have found without freezing my system is force quit.

 

I have 2 gmail accounts, another imap and an iCloud all as different mailboxes.

 

Any ideas how to sort it? Any news on apple releasing a fix for it?

 

Its a 27inch 2.66ghz i5 iMac from 2010 with 12gb ram. I'm not installing it onto my laptop until I know it wont kill it.

 

Thanks

  • toldor Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 29, 2013 5:38 AM (in response to cryptorchid20)

    110% cpu? LOL Anyway, glad to read you looked in several threads. I remember I read something "internet accounts" pref.pane and 100% CPU. It was because the .plist-file takes up to 60MB in size. Maybe it is related to this.

  • jeremymaxwell Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 2, 2013 12:29 PM (in response to cryptorchid20)

    Yes, I'm having very similar problems. Mail constantly hangs or is unresponsive forcing me to force quit and reopen multiple times. Old drafts suddenly appeared in my drafts folders. If I try to open preferences, I am met with a spinning beach ball for 1-2 minutes, or until I force quit.  Huge percentage of memory is used by Mail when it looks idle. Any news of when an update may be coming to fix this ?

  • Csound1 Level 7 Level 7 (32,360 points)
    Currently Being Moderated
    Nov 2, 2013 12:31 PM (in response to cryptorchid20)

    110% is available, 200  is possible (if you have a 2 core CPU), even 400 is available if you have a 4 core CPU (i7)

  • disguise Level 2 Level 2 (330 points)
    Currently Being Moderated
    Nov 2, 2013 12:33 PM (in response to jeremymaxwell)

    I don't know if this is possible, but I'd try disabling iCloud to see if that's the problem.

  • Houkes Calculating status...
    Currently Being Moderated
    Nov 11, 2013 4:24 AM (in response to cryptorchid20)

    I have the same issue, with roughly the same configuration. I can not use Mail anymore without it hanging my entire system to the point that both CPU and RAM are 100% used. This is áfter the update Apple issued last week, so I don't know what's happening.

     

    Does anybody have an idea how I would go about resetting this and trying again, without having to reinstall my entire OS? Did I miss any setting changes?

  • FenceStrider Calculating status...
    Currently Being Moderated
    Nov 12, 2013 6:59 AM (in response to Houkes)

    Try this...

     

    My problem was caused by dodgy entries in the accounts.plist file in my User Library folder. It appears that either when I upgraded to Mavericks this file gained hundreds (possibly thousands) of spurious entries, or maybe these entries were in there before but previously the OSX/Mail combination was more tolerant. When I removed these the problem with Mail disappeared. Here’s what I did….

     

    1> Make the user Library folder visible - in Mavericks this is a lot easier than Lion/Mountain Lion. Simply open up your user directory in Finder, select menu View>Show View Options, and select “Show Library Folder”

    2> Navigate through username>Library>Mail>V2>MailData and select the Accounts.plist file. If this file is multiple megabytes (mine was 40+mb) then this is likely the cause of your problem (once sorted mine ended up at 19k in size!)

    3> To be safe, make a copy of this file (I placed the copy on my desktop).

    4> Using your chosen text editor (I used Text Wrangler but I’m sure TextEdit would work just fine) open the Accounts.plist in the MailData folder (not your backup copy) and take a look. If it’s the same as me you will find hundreds and hundreds of entries for the same mailbox repeated in there. Mine was an old MSN mailbox that I never use any more (I’ve seen in other forums that other Hotmail type accounts also seem to be the culprits in this context). There will likely be two lots of repeated data, one in the XML “DeliveryAccounts” <array> section, and one lot in the “MailAccounts” <array> section.

    5> Delete (keeping in mind the need to select the XML sections correctly from <dict> to </dict> completely) all those extra entries that you found, keeping the mail accounts you do need, in the XML and save the file.

    6> Mail should open up nice and fast again and not eat your system

    7> If this did not work, and causes problems because of over eager deleting in <5> you can replace your broken Accounts.plist file with your backup and try again.

  • Houkes Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2013 1:15 PM (in response to FenceStrider)

    Thank you so much, FenceStrider. This is EXACTLY what was wrong. The file was 42 MB, and I got it down to 10kb with your instructions. The culprit with me was Hotmail, and a little plugin I installed 2 years ago called 'HTTPMail'. Totally forgot about that, since I don't even use Hotmail anymore.

     

    For anyone looking to remove this plugin, go to /Users/<username>/Library/Mail/Mail Lost+Found/Bundles and delete 'httpmail.mailbundle. Restart Mail and it'll work fine. 

     

    Thank you again for this detailed reply, and I hope this is of help to others!

  • DavidAMcL Calculating status...
    Currently Being Moderated
    Nov 15, 2013 8:31 PM (in response to FenceStrider)

    Thanks very much, FenceStrider -- your instructions seem to help.  I only had less than half a dozen excess entries, but deleting them seemed to bring performance back to an acceptable level.

  • avmatso Calculating status...
    Currently Being Moderated
    Nov 28, 2013 7:11 AM (in response to cryptorchid20)

    FenceStrider thank you. I had exactly the same problem. My Accounts.plist was 42 MB large and went down to 18K. Cheers!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.