1 Reply Latest reply: Nov 2, 2013 4:39 PM by Klaus1 Branched to a new discussion.
Joshua.Slator Level 1 Level 1 (0 points)

I have updates my ipad to iOS7, but now it says on my mac (10.5.8) that i hav eto have Itunes 11.1 or later which i can't get. Would of been nice to have had some kind of compatability as I use the 2 devices in tandem regularily. Is there anything i can do without purchasing any software?


MacBook, Mac OS X (10.5.8), using with ipad2 with IOS7