Skip navigation

Undo change in Safari behavior with pdfs

462 Views 2 Replies Latest reply: Dec 19, 2013 6:06 AM by BergerT RSS
rpdrake Calculating status...
Currently Being Moderated
Nov 3, 2013 9:00 AM

There has been a recent change in the behavior of Safari with pdf files. 

 

Since I often download large pdf's, I prefer not to see them in Safari, which has been pretty clunky for this purpose.  In addition, these files are often publications for research so I want the files on disk anyway. 

 

So for several years I have set Safari to automatically download any pdf file I click on. I'm pretty sure I did this with this command in Terminal:

 

defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

 

As of a few weeks ago, Safari quit autodownloading the pdf files and started displaying ASCI gibberish instead.  This was probably after an upgrade.  Undoing the setting with

 

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

 

returns the basic behavior that the file comes up in Safari unless I use Control-click to do something else.  But that does not always work, in particular on some secure websites.  So now it takes several extra steps (print to pdf) to get back to what I want -- a certain file on my disk. 

 

Does anybody know how to get the current version of Safari (7.0) on Mac OS 10.9 to autodownload pdfs?  (The problem existed with OS 10.8 but I upgraded in the hope of a solution, which did not occur.)

 

Paul

Mac Pro, OS X Mavericks (10.9)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.