Skip navigation

New Macbook Air - wifi connectivity problems

444091 Views 2,047 Replies Latest reply: Apr 14, 2014 1:09 PM by Garryatco RSS Branched to a new discussion.
  • infrid Calculating status...
    Currently Being Moderated
    Oct 27, 2013 9:53 AM (in response to andQlimax)

    It seems to me that the grip of death is not only restricted to iphones.

     

    I've had non-stop problem with wifi interference over they years. Just seems apple are getting so good at ******* up the wifi that they can now worsen it with software updates.

     

    So very very sad. I used to herald apple as a bastion as quality; truth is that despite having the best kit, the level of quality is dropping rapidly. If they continue like this, my next macs will all be hackintoshes.

  • Cloudi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2013 2:25 PM (in response to infrid)

    Hi All!

     

    I haven't had much to say until I upgraded to Mavericks.

     

    To recap on my story:  I bought the new 2013 13" MBA in June (i7, 256Gb, 8Gb) and it's been perfect including with all the upgrades appart form one thing (BTW, see my posts for the details, but I have used my MBA's WiFi in dozens of different locations). My only 'problem' was that to keep my pings down to my local router, I've had to roll back to the *22 Broadcom firmware.  Having said that, pings to areal places like Google and the BBC are always brill whichever Broadcom Firmware I have - and, yes, I can always stream video superbly over longer distances than before using an ac Router whichever Broadcom firmware.

     

    So, now I have moved to Mavericks.........

     

    Well, I can report that it's absolutely fine!  I have obvioulsy not tried many different WiFi locations - when I have, I'll report again.

     

    I can say that the Broadcom firmware that came with Mavericks gave the worst pings ever to my local router, but try as I might, I have been unable to detect a 'consequence' arising from that. Video, big file downloads, multiple little file downloads, all OK.

     

    Anyway, I have once again swapped back to the *22 Broadcom Firmware (which worked very nicely, although I did have to fix the changed permissions). Now my pings to my local router are suitably short again (1 or 2 ms).

     

    Outcome: All is fine.

     

    I don't know what this all means.  I'm as confused as ever - it seems Apple are too....

     

    I continue to make wishes for those with a horrible June MBA story.

     

    BTW and in support of the new Air and Maveriskcs (those reading this thread need some good news, so bear with me):

     

    1. My battery life is a little better with Mavericks (so now it's truely unbelivebale).

    2. Waking from sleep and going to sleep is a little faster in Maveriks.

    3. Start-up from cold is perhaps 10 seconds slower with Mavericks - don't know why.

    4. Full shut-down is as fast as ever with the solid state drive.

    5. Appart from the published changes and additions (is there really 200 of them?), I can't say the upgrade has made any changes to my user experience - it didn't even cost me anything.....

  • Fujishu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2013 3:02 PM (in response to Cloudi)

    Cloudi,

     

    I"d been waiting for an update from you! Glad things are still pretty good.

     

    I am an amateur with little Apple-product knowledge, but the thought occurred to me: are the worse/irregular pings with the new driver in Mavericks somehow related to efforts being made to increase battery life? (Apple must know that many MBA users have found the .22 driver to be preferable for ping speed, so why is this driver not being reinstated in the software?)

     

    I am still using the original June software with no upgrades or patches. I still have no problems that I can see apart from a strange WORD cursor-display problem (a Haswell image-driver issue?) which has been seen by many other MBA users--and other new Haswell laptops, I believe. (The cursor all but disappears from view when one attempts to move into a line of Italicized text.)

     

    Thank you.

  • Oyinbo71 Calculating status...
    Currently Being Moderated
    Oct 29, 2013 12:33 AM (in response to Fujishu)

    Okay, a post-Mavericks update.  My problem was beyond mere pings, my new MBA would not stay connected to WiFi (including a new 802.11ac Time Capsule) for more than a couple of hours.  When I would sleep the computer and then wake it, it would NEVER (100% of the time) re-connect to any WiFi without a reboot.  It would just search and search and never connect.  Nothing could make it come back except a reboot.

     

    I went to the Apple store and a genius tested my hardware and ID'd a bad WiFi card almost immediately. Yay! Getting the card replaced was bit more of a hassle than I would expect from Apple, but it was covered under warranty.  After it was installed...SAME PROBLEM.  Boooooooo...  I hated this machine.

     

    And then I updated to Mavericks, and so far I've slept and woken the machine a couple of dozen times, and haven't had to reboot in over four days.  It's a Mavericks miracle!  At least so far.  Stay tuned.

  • Miti101 Calculating status...
    Currently Being Moderated
    Oct 29, 2013 1:00 AM (in response to vhkim)

    give up

  • nixwizard Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 1:36 AM (in response to Miti101)

    I had no wifi problems in ML with my 2013 13" MBA. However, after updating to Maverics, when resuming from sleep, the computer fails to connect to my wifi (or find any wifi for matter) without exception. I always have to toggle wifi off and then back on. Apple, fix this ASAP!

  • breyn999 Calculating status...
    Currently Being Moderated
    Oct 29, 2013 5:32 AM (in response to vhkim)

    I  have a mid 2013 MBA and also 802.11AC base station.  Ever since I got it and even with the maverick update the wifi connection seems to lock up.  I need to got to the URL line and press enter or go to the wifi icon on the tool bar to get it to reconnect.  It is quite annoying.  It seems to be getting worse.  II haven't contacted apple support yet.  After reading this post, I don't think it will do any good.

  • KlaatuBarada Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 29, 2013 5:56 AM (in response to breyn999)

    breyn999,

     

    Do not let the posts on this forum give you the impresion that all MBAs are having problems.  I can tell you that I have tested three 2013 MBAs on my Airport Extreme 802.11AC base station as well as Airport Extreme 801.11n, fifth gen.  I have never experienced a delay or disconnect.

     

    Granted I do see an occasional ping delay but this is not affecting performance.

     

    Remember the only people that post are limited few that have problems.

    MacBook Air, OS X Mavericks (10.9)
  • bcode Calculating status...
    Currently Being Moderated
    Oct 29, 2013 7:55 PM (in response to vhkim)

    Hi,

     

    I had a specific story about my Mid-13 MBA. Just after I got my (custom) MBA (13/512GB/i7/1.7GHz/8GB) in July, I experienced problems with the power subsystem. After I contacted local AppleStore GeniusBar several times, they finally recognized the problem and decided to repair my MBA by replacing everything except SSD and battery.

     

    With new MBA, I started to get wifi problems with all the access points i just used in the past. In particular, now I loose connection also with good SNR figures (around 30 db). This means that being back a couple of walls will drop my connection. Since I did not have this problem with MBA before the repairing (and I still don't have it with my iPad and other computers), I guess this problem is related to specific MBA hw production units.

     

    Now I am going to update OSX to Mavericks, but I don't think I will fix the problem.

     

    It is very disappointing how Apple is taking care of this issue, especially considering the top price of this machine and that wifi is key feature for ultrabooks such as MBA!!!

     

    My location is south of Italy.

  • bcode Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 8:01 PM (in response to KlaatuBarada)

    @KlaatuBarada: I am glad you had a good experience with your MBA, so ejoy it and let customers frustrated by this relevant and still unsolved problem to express all their disappointement for Apple customer care, and to push the company to admit there is an engineering error and to solve it!!

  • bwat47 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 9:07 PM (in response to vhkim)

    Wireless latency is looking great for me in mavericks on my MBA 2013, no longer getting poor pingtest results and high jitter like I did in ML. Ran this with no active downloads running in background:

     

    http://www.pingtest.net/result/88564167.png

     

    And I've yet to have issues connecting to any AP's or have any connections drop.

  • xgregious Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 9:39 PM (in response to bcode)

    Hi All,

     

    I'm a new MBA owner - as of about a month now.  This is my 2nd Mac - first was MBP that was legendary - never a problem at all for 2+ years. I, too am having latency + WiFi dropping issues with my new MBA. I followed instrructions to roll back wifi firmware to the '22' version, and now everything works great. Naturally, I would like to be on the latest version, but... I don't see that I am missing anything with this version.  So, the question is: What exactly am I missing with this driver - or am I missing anything at all?  ...and if that is all it takes to solve the issues, why all the fuss (aside from the principle of it all....)?

     

    FWIW...  I don't recall having any issues until I upgraded to Mavericks, then the wifi drops were fairly regular.  No problems whatsoever after the roll-back.  Thanks all for the useful discussion and tips!

    MacBook Air (13-inch Mid 2013), OS X Mavericks (10.9)
  • SMT990 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2013 10:52 PM (in response to Cloudi)

    Cold boot shouldn't take that long.  I suggest resetting the nvram (command + option + P + R) during boot.

  • vincent44500 Calculating status...
    Currently Being Moderated
    Oct 30, 2013 1:44 AM (in response to andQlimax)

    For me, with mountain Lion, the first connection worked fine, and the connectivity drops randomly. I downloaded all the update, but the problem was still here.

    With Mavericks, i thought the problem was fixed, but it appeared again randomly....

    Still waiting for the good update....

  • jguzman12 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2013 1:39 PM (in response to vhkim)

    i tried everything... 22, 35 and the new maverick's driver and my wifi still drops, with 22 driver pings are better but i still having random connection lags with safari and also using chrome.

    i'll be waiting for the real fix apple... or you're so busy with iphone 6 and ios 8??

     

    APPLE: ALL MACBOOK AIR 2013 USERS NEED A REAL FIX, MAVERICKS 10.9.1 OR THE 2.0 WIFI FIX!!!!!!

     

    And all the users with wifi issues in MBA don't let this thread die!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (72)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.