14 Replies Latest reply: Nov 22, 2013 6:58 AM by Perpetually Perplexed
agiuliano Level 1 Level 1 (0 points)

Playing around with Server 3 for a couple of days now.  Got Open Directory, Network Accounts, Profile Manager working.  Trying to set up Messages service but user's aren't able to authenticate for some reason.  Calendar service works, but when a network user tries to use Messages, am prompted to enter password, "Messages can't log in to user@server.domain.com because your login ID or password is incorrect."

 

Any insight on what could be causing this?  Thanks in advance.


MacBook Pro, OS X Server
  • 1. Re: Can't Authenticate to Messages
    bobgeo Level 1 Level 1 (25 points)

    I am having this exact same problem; trying everything and nothing is helping. Does anybody have any ideas?

  • 2. Re: Can't Authenticate to Messages
    bobgeo Level 1 Level 1 (25 points)

    I fixed it, but it is a somewhat of a pain, not GUI goodness. Basically, you need to modify the sm.xml file it is located in the following area:

     

    Run the command "sudo serveradmin settings jabber" in Terminal and you will see the path. It is Library>Server>Messages>Jabberd

     

    In the sm.xml file, look for yourserver.local and change it to yourserver.domain.com or whatever and it should work then.

     

    This has been an issue for a while - I recall I had to do the same thing in 10.8.

  • 3. Re: Can't Authenticate to Messages
    agiuliano Level 1 Level 1 (0 points)

    Hmm.  Thanks for the response, but this didn't work for me.  I changed one instance of "mycomputer.local" to "myserver.mydomain.com", under where it says:

     

    ....If not set, the SM id is used. -->

    <id>myserver.mydomain.com</id>

     

    Did you have to change it in more than one spot in the file?

  • 4. Re: Can't Authenticate to Messages
    bobgeo Level 1 Level 1 (25 points)

    I changed it in only that 1 spot; then I ran the disk utility and fixed permissions and it worked fine for me.

     

    Do you see anything odd when you run "sudo serveradmin settings jabber"?

  • 5. Re: Can't Authenticate to Messages
    agiuliano Level 1 Level 1 (0 points)

    I'm not super familiar with what is normal there or not, but if I had to take a stab I would say that both lines describing a host lists mycomputer.local rather than server.domain.com.  Those two lines are:

     

    jabber:hostsCommaDelimitedString = "administrators-macbook-pro.local"

    jabber:hosts:_array_index:0 = "administrators-macbook-pro.local"

     

    Actually now that I point that out I changed my computer name to "MacBook Pro Server".  Maybe this has something to do with it?

  • 6. Re: Can't Authenticate to Messages
    bobgeo Level 1 Level 1 (25 points)

    Yes, I had that exact same problem. I did a clean re-install and did the following in order and it cleared those up.

     

    There is an article in these discussions on how to change those exact 2 values which I detail below what I did in terms of a clean re-install while being careful of the order I started things up. Here is what I did:

     

    1.)  Did a clean install from a USB stick that I created.

    2.)  First thing then after re-install and before I installed Server 3.0, I changed the name of the computer to its name I wanted on the network.

    3.)  Installed server and then before doing anything else, I changed the host name to the FQDN.

    4.)  Then, I started up the services and they all read the FQDN fine.

     

     

    Now, to fix using commands and not do a clean re-install, the first error can be fixed by:

     

    Before doing these - stop the Messages service in the GUI; then...

     

    sudo serveradmin stop jabber

    sudo serveradmin settings jabber:hostsCommaDelimitedString = "hostname.domainname.com,domainname.com"

    sudo serveradmin start jabber

     

    (you can just make the hostname ""hostname.domainname.com"

     

    The second one can be fixed by:

     

    sudo serveradmin stop jabber

    sudo serveradmin settings jabber jabber:hosts:_array_index:0 = “servername.domain.co.nz"

    sudo serveradmin start jabber

     

    Then restart in the GUI, maybe do a permissions fix, throw in a restart for grins and Bobs your uncle.

  • 7. Re: Can't Authenticate to Messages
    agiuliano Level 1 Level 1 (0 points)

    Awesome, we're getting there.  I don't mind doing a fresh install as I'm just playing around with it at this point, however, the first command works

     

    sudo serveradmin settings jabber:hostsCommaDelimitedString = "hostname.domainname.com,domainname.com"

     

    The second command doesn't,

     

    sudo serveradmin settings jabber jabber:hosts:_array_index:0 = “servername.domain.co.nz"

     

    I do also realize there is probably a typo there with the word jabber added twice, but even so, when I enter "sudo serveradmin settings jabber:hosts:_array_index:0 = “server.domain.com", it's just returning

     

    "jabber:hosts:_array_index:0 = "administrators-macbook-pro.local", the original value.

     

    I'll probably proceed with the fresh install and be mindful of the order in which I make the changes like you suggested.  Thanks for all the help you're my hero!

  • 8. Re: Can't Authenticate to Messages
    bobgeo Level 1 Level 1 (25 points)

    I had the exact same thing happen to me and I looked on the net and found another similar line that seemed to work. I just searched around, but they all look the same, in the form:

     

     

    sudo serveradmin settings jabber jabber:hosts:_array_index:0 = "myfqdn.server.name"

     

    Maybe I did a restart before I tried it again, but I did get either the above command to work, or something very similar to it, and it did change the FQDN, but not the first time.

     

    Trying to remember...!!!! ;-)

  • 9. Re: Can't Authenticate to Messages
    agiuliano Level 1 Level 1 (0 points)

    Okay so I did a fresh install.  This time I didn't bother changing the computer name at all.  Opened server, changed the host name and went straight to termainl to check jabber settings and it's still listing "administrators-macbook-pro.local" on those two lines for the domain name.  I guess I'll have keep trying to change them with the like commands you suggested.

  • 10. Re: Can't Authenticate to Messages
    agiuliano Level 1 Level 1 (0 points)

    Sorry I never updated this.  This ended up working.  I had to restart before the second terminal command would take.  It was "sudo serveradmin settings jabber:hosts:_array_index:0 = "myfqdn.server.name" (without the second instance of the word "jabber" in there).

     

    Thanks Bob for all the help.  I have a couple other unanswered threads you should check out if you have a few minutes

  • 11. Re: Can't Authenticate to Messages
    jaydisc Level 4 Level 4 (1,400 points)

    My experience (3.0.1) is just that the serveradmin command is a bit busted for fixing this (I've filed a bug). I just did a find in the config files for the .local name (ignoring the .bak files):

     

    grep -r server.local . | grep -v .bak
    

     

    And then went into each of those files and did a find and replace.

     

    If you want multi-host support, it's a bit more tricky, but possible.

  • 12. Re: Can't Authenticate to Messages
    Perpetually Perplexed Level 1 Level 1 (0 points)

    Am now rather baffeled as

     

    1.  it reverts the host arrary every time I try to reset and

    2. I can not access the mxl file required as it wont give me permission

     

    Any bright ideas

  • 13. Re: Can't Authenticate to Messages
    bobgeo Level 1 Level 1 (25 points)

    You have to drag a copy of the sm.xml file out and modify the copy; and then copy it back into the directory. Next, change the names of the files appropriately; keeping the old one for backup and call it something different like "sm_old.xml".

  • 14. Re: Can't Authenticate to Messages
    Perpetually Perplexed Level 1 Level 1 (0 points)

    thanks for that a comnination of all above has worked perfectly