Skip navigation

I can't add my Epson to the printer queue

3221 Views 7 Replies Latest reply: Dec 21, 2013 6:47 PM by JuliannaM RSS
Shelby0309 Calculating status...
Currently Being Moderated
Oct 12, 2013 11:34 PM

I have a Epson WF 2540 printer. It has been printing wirelessly perfectly fine for the past 2 months. Tried to print today, and I keep receiving a message saying the printer is not connected. I have re-set the wi-fi on the printer, re-installed new drivers from Epson website, however now my mac is not seeing the printer in the system preferences at all. It will not let me add or select my printer. What can I do?

MacBook Pro
  • anth2013 Level 2 Level 2 (270 points)
    Currently Being Moderated
    Oct 13, 2013 12:31 AM (in response to Shelby0309)

    What u can do is dont use drivers from website as i have epson WF 3520,just plug ur printer to mac book pro and let apple find the drivers for u automatic and then when found it,download when request and after this go to system preference>print&scan and check if ur model in folder and if not click + on left side to find ur model and for ur router reboot it...take off both cables(power &internet) and then put back after 15 secs this for refresh signals.

  • pennbank Level 4 Level 4 (1,515 points)
    Currently Being Moderated
    Oct 13, 2013 3:34 AM (in response to Shelby0309)

    Is your printer connecting  to your wifi ? 

     

    You may have your SSID in router settings  not showing ,whilst you  are trying to connect.

     

    http://support.apple.com/kb/TS3147

     

    http://support.apple.com/kb/HT1338

     

     

     

     

     

    Additional Information

    Note: If your printer is wireless-capable, you should first add the printer to your network. Use the printer's control panel, or temporarily connect the printer to your Mac via USB.  For more details, see this article.

    For information about adding a printer and other topics, see these articles:

  • Jocko D Calculating status...
    Currently Being Moderated
    Oct 24, 2013 12:28 PM (in response to Shelby0309)

    I have made it work.

     

    Short strokes, yesterday, could see the printer occasionally from iMac on 10.7, could not see it at all from MBA on 10.8, nor on 10.9 ( Go Mavericks!). iPhone at IOS 7 also couldn't see it in Epson iPrint.

     

    I powered down everything, including router.  Rebooted router, powered up printer, waited for it to connect to the network.  Then powered up everything else.

     

    Everything works.  Skies opened, and white pigeons flew around my house.  It was amazing.

     

    Several hours later, everything is still printing.

     

    Somebody is leaving little gifts in buffers somewhere that need power cycling to clean out, but at this point, all is much less frustrating, and actually working.

     

    I'll repost if the pigeons turn into those NYC variety that drop little presents everywhere and the printers stop working...

  • appleAZ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2013 11:18 AM (in response to Shelby0309)

    After an hour of frustration, I spotted something about VPN on the Epson site. THAT was the reason I couldn't connect to my printer on my home network. Seems obvious now, but I was working away and forgot that I was connected to my company's VPN. I disconnected & printed just fine.

    Hope this helps someone out there!

  • JuliannaM Calculating status...
    Currently Being Moderated
    Dec 21, 2013 6:47 PM (in response to Jocko D)

    This worked! Thank you!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.