Skip navigation

Question about Messages notification sound

3402 Views 5 Replies Latest reply: Apr 3, 2014 3:08 PM by OrchardKeeper RSS
Rocky M. Calculating status...
Currently Being Moderated
Nov 2, 2013 8:11 AM

Ever since I upgraded to Mavericks, I've been having issues with Messages. I'm praying that somebody can help me get everything situated.

 

First, whenever I have any window up over the chat, I don't hear a sound when I receive a message. I use this app every day for work, so not hearing that I've received a message while reading email is a real pain. If I have the chat open and above all of my other apps, I hear sounds perfectly. I've checked the settings and I have Play Sound Effects on. I'm not sure what else it could be.

MacBook Pro, OS X Mavericks (10.9)
  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Nov 3, 2013 12:04 PM (in response to Rocky M.)

    HI,

     

    I have several threads on this in thre Mavericks forum.

     

    As of yet I have not worked out a complete set of answers.

     

    What I do have.

    Alerts as they were called are no longer a separate option in the Preferences.

    You cannot turn off the sounds for actions like Invites (Text and A/V), File Sending or Receiving, Screen Share Invites.

     

    You can in the General Section of the Preferences change the Message Received sound to None or any Syste Sound or any Sound you have in ~/Library/Sounds (your User's Sounds Folder)

    You cannot switch it to any of the iChat/Messages sounds that are contained within the app.

     

    You also cannot apply a sound to a Specific Action for a Specific Buddy ins a Specific Buddy list as you cannot call up their Info Card any more (Highlighting a Buddy and doing Get Info (CMD + i keys) no longer works).

     

    I did manage to change the Messages Received Sound to one I had in my own Sounds folder.

    It worked for that session.  ( I "hid' the app behind a Browser and iMessages myself form my iPhone)

    The next day (I quit apps before shutting down and Start fresh the next day then launch the apps I want) I still had the sound set but it was not playing when I sent new messages (hidden or not).

     

    I checked the .plist and the info is not written to it.

    Part of the .plst shown and the corresponding Preferences

    plist and Preferences.png

     

    As the Video Invite item also shows it remembers what I had set before but plays the Ringer sound instead.

     

    As I said I don't have much of an answer beyond this.

     

    I would use the http://www.apple.com/feedback/ichat.html page as Messages is built on the iChat Engine

    put your full specs in the Free text area as the Version numbers drop down is miles behind (I does not even list iChat 6)

     

     

    3Sigcopy2.png
    8:04 pm      Sunday; November 3, 2013

     

      iMac 2.5Ghz 5i 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Nov 4, 2013 12:38 PM (in response to Ralph Johns (UK))

    4thanx.gif for the 1helpful.png  Points

     

     

    3Sigcopy2.png
    8:38 pm      Monday; November 4, 2013

     

      iMac 2.5Ghz 5i 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

  • Bernard808 Calculating status...
    Currently Being Moderated
    Mar 6, 2014 4:01 PM (in response to Rocky M.)

    Rocky M - were you able to resolve this, as I have the exact same issue.

     

    The only time I hear an audio alert for an incoming chat Message is when the Messages app is in the foreground as the "active" app. (Which is also when I need it the least.)

     

    When the app is running in the background and any other app is running in the foreground, no audio alerts come through.

     

    Appreciate any insight you (or anyone) has to offer!

     

    Thanks!

    -B

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Mar 7, 2014 12:45 PM (in response to Bernard808)

    Hi,

     

    Nothing has changed for me in the OS X 10.9.2 update that did change/add the Block fetaure to the iMessages account (in previous version of Messages and iChat this would have been enough for a sub number to the app).

     

    The best results I have are still changing the sound to something not in the Messages app itself.

    The "AlertClose" in the pic is a riff from Jimi Hendrix held in my ~/Library/Sounds folder.

     

     

     

    3Sigcopy2.png

    8:45 pm      Friday; March 7, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • OrchardKeeper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 3, 2014 3:08 PM (in response to Rocky M.)

    I don't know if this precisely addresses the issues you guys are having, but you may find this article interesting:

     

    Using AppleScript to restore missing functionality from iChat to Messages in OS X 10.9.x Mavericks

    http://tech.iprock.com/?p=11095

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.