Skip navigation

Time Machine extremely slow on Mavericks ?

55493 Views 341 Replies Latest reply: Apr 13, 2014 4:59 PM by moguySTL RSS Branched to a new discussion.
  • JustAMan Calculating status...

    Switching cables from FireWire800 to using the USB cable did the trick for me with backup issues. Now I can try to focus on getting spotlight tuned (the indexing goes on and on).  The external hard drive is WD My Book Studio XL so it is USB 2.0. iMac is 2 years old as is the WD hd

    I need to post a question now about mdsutil and spotlight privacy settings to figure that out!

  • paradoxatplay Calculating status...

    Same problems here, on my early 2009 iMac... About to notify Support... Seriously NOT fun!

  • alaz0 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2013 3:24 AM (in response to paradoxatplay)

    Same problem.  I've been following this issue on another thread, and found this one.  On a WD RAID firewire drive, it took 47 hours to do a single backup.  I took another drive (USB 2.0) formatted it and started a fresh Time Machine backup on it.  After 4 days, it backed up about 26 GB of 465 GB.  Figured it would take about 70 days to do a single backup on a fresh drive.


    Sent feedback to Apple, no response, and it's not on their top to do (mos popular) list.  Still no solution.

  • woodsfortysix Calculating status...
    Currently Being Moderated
    Nov 4, 2013 4:50 AM (in response to alaz0)

    Like others have commented, Time Machine is extremely slow on my iMac (but appears to be okay on my MacBook Pro) - running Mavericks.  Have re-imaged disks, re-installed Mavericks, re-indexed Spotlight, etc...but still have performance problems.  Also noted that Spotlight seems to be doing a lot of indexing.  Will be estimating time, say 4 to 5 days to complete, and then in an hour, it is not indexing.


    Any suggestions?



  • TRATRA Calculating status...
    Currently Being Moderated
    Nov 4, 2013 6:10 AM (in response to faroutsider)

    Hi all,

    I wanted to do a full backup of my system before installing Mavericks.

    I use a TimeCapsule (1TB) with Time Machine.

    So I activate TM and after some time it reports backing up 348.616 items 19GB of 249,72GB - About 9 days.

    Maybe my HD was too full... so I quit the backup and moved my iPhoto library to an external HD (LaCie Rugged 1TB -firewire800) Also did a backup of my MBP to another partition on that same HD, which went fine.

    The TimeMachine backup I started after was irritatingly slow, so I stopped that.

    Then I thought maybe my TC is bad, so I get another TC, erase and format it, and start a fresh backup yesterday morning. By yesterday evening it was telling me it would need 4 days to complete the backup, so I left the MBP open through the night, chequed it this morning, and now it shows "25,57 GB of 218,55 GB - About 8 days"

    Disk Utility says I have 121,99GB available of 250,14GB, so that's 128,15GB used. Why is Time Machine backing up 218GB???

    By the way my Spotlight is not indexing or anything like that, and my CPU is about 90% idle, except when Ido something on the computer, then it goes to about 80% idle.

    Disk Activity is showing no significant activity either...

    Now I'm worried about what to do next, the MBP is my only computer and I need to get on, can't just leave it in a corner for "about" 8 days.

    Any ideas anybody?

  • Protagonist Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 4, 2013 7:08 AM (in response to TRATRA)

    Do what many have already suggested. Clone the drive at least for now and that will at least give you a current backup. I usually clone my drive once a week as well as have a TM backup. For some the TM problems have sorted themselves out, ( I guess I was one of the lucky ones), but for many it is a major issue. I suspect those will have to wait for a fix from Apple.


    One common thread for many seems to be WD and LaCie. I know WD had FW problems several years back and that is when I migrated away from their drives and went to Seagate. I do have a LaCie 2Big duo setup but as luck would have it that is not my TM drive anymore. Anyway, Apple does seem to be taking longet than I would have expected on this. A simple acknowledgement Would be helpful but I guess that is too much to expect.

  • jefsch Calculating status...
    Currently Being Moderated
    Nov 4, 2013 9:37 AM (in response to Protagonist)

    Ironically, I have the latest & greatest MacBook Pro 15-inch Retina with all the bells & whistles. I do have a WD 2GB external drive, but it worked fantastic under OS X 10.8, but since upreading to Mavericks; it takes forever. Sometimes it will finally finish, but take an hour or so just to clean up the backup.


    Also, it has been mentioned earlier in this discussion, but once it finishes, I can immediately restart the backup and it will say I have 100GB+ of backup to do...with nothing having been changed since the last backup.


    This is becoming an annoying issue. I have reported it to Apple, but like those above...nor response.

  • TRATRA Level 1 Level 1 (30 points)
    Currently Being Moderated
    Nov 4, 2013 9:38 AM (in response to Protagonist)

    No can do, I don't have another drive to clone this system. The drive I have is already keeping a SuperDuper! clone of my previous system from before I attempted a full clean TimeMachine backup to the TimeCapsule.


    Anyhow, it's not just Mavericks... I'm still on ML, the Apple TimeCapsule is my main TM drive.


    Will keep trying...


    (ps. lucky you)

  • Bert-B Calculating status...

    Tried again today with new MacBook Pro Retina.  After 1 hour and 45 minutes, only completed 192.7MB of 86.09GB.  It's been stuck on 192.7MB now for about 10 minutes.  Backing up by USB 2.0 to WD 1TB drive.  Not getting any better.

  • Bert-B Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2013 11:16 PM (in response to Bert-B)

    I got confirmation today from Apple Tech Support that my problem was the Western Digital external hard drive.  WD has confirmed there is a problem (see link below).  Apple Tech Support said to remove any WD software and check for a firmware update.  My WD drive is over 2 years old, so at this point there is no firmware on the WD Support website.


    I did a full backup to my home Time Capsule and the initial backup of 112GB took 2 hours and 40 minutes.  This appears to have solved the problem.


  • DCIFRTHS Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 5, 2013 4:03 AM (in response to Bert-B)

    I believe that there is more going on here than the WD software. I am using a NAS device, and am having major problems with time machine. Slow, ridiculously large backups etc.


    It's more than a WD software issue. It's a Mavericks software issue.

  • jefsch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 8:22 AM (in response to DCIFRTHS)

    Agreed. I have several backup drives that I am using for my MacBook Pro WD, Seagate, and a Time Machine drive. I have tried them all and find the same result.

  • jefsch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 8:50 AM (in response to Bert-B)

    Just to give it a try, I updated the firmware on my WD 2TB backup drive and it was 'preparing the backup' for over 45 minutes and when it finally started the actual backup, it said that I have 1.75GB of backup to do, and I havent even used the computer since the last backup.


    This is getting to the point of real annoyance. I have been an apple user (and supporter) for many years--even during some of the darkest days and I can't say that I have seen a problem like this with so many comments and posts across various sites, blogs and forums without any response from Apple.


    Very concerning.

  • elenchus Calculating status...

    Fellow Sufferers,


    An update (though premature to cast it as a solution).


    I begin with some facts/observations about my own case.  I'm not sure which are relevant, but some combination (a subset of these) is likely shared by many of us.  My operating assumption is that a specific, identifiable set of symptoms more likely points to the same underlying problem.  Even though it is possible that we are all experiencing approximately the same effects tracing back to distinct causes, it seems bad science to presume a multiplicity of causes for the same general observables. That's a long winded way of expressing doubt that the slowness of TM backups in one case is due to a WD drive incompatibility and in another case it is due to unsupported NAS drives (that work with earlier OSs despite being just as "unsupported" then) and in yet another case is some sort of persistent Time Capsule issue. If we are all having slow TM backups post Mavericks, given different drives, different connectivity, different modes of os upgrade (clean, restored, updated, cloned, migrated, etc), then Mavericks seems to be the common denominator.  Thus, I'm hoping to narrow down the aspects of the Mavericks upgrade relevant to the TM problem. Since I am now 45GB into a 125GB backup (over wifi to a time capsule with an existing sparsebundle and no resetting of the TC), I think I'm onto something. My machine reports an estimated 3 hours to finish the 75+ gigs.  All looks promising.


    Now the observations:


    I did a "clean" install of Mavericks while booted from an external USB drive containing the Mavericks installer.  I'd had my TM backup, since my regular backup protocol was unproblematic under 10.8. Two machines backup to the same 2TB TC.  The other, a 2011 MBP, has enjoyed uninterrupted performance following an in-place upgrade from 10.8 to 10.9 (i.e., no reformatting or booting from a different drive).


    In addition to my existing TM backup, I cloned my home folder and a few global settings using Carbon Copy Cloner. I also manually copied a few key items to cloud space (my documents, iphoto library, etc). I've lost data before: once burned, twice cautions.


    After the fresh install, I booted into the new volume, repaired permissions, updated via the app store (including the installation of "new" apps, like iphoto and iwork). Repaired permissions again and booted into an external volume (the one from which I did the installation, running 10.8 and containing all of my utilities). I ran Diskwarrior, which reported no problems, and then copied over my pics, music, docs, and the like.  Booted back into my mavericks volume and commenced to redownloading the software I need for daily life (dropbox, ram cleaner, temp gauge, and so on). Repaired permissions again and attempted to setup TM. That's when I discovered two critical problems. (1) crazy-slow backup performance; (2) iWork. Once I realized that the estimates of 5-6 days to complete a backup were stable, I halted the process. I verifying the sparsebundle (all seemed ok), and I repaired the permissions on the backup image, which also seemed okay. I then attempted a backup via the usb ethernet dongle. Same speeds. Halted the process and attempted to repair the sparsebundle with DiskWarrior. It reported insufficient RAM and recommended that I boot from the CD, which wasn't an option, since I can't mount networked volumes when booted from the CD. So, I spent the night copying the sparse bundle from the TC to an external drive. The data was only about 200-250GB (absurd that I just said "only" 200GB!) but the image registers the capacity of the TC drive. So once it was copied over to the external drive, I shrank the image to 250 and attempted to use DW again. Same memory error. This was on a 1TB drive, so there was ample working space. I then moved to my wife's MBP with 8GB of RAM; still that error. I abandoned that approach.


    By this time I realizes that the new iWork is a sucking chest wound where once there had been a serviceable productivity suite. So, I restored my 10.8 environment from the TC, and all went reasonably well. Took better than 13 hours, but that's not terribly slow for a full TM restore, as I recall. Booted, repaired and retrieved my cloud-stored iWork documents, lest they be befouled by The Abomination (iWork for iOS, bundled as iWork for Mavericks). Tragically, in my unreflective enthusiasm I updated my ipad's version of iWork and worried that this would corrupt the many documents in the cloud, documents I wanted to continue using with my restored iWork '09.  Anyway, I concluded that the problem was not with TC or with the sparsebundle, since restoring my machine went fine.


    Once I'd salvaged all of my documents, I attempted to figure out why the new OS wasn't cooperating with the existing backup. Many of you (6+ pages of comments on this thread alone by then) reported problems with Spotlight and various differences in performance depending on connectivity (USB, FW, TB, E-net, etc). Some reported intermittent success following factory resets, reformatting, and so on. But no clear, stable solution.


    I resolved to maintain a "backup" manually until the end of the semester (I'm a teacher and really should not have broken my private policy of not dicking around with my setup during the term; I am weak). But then I noticed that quick look didn't work. And the default apps were wrong, and wouldn't change.  For example, "get info" on a pages document revealed that Preview was the default app for the file type and when I manually selected Pages and applied to all, it seemed to execute, but none of the other ".pages" documents reflected this change. Permissions repair and reboot had no effect. I also noticed that spotlight searches came up empty, even when I knew the file existed. (I'm lazy and almost never navigate to things when CMD-space will get me there.). Then I started getting errors on all of my cloud services (dropbox,, and googledrive all reported permission errors). I'd still not connected all of this up, so I just had all of the content restored from the cloud, overwriting the stuff I restored from my pre-upgrade clone.


    Then, iTunes denied access to google play music manager (I have an android phone), despite the fact that all of these services worked flawlessly on 10.8.


    Finally, the Mavericks version of Onyx came out.  (Love, love, LOVE this utility.). It reported a damaged file structure and instructed me to repair it via the recovery partition. I'd verified the 10.9 volume from within the same 10.9 volume and it checked out, and I'd run a check from both DiskWarrior and Disk Utility on a 10.8 volume (while booted from the 10.8 volume), and none of these attempts to test it revealed problems. But onyx caught it. And the 10.9 recovery partition seems to have repaired it. I then used onyx to purge everything it would allow, every cache, every cookie, every font. It detected several corrupted plist files--specifically having to do with iWork. I did NOT upgrade to the new iWork after restoring my machine, recall. Yet, the plist for iWork was v3.0 instead of '09 (with the Mavericks creation date, even). Tried deleting it, but the new one created following a reboot was the same, v3. Finally copied the plist from my clone, which changed the version number to 3, but kept the creation date the same as for iWork '09.


    Two things to note. After onyx purged everything and rebuilt everything rebuildable, spotlight took almost four hours indexing the startup volume.


    I initiated a TM backup almost 3 hours ago. I had 125GB to backup. It is 67GB into and the system estimates another 2 hours remaining. So 5 hours to do a 125GB backup over wifi. Not bad.


    Another thing to note. All of my home folder permissions remain dorked--where the get info should show "Staff" as read/write, it has a ghosted "Fetching ..." and "custom." It would seem that the fairly permissive dragging and dropping form of "migration" is not all that successful under 10.9.  The usual advanced features context menu in accounts seems fine--the user ID is 502 and the group is staff. I didn't want to monkey about while the backup is running so smoothly. But, when it is done, I'll probably boot into the recovery partition and reset ACL permissions (though Disk Utility is not spitting out ACL permission errors). I do recall encountering this particular problem years back and using terminal to repair it, but I'm hesitant to employ older terminal commands in a wholly new OS.  **** even making hidden files and folders visible requires a slightly different command.


    My new fledgling theory: the culprit is migration problems that generate permissions problems neither detected nor repaired by Disk Utility (or third party utilities, even the undeniably awesome DW) ... unless booted into the recovery partition using the 10.9 disk utility there. Onyx was the crucial diagnostic tool in my case.  Probably still needs the ACL reset too.  And, if I really wanted to play it save, I probably should have reinstalled iWork '09 from the DVD instead of restoring from the clone.  Might have been nice had we been cautioned that one would need to actually migrate data to the new volume, not just copy it over. Assuming that's the problem.


    Whew. You're a champ if you read this far.  I think the fix (for me) involved repairing the 10.9 volume from the recovery partition and using onyx to force various rebuilds, spotlight in particular.  I do not know why spotlight didn't index post update, or didn't do a thorough one when I dragged all of my files into my home folder. Historically, (a) lots of new data copied to the drive triggers a reindexing and (b) it's obvious when this happens (fans blow, machine gets sluggish, clicking on the spy glass shows indexing, ram dwindles, activity monitor shows a lot of mds action, etc).  There was no massive indexing post installation.


    Also of concern: I had installed Temperature Gauge, which I downloaded from the app store (and wicked miss). But console listed scads of smc errors pointing to either the temp app or the ram app. Uninstalling the temp app and doing an smc reset (and pram zap, just for the **** of it) seems to have coincided with the elimination of those errors. But it's too early to say they are gone for good. And I can't be sure that all of the other stuff didn't cure it.


    Hope this ridiculous data-dump proves useful to others as you attempt to diagnose yourselves to TM nirvana.  (About an hour left to my first post-10.9 backup.)

  • Protagonist Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 5, 2013 11:39 AM (in response to elenchus)

    Thanks for the report. As one who had the initial new TM backup take over 16.5 hours, which may not be that much out of line considering I for got to turn off spotlight first and it was approx 330gb, over a FW800 connection and where subsequant backups seem to run normaolly I will add the details of how I installed Mavericks. Hopefully if enough data is collected some sense can be made out of all this.


    Anyway, I did a fresh SuperDuper clone and made sure the TM backup ran one last time. I went the upgrade path but did not install immediately. I chose to copy the installer to an external drive first. Prior to the DL I used Disk Utility to repair the drive and to repair permissions. I also did a lot of routine maintenance to insure the drive was cleaned of as much as it could be. I then unmounted, powered down and disconnected all my external drives. Since I boot in three stages, boot - after boot - and morning start apps, to prevent all the programs I use during the day from trying to start all at once I closed down just about all the background apps. My start on login list is fairly short this way. I then ran the installer and on reboot only ran into one problem, which turned out to be from an online backup program that was turned off but still loading, and everything looked good.


    Like you I did a lot of updating and when I completed that I repaird the prefferences again. There were a lot of preferences that needed repairing. When I set up TM I used a different volume so that I would get a new backup and kept the onld backup in case I needed to revery. And I can't stress enough to people if you can keep two different types of backups on different drives. My clone is to a drive that sits in a docking station for easy removal and drive rotation. My TM sits on one volume in a four disk DROBO connected thro a FW800 connection.


    As I mentioned earlier the initial backup took a long time but has worked normally since then. As you said, if we can get enough explanations of people experiences perhaps a common thread can be discerned. I hope my info can help you out. BTW, I would like to put in a plug for Hardware Monitor. It gives a large array of temp sensor readings and I use it to keep track of the sensors I think are critical. It does other things as well so it is a very useful program.

1 ... 7 8 9 10 11 ... 23 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (11)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.