Skip navigation

My email confuses inboxes

584 Views 8 Replies Latest reply: Nov 6, 2013 7:36 AM by Glenn Leblanc RSS
JayMM Calculating status...
Currently Being Moderated
Jul 10, 2012 9:15 AM

I have multiple email accounts that I use in Mail, including two Gmail accounts. 

 

Recently, I've received emails from the two Gmail accounts in the wrong Gmail inbox.  Replies to one of the Gmail accounts always show up in the other gmail account inbox.  It happens on my MacBook Pro, my iPhone and iPad.

 

Is this a Mail problem or a Gmail problem?  How do I fix it?

 

Thanks.

 

Jaymm

MacBook Pro
  • Glenn Leblanc Level 5 Level 5 (5,925 points)
    Currently Being Moderated
    Jul 10, 2012 9:25 AM (in response to JayMM)

    The problem is that if you are using the same gmail server for different accounts, it will change the address to the address of the server you are using.

     

    To fix it, you will need to check each gmail account settings in Mail and on each device. Make sure each account has the correct outgoing server selected for it in the list with the correct user name & password for that account and check the box to use only that server with that account.

     

    Anothe way to fix it to use any gmail server with any account is to go to gmails website. Go into settings and either the Accounts tab or Pop & Forwarding tab (don't remember which it is under) and find the setting to Send Mail As. You can add the other gmail accounts to it and create the setting for each different account to what address to use (put the email address of the account you add). Then gmail will leave the address used instead of changing it.

    You will have to do this to all accounts, or just use one as the main account and add the other address to it. Then in you devices, use the SMTP server for the main account.

  • jrfelbab Calculating status...
    Currently Being Moderated
    Jan 19, 2013 10:16 AM (in response to Glenn Leblanc)

    Thank you Glen, for the quick reply.  I only have one Gmail mail account, one email address.  It is the sole Gmail email account I use on these iPads  I have a couple othere mail accounts from other server like Yahoo and Apple.  I don't quite understand then how the account setting would need updating for different accounts as I only have the one Gmail account.

     

    The Gmail account address, myusername@gmail.com, is set for mail only and is an IMAP account using SSL and port 993 with password authentication.

     

    It's outgoing SMTP server is smtp.gmail.com on port 465 using SSL and password authentication. It is designated as the primary server and all other servers are set to off for this account.

     

    Perhaps I need to look at the Gmail website as you mentioned?

     

    This is muddling up my thought process to the point where I am not understanding what is occuring and why.

  • Glenn Leblanc Level 5 Level 5 (5,925 points)
    Currently Being Moderated
    Jan 21, 2013 10:37 AM (in response to jrfelbab)

    Well what you are asking is confusing. You first post said you had 2 gmail accounts and replies from one are going to the other account. So I'm not exactly sure what the problem is from the last post.

     

    Is your problem stricktly with gmail and no other accounts? I'm a bit confused.

  • jrfelbab Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 21, 2013 12:51 PM (in response to Glenn Leblanc)

    The reason for the confusion is mine.  I had posted a question in a forum here and came back later and was reading related issues and thought your reply was for my post.  Only later did I realize yours was not a response to my issue.  I am sorry for the confusion.  Guess I had a brain F_rt.  Happens sometimes when you get old.

  • Gingerzon Calculating status...
    Currently Being Moderated
    Nov 6, 2013 6:21 AM (in response to Glenn Leblanc)

    Glenn,

     

    I am having a similar gmail issue.  I have a gmail account username@gmail.com and then my work email for my business which is username@company.com but the email is managed by gmail.  I don't quite understand what you said to do, but I need to figure something out becaues I send from apple mail and its sending from my @company.com email addy but all responses keep coming to @gmail.com and its really unprofessional and frankly frustrating as my emails I had tried to hard to keep seperate (personal vs work) are all jumbled.

     

    Help!

     

    Colleen

  • Glenn Leblanc Level 5 Level 5 (5,925 points)
    Currently Being Moderated
    Nov 6, 2013 6:36 AM (in response to Gingerzon)

    Are you sure you are sending form the company account? Does the sending address show the correct account? If it isn't sending from the correct account, then that may be your problem. Open Mail's preferences. Go to the Composing tab first. Look at the box to Send New Messages from. Choose the account of selected Mailbox.

     

    If you have the wrong outgoing server for an account, it will use whatever you have listed and the address sent will be changed to that of the outgoing server no matter which account you are sending from.

    As I said earlier, each account should have it's own outgoing server with username and password. Open Mail's preferences. Go to the Accounts tab, then Accounts. Highlight an account and look at the SMTP server listed in the box for that account. Click on the box and edit the server list. Highlight the server for that account and check the username and password for it and make sure it is correct. Save it and check the box to use only that server for that account.

    Check the other account and do the same for it.

  • Gingerzon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2013 6:56 AM (in response to Glenn Leblanc)

    Ok I have done that.  It's weird, it says (offline).  I have the right username & password, would that be why its not working right?

  • Glenn Leblanc Level 5 Level 5 (5,925 points)
    Currently Being Moderated
    Nov 6, 2013 7:36 AM (in response to Gingerzon)

    If there is a problem with a setting, it will attempt to swap to the next server in the list. If you check the box to use only that server with each account, when the one you have for the account fails, you will get a list telling you that it failed and a choice to use another server in the list. If you don't have the box checked to use only that server, it is done automatically and you won't see the list or get the failure warning.

     

    Try it and see. If it's offline because of an error, you should get a warning message when you send.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.