1 Reply Latest reply: Nov 9, 2013 10:26 AM by appleidsareSOfxxkedup
appleidsareSOfxxkedup Level 1 Level 1 (0 points)

I've scanned an old slide, cleaned it up and have tried to use it in a book.  Occasionally, the upper half of the picture will go completely black on the screen. Restarting Aperture will often correct this, but even when it show correctly on screen, it will still print half-black.  I've done this with hundreds of other photos from scanned slides, but the half-black phenomenon has only ever shown up on this one.

 

Maverick disabled server functionality, which I have not yet restored, but I don't think that's relevant to this issue.


MAC MINI SERVER (LATE 2012), OS X Mavericks (10.9)
  • 1. Re: Why does a picture turn half-black?
    appleidsareSOfxxkedup Level 1 Level 1 (0 points)

    I went to Apple's phone support for this, and they were excellent.  Attaboys for Jamal and Christian!  It turns out that when I copied the Aperture library from my laptop to my Mini server as part of a plan to centralize photographic services, some elements of the library were corrupted.  The process by which Aperture 'exports' a photo for printing or incorporation in a book seems to be that it goes back to the original and applies all adjustments.  Although the version seen in the book editing window looked fine, anything 'printed' was corrupted, which suggests that it was the record of adjustments that was damaged, since the solution Jamal found went back to the original.

     

    He proposed (and walked me through, to make sure everything would work) exporting the original of a damaged photo, deleting the original and all versions from the library, renaming the exported file and reimporting it.  All adjustments had to be redone, but it worked.  Which was a good thing, because the last ditch measure would have required restoring a copy of the library from my laptop, if Time Machine still has a copy of that months-old file!

     

    It occured to me later that I might have tried taking a screen shot of the image as it appeared in the book editing window, deleting original and all copies followed by reimport.  If the quality was acceptable for the application, that would have saved the readjustment step.

     

    The problem arose on 4 photos out of 400 used in two books, so, if that is representative, there's a 1% chance I'll have to do this again.  Hope I can remember how!