Skip navigation

why does iPhoto blow up when I click on import?

340 Views 8 Replies Latest reply: Nov 14, 2013 10:04 AM by whitesalmon133 RSS
whitesalmon133 Calculating status...
Currently Being Moderated
Nov 8, 2013 10:30 AM

I open iPhoto, then click on "import to library" so I can select a file to import, and iPhoto blows up right away. Up comes an long error of some kind that says the error report will be sent to Apple. And, here I am!

iPhoto '11, Mac OS X (10.7.5)
  • Terence Devlin Level 10 Level 10 (121,640 points)

    I have no idea what "blow up" means.

     

    There are 9 different versions of iPhoto and they run on 9 different versions of the Operating System. The tricks and tips for dealing with issues vary depending on the version of iPhoto and the version of the OS. So to get help you need to give as much information as you can. Include things like:

     

    - What version of iPhoto.

     

    - What version of the Operating System.

     

    - Details. As full a description of the problem as you can. For example, if you have a problem with exporting, then explain by describing how you are trying to export, and so on.

     

    - History: Is this going on long? Has anything been installed or deleted? - Are there error messages?

     

    - What steps have you tried already to solve the issue.

     

    - Anything unusual about your set up? Or how you use iPhoto?

     

    Anything else you can think of that might help someone understand the problem you have.

  • Old Toad Level 10 Level 10 (113,030 points)

    Sounds like iPhoto is crashing and creating a crash report.  Try again and when it crashes copy and post just the first 50 lines of the crash report here.

     

    OT

  • Old Toad Level 10 Level 10 (113,030 points)

    As a quick fix attempt try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

     

    home.PNG

     

    or with Lion, Mt. Lion or Mavericks delete the contents the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder.

     

    iP11mtlioncache.png

     

    3 - reboot, launch iPhoto and try again.

     

    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and press the Return key - 10.7: Un-hide the User Library folder.

     

    If you're running Mavericks, 10.9,  go to your Home folder and use the View ➙ Show View Options menu to bring the this window:

    Mavlibvis.png


    where you can check the Show Library Folder checkbox.

  • Old Toad Level 10 Level 10 (113,030 points)

    Then go to the Desktop, hold down the Option key and click on the Go menu. There you will see Library listed.  Click on it and you can get to the Preference folder where you can find and delete the com.apple.iPhoto.plist preference file.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.