Skip navigation

mail.app rules still trash

2197 Views 15 Replies Latest reply: Feb 28, 2014 7:26 AM by Laurent Seroude RSS
1 2 Previous Next
mustdent Calculating status...
Currently Being Moderated
Nov 7, 2013 11:18 PM

The mail application rules which were not working truly after Mavericks download still seem to be broken even after the update of yesterday. The application adds ''copy'' command to random rules which are created before as ''move''. I cannot create a new rule in confidence because of graphical problem at the interface and the rules cannot do their jobs as they've been created, moving and/or copying to the wrong mailboxes. I put a screenshot of a rule created interface that you will be able to see nice! view of the interface. Am I alone with these rule problems or does anyone else there? Have you found any solution or is this a Mavericks OS fault about which Apple doesn't care!! Thanks for all helps in advance firends. Screen Shot 2013-11-08 at 08.26.27.png

Mac Pro, OS X Mavericks (10.9)
  • Kingoftypos Level 2 Level 2 (420 points)
    Currently Being Moderated
    Nov 7, 2013 11:27 PM (in response to mustdent)

    I have over 25 rules and none of them look like that. Most were made during Mt Lion, and some were edited or added after Mavericks.

     

    Also with yesterday's update. I noticed that the rules stopped working. But when I arrived back home and selected the messages that didn't do what they were suppose to do. And selected "Apply Rules". Everything else worked after that. Could it worked if I restarted Mail, perhaps.

     

    KOT

  • azamino Level 4 Level 4 (1,615 points)
    Currently Being Moderated
    Nov 8, 2013 7:10 AM (in response to mustdent)

    i also confirm that my Rules dont have that overlapping GUI problem.

     

    still, neither the rules created under Mountain Lion, nor new Rules created under Mavericks will move messages out of the Sent box into the appropriate folder.  i was always able to do a Message/Apply Rules to Sent messages before, and it stopped working under Mavericks.

     

    for Incoming messages however, all of my Rules do work on Incoming messages, before and even now, under Mavericks. Only have the problem with applying it to Sent messages.

     

    thanks

  • Kingoftypos Level 2 Level 2 (420 points)
    Currently Being Moderated
    Nov 8, 2013 9:06 AM (in response to mustdent)

    With azamino's reply. I was able to verify that my Rules does work. I've had all Apple Support Discussions moved into a folder. Had it since Mt Lion and it still works under Mavericks, even with the Mail app update from yesterday.

     

    I also have rules on my out going emails. Not to move them, but to change the back ground color so I know what email address I used. However, I made those rules after installing Mavericks and it does work. Haven't sent any email since yesterday though.

     

    KOT

  • azamino Level 4 Level 4 (1,615 points)
    Currently Being Moderated
    Nov 9, 2013 6:53 AM (in response to mustdent)

    mustdent,

     

    i confirm the same phenonomon as you mentioned: when making new Rules in Mail, if I use the command "Copy to" then the GUI has a kind of wrinkle effect as per yr screen shot.

     

    i also confirm that as a work around, until apple fixes the "Move to" x folder command to be used, doing a Copy to then a "Delete Message" does work, in order to get Sent messages from the Sent box into folders.

     

    thanks

  • ΙΚΑΡΟΣ Calculating status...
    Currently Being Moderated
    Dec 5, 2013 12:55 AM (in response to mustdent)

    I do have the same problems with you since Mavericks installation which didn't vanish even after the Mail Update. Apple sure takes its time to fix this.

  • Dr.MORO Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 19, 2013 1:23 PM (in response to mustdent)

    Domo!!!

     

    I have the same problem with Mavericks' Mail rules.

     

    I mainly use rules for incoming messages to be sorted to appropriate folders. 50+ rules worked perfectly in Mt Lion until my upgrade... I just upgraded from Mt Lion to Mavericks a few days ago, and it has been a very unpleasant whirlwind.

     

    Only the newly received messages get moved properly by the rules.

    None of the read messages already on the server with be moved by the rules manually, as it used to in Mt Lion.

    There is another thread: "Mail rules in OS Mavericks 10.9 don't apply to Sent Messages" .

    Seems like a rules to 'Play Sound' works even manually, but just not 'Move to' function.

     

    I will try the Copy and then Deleted rules method, and see if I can 'move' messages around, until Apple fixes this issue.

     

    Apple, please fix this immediately!!!

  • BG29 Calculating status...
    Currently Being Moderated
    Dec 22, 2013 2:03 PM (in response to Dr.MORO)

    I waited patiently for Mavericks update 10.9.1 to appear but the problem with Rules has not been fixed. Very disappointing.

     

    As many others have found, if you want to move messages from the Inbox to another folder, and Edit an existing rule to add a new address to be Moved to another folder, and then Apply the rule to that new address, Mail is determined to Copy the message rather Move it.

     

    It's easy to miss that Copy is what's happening - at first nothing seems to happen because the message you want to move remains stubbornly in the InBox, but check the destination folder and you may find the message now also appears where you intended.

     

    Fortunately for me at least, Move rules seem to work okay after that, but Applying a rule to a new address does not work as it should.

     

    This seems a pretty simple thing - disappointed it's still not been fixed.

  • Harald Brandt Calculating status...
    Currently Being Moderated
    Jan 5, 2014 7:13 AM (in response to mustdent)

    My rules look just as bad as yours [referring to your screen shot].

     

    In addition, I would like to add the following important thing:

    I also have coloring of the the mail (Set Color of Message) as a rule in between the Move and the Stop Evaluating rules. Each time the rule is opened, the rule gets a bit more obscured and overlapping, and after a few times, the Set Color rule is completely hidden! Even in cases where I have the coloring rule at the end, it will finally disappear! So it it does not even looks corrupt -- it looks like that rule is completely gone!

    But the rules still work though.

     

    If I quit Mail and reopen it again, I can once again see the Set Color rule, but again it gets obscured after a while.

     

    Mavericks = Junk!

     

    I waited long with this "upgrade" to Mavericks simply because I hate such obnoxiousness. I regret that I did not wait another half a year or so, or perhaps even a year or two... This Mavericks "upgrade" was said to be free, but it has so far cost me about 10 hours of wasted time (and counting), because it also screwed up the mail import completely so that many dates of old mails were reset to today! Priceless...

  • Laurent Seroude Level 1 Level 1 (60 points)
    Currently Being Moderated
    Feb 8, 2014 12:24 PM (in response to mustdent)

    The rules "News from Apple" (added with 10.9) have a "after performing" rule "Stop evaluating rules" included that should not be there and prevent all other rules from working. Removed this action and all rules work again (Apple needs to update Mail to remove this).

  • photopulse Calculating status...
    Currently Being Moderated
    Feb 19, 2014 2:06 AM (in response to mustdent)

    I have Mavericks 10.9.1. The rules interface looks good but I have the same problem:

    When setting a rule that would copy my inbox IMAP mails to a local mailbox (inbox 2014) on my Mac Pro

    and an other rule that would copy my sent IMAP mails to a local mailbox (sent 2014)

    The mails are mixed up in the local mailboxes or the rule doesn't apply at all! or weired things happens!?

    I tried this as well on my macbook pro (also 10.9.1), same problems!

    Talked on the phone with the Apple support about this and I should have a feedback within one week...

  • Dr.MORO Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 25, 2014 11:53 AM (in response to mustdent)

    Hi all!

     

    Well, the latest Mavericks update 10.9.2 seems to have fixed the rule issue in Mail, I think.

    Mine is now Mail version 7.2 (1874), and applying the 'Move to' rules even to the emails left on the server, now correctly get moved to the appropriate folders on my Mac.

     

    I haven't tested intensively yet, but will try once again tomorrow.

  • andersab Calculating status...
    Currently Being Moderated
    Feb 27, 2014 1:31 AM (in response to photopulse)

    I have the same problem as you, I want to move automatically after 30 days my IMAP mail into a local archive and it does not work at all...

     

    Let's see what you get..

     

    By the way I have 10.9.2

  • Harald Brandt Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 28, 2014 12:41 AM (in response to Harald Brandt)

    Mail.app in 10.9.2 is as bad and lousy as before! No improvement concerning the problems that have plagued me:

     

    (1) Rules look just as bad as before. Each time the rule is opened, the rule gets a bit more obscured and overlapping.

     

    (2) Many old mails have the wrong text encoding, and there is still no way to change that!

     

    Mail.app in Mavericks: the worst mail application I have used in the last 20+ years!

     

    Mavericks = Catastrophy!

  • photopulse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 28, 2014 2:49 AM (in response to andersab)

    I got a very unsatisfying answer from AppleCare Engineering basicly saying that rules setting is not planned to work with the sent mailbox (even if there is a tab "sent" in the rules setting !!!?). What ever that means!

     

    They apparently know about the rules problem and as I can read in the apple forum these issues are known for long. So hopefully they will do something soon. I have also problems with rules on the inbox and there is unfortunatly several other bugs in Mail.

    I am thinking like Harald. I am so far happy with Mavericks but Mail is really a catastrophy!! I have also 10.9.2. and if all these issues are not solve with 10.9.3 I will for sure go back to Outlook for Mac.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.