Skip navigation

remote desktop 3.7 "Full Quality" mouse lag

2730 Views 12 Replies Latest reply: Feb 26, 2014 2:19 AM by Christoph Ewering1 RSS
defecta Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 1, 2013 2:57 PM

Hi guys,

 

Since upgrading my MacBook Pro running Mountain Lion and my Mac Mini running Mountain Lion Server to Mavericks and Mavericks Server respectively, Apple Remote Desktop was also upgraded to 3.7.

 

Now when run a remote control session on my W/LAN with ARD with the same settings I have always used, to my Mac Mini server, the mouse is extremely laggy making it very difficult to control. Both the ARD client and server are on version 3.7. The resolution of the display on the Mini is 1920 x 1080.

 

I have just tested remote control with my partners MacBook Air which is still on Mountain Lion 10.8.4 and ARD version 3.6.2 and it is mostly OK. The screen resolution is 1440 x 900. Only in some programs do I have issues with the mouse tracking correctly. Like when Safari 6.0.5 is in the Top Sites view the mouse control goes all laggy and he cursor disappears from screen until it leaves the Safari window.

 

I then upgraded the ARD client on her computer to 3.7 with no noticable impact on performance. I did notice however that using ARD in full screen mode worked a little more reliably.

 

So I've gone back to my Mini to see if the same full screen helped mouse control and it didn't. I then tried reducing the image quality from Full Quality to Adaptive Quality and BAM! The problem is gone. Including my partners MacBook Air when in the Top Sites view Safari.

 

Which begs the question, what broke in the 3.7 such that you cant use Full Quality on a W/LAN?

 

I appear to be the only person experienceing this issue as I have been googling this problem since upgrading to 3.7. Or are there others out there with the same or similar experiences?

MacBook Pro (15-inch Early 2011), OS X Mavericks (10.9)
  • BW Martin Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 2, 2013 9:52 PM (in response to defecta)

    I have been experiencing the same issue.  Mostly seems to happen when using ARD on OSX Server 10.9 and connecting with client machines running 10.9 outside of the LAN.  No issue inside the LAN or when contacting machines running 10.8, 10.7, 10.6, etc.

     

    Thanks for the tip about using Adaptive Quality: it helped a lot and will at least be workable until there is a fix.

  • newtrawn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2013 10:29 PM (in response to defecta)

    I am having this EXACT same issue. Worked fine with 10.8.5 on ard 3.6.x but now works like crap. It's not even usable.

     

    2012 imac --> 2009 mac pro. Both on OSX 10.9 and ARD 3.7.

     

     

    Terrible framerate. Slow and choppy. Mouse is almost uncontrollable, it's so bad.

     

    Apple, PLEASE help us!

  • Superfletch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 2, 2014 12:35 PM (in response to defecta)

    I am experiencing bad lag as well and after reading your post switched over to wifi and it seems to be cleared up. Very Strange!!!

  • Christoph Ewering1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 3, 2014 5:47 AM (in response to defecta)

    Hello!

     

    Same problem here for me:

     

    Some ARD clients behind a vpn-tunnel.

    ARD admin cpmputer running 10.9.1 and ARD 3.7.1

     

    There is no problem with clients running 10.6.8, 10.7.5 and 10.8.5 with ARD client 3.5.4, 3.7 and 3.7.1

     

    But clients with 10.9.* and ARD client 3.7.* is it impossible to do remote control. It does not matter which color/quality mode i select. The mouse movement is extremly sluggish and lagging - it takes a few seconds until the mouse settles down - I need about 10 seconds to close a window.

     

    Once again all clients are controlled via the same vpn tunnel from the same ARD admin-computer.

     

    Apple has to fix it ASAP. We rely on reliable software products.

     

    Bye,

    Christoph

  • Christoph Ewering1 Level 1 Level 1 (5 points)

    bugreport number:  15743671

  • cnesko Level 1 Level 1 (0 points)

    After some investigating my problem with mouse lag on Mavericks was related to locking computer screen.

    As soon as I unlock the screen the lag is gone.

    Choosing adaptive quality makes the work possible but irritating.

    With lag it is impossible to do anything but simpliest things.

  • mullen8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2014 8:28 AM (in response to defecta)

    Just discovered this problem after using my new iMac to control my now headless Mac Mini (on the same desk). What's strange is that if I connect a monitor to the Mini the mouse lag in ARD on the iMac disappears. When I disconnect the monitor it instantly returns?

     

    Looks like this is a known issue with headless Minis.

    http://blog.macminicolo.net/post/33839671756/build-a-dummy-dongle-for-a-headless -mac-mini

     

    Message was edited by: mullen8

  • Macorland0 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 25, 2014 5:14 PM (in response to defecta)

    Hey, I just found out I was having this problem as well with 10.9.1 and ARD 3.7.1. Thanks for the tip about Adaptive Quality, it is actually less laggy then greyscale for us. (we never use Fully Quality). Not really sure how that is possible but at least I can use it now.

  • Christoph Ewering1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 26, 2014 2:19 AM (in response to defecta)

    Mavericks 10.9.2 13C64 is out and as far as I can tell no change - still lagging which makes remote control impossible

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.