Skip navigation

"Unable to download application"

3881 Views 3 Replies Latest reply: Nov 12, 2013 6:10 AM by matt00 RSS
geek1984 Calculating status...
Currently Being Moderated
Nov 6, 2013 11:43 AM

Since a couple of days, I'm having this error. Itunes store connects fine for most times, it shows which apps need updating and all but when I try to download it gives the error, "Unable to Download Application". Pickle is when I connect through VPN it downloads application just fine. I can not even access Apple Discussion group from my Iphone but I can do it from my computer with same connection. Before this it had been working just fine. I've tried to change the date but it hasn't been working. Can not restart it because then it gives me signal problems. Tried signing out/signing in to the app store. It signs in, just keep giving same error.

Iphone 4 i.e.

iPhone 4, iOS 5.0.1


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.