Skip navigation

Flagged folder in Mail, in Mavericks

4280 Views 34 Replies Latest reply: Mar 27, 2014 2:04 PM by dianeoforegon RSS
1 2 3 Previous Next
rha90272 Calculating status...
Currently Being Moderated
Oct 24, 2013 4:51 PM

In Mavericks on my iMac, I have a "Flagged" Mail folder that shows "7", but it's empty. This started with Mavericks.  I don't think I have any flagged messages, but if I do, I can't find them because of the empty folder.  Is there any way I can resolve this, so I don't have that "7" hanging around?  (I've restarted Mail, to no avail.)

iMac, Mac OS X (10.7.2), Mail
  • yaychemistry Calculating status...
    Currently Being Moderated
    Oct 26, 2013 9:33 AM (in response to rha90272)

    You might try rebuilding your Inbox.  "Mailbox" menu -> Rebuild.

  • Andyred Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2013 3:39 PM (in response to yaychemistry)

    I have the same problem in that it shows I have 2 Flagged mail messages (which I did prior to upgrading to Mavericks), but when I click on the Flagged tab, there are no e-mails contained in it.  I tried rebuilding all of my individual inboxs (icloud, gmail and yahoo) and I even rebuilt the Main Inbox (for all accounts) and it still have not fixed the problem.

  • obscurity Calculating status...
    Currently Being Moderated
    Nov 4, 2013 5:37 PM (in response to rha90272)

    Try this support page, which worked for me:

    http://support.apple.com/kb/PH11704

  • stayingaliveuk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2013 1:28 AM (in response to obscurity)

    Hello, yep having the same issues.

     

    I can't even find the mail folder in Library?

     

    obscurity are you able to share how to find the folder as mentioned in the support page?

     

    Should I be able to find that via finder?

     

    Many thanks, Michael

  • obscurity Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 6, 2013 1:39 AM (in response to stayingaliveuk)

    Hi Michael, The Library folder is hidden by default. Open the "Go" menu and press the Option key that will show the link to it in the menu.

     

    I use this folder frequently so I place a shortcut to it on the Finder Sidebar but bear in mind it is a folder that one needs to be smart about

     

    PS. The folder in question is your Home folder Library, not the System's Library folder.

  • stayingaliveuk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 8, 2013 1:38 AM (in response to obscurity)

    @obscurity

     

    Thank you I found it and followed the instructions.

     

    The re-indexing took about 15 minutes in the end and at first glance it looked great.

     

    The flags that had a number against them but no messages, didn't any longer and the ones that did have a flag appeared correctly.

     

    But...only for a few minutes and then the numbers started to increase steadily. It pulled in old messages that may have had flags against them in the past.

     

    So I'm back to status quo. Yellow flag says 1, no messages there. Blue flag says 3, nothing there either.

    Red flag, I removed the flags from the old messages and now the count is correct, which it wasn't previously.

     

    Oh by the way after the re-index, it showed up approx. 100 messages in various folders as unread. Very bizarre.

     

    Any other ideas. I didn't reboot after the re-index, so maybe I will try that?

     

    Many thanks

  • lahaina Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2013 3:09 PM (in response to stayingaliveuk)

    Same situation as stayingaliveuk.  Fixed for a minute and then reverts

  • stayingaliveuk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2013 3:31 PM (in response to lahaina)

    I realised afterwards that the envelope files were in my trash still, I'm guessing it may pull in those old phantom flags from there? But when I tried to empty trash it said that files were in use and couldn't be deleted. So maybe I need to re-do the whole thing. Empty trash, reboot machine and then open mail for re-indexing.

     

    Wish me luck!

     

    Michael

  • lahaina Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2013 3:39 PM (in response to stayingaliveuk)

    Same staus as yourself.  I eliminated the envelop files in trash and did a restart to no avail.  come on apple clean up Mavericks.

  • obscurity Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 9, 2013 10:37 PM (in response to stayingaliveuk)

    I don't know what to suggest. Surprised the indexing took so long, I had 19k that re-indexed in less than five minutes…you could try a rebuild of your mailboxes.

  • lahaina Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2013 4:04 PM (in response to obscurity)

    Finally fixed it.

     

    After indexing my messages one without a flag actually showed up in flags. It was color highlighted by use of formatt color.  I had used colors to high light messages.  eliminated color highlight and violá. 

     

     

    Makes sense.  double highlighting is verboten.

  • dbk9999 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Nov 11, 2013 7:45 PM (in response to rha90272)

    For what it's worth, I had 74 flagged messages listed though only 44 were there.  When I transferred everything to my new iMac, it said 44 - but eventually it became 74 as well.

     

    Following things in this thread, I tried rebuilding everything without success.  Then I tried the idea of deleting the "envelop index" files as described in a link here.  That didn't help much - the number only changed to 73.  So then I tried rebuilding the inbox again and got 44.  I don't recall, but I may also have quit mail someplace in this process.

     

    Then I read where some people had the wrong number come back and theoritized that the files still in the trash could be an issue.  When I tried to empty the trash, I had the some problem another poster reported (said they were in use).  So I quit mail and restarted the computer.  That let me empty the trash and then I relaunched Mail.

     

    So far it is okay, but it hasn't been very long!

  • stayingaliveuk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2013 6:31 AM (in response to dbk9999)

    @dbk9999

     

    thank you for your insights. i rebooted the mac and was able to delete the index files from my trash, great. relaunched mail but the offending ghost flags are still there.

     

    let's hope apple are working on a fix.

     

  • dbk9999 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Nov 12, 2013 7:22 PM (in response to stayingaliveuk)

    Mine is still working - did you rebuild AFTER deleting those files?  That's what I had to do.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.