Skip navigation

why mail will not quit?

506 Views 3 Replies Latest reply: Nov 14, 2013 10:17 PM by FrenchToast RSS
ASchun Calculating status...
Currently Being Moderated
Aug 26, 2013 7:58 PM

Mail will not quit, and prevents macbook pro from shutting down/restarting.

It will not quit, and does not give the option to force quit.

MacBook Pro, Mac OS X (10.6.8), Mail
  • Carolyn Samit Level 10 Level 10 (84,045 points)
    Currently Being Moderated
    Aug 26, 2013 11:09 PM (in response to ASchun)

    Try this keyboard shortcut.

     

    Option + Command + Esc

     

    That should prompt the Force Quit window.

     

     

    You can also force quit an app using Activity Monitor located  in HD > Applications > Utilities

     

    Select Mail under Process Name then Quit Process.

     

    Message was edited by: CS

  • Brandonchamberlain Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2013 7:37 PM (in response to Carolyn Samit)

    Mine is still doing this. It hasn't properly closed since I installed Maverick. Even with the Mail update a few weeks ago, it will not properly Quit the application. I have to Force Quit or hard restart (which I never do) to close it.

     

    It also freezes a bit during mail reading, not large files just normal text, and the fan will kick on as if the computer is in overdrive. No other applications running. Just Mail.

     

    Any advice? All the forums with this problem have Force Quit as a solution which isn't what I am looking for.

  • FrenchToast Level 3 Level 3 (570 points)
    Currently Being Moderated
    Nov 14, 2013 10:17 PM (in response to Brandonchamberlain)

    Looks like the Mavericks upgrade has messed with a lot of people's installations, and some Apple applications (like Mail, or Safari) seem more highly impacted than third-parties'.

     

    In your case, Mail appears to be gobbling up CPU cycles and RAM. You could install this little gem called atMonitor, highlight the Mail line in the main windows, then click on the "renice" button in the top right. You can then give it a "20" value (the lowest possible CPU grade for an application or service in OS X), then click on "Set and remember".

     

    Mail should behave from then on, and close down gracefully when you ask it too, because you put a cap to its CPU usage.

     

    One caveat: atMonitor must be running for the settings to take effect upon reboot. You can add it to your startup items.

     

    There's another app called Dock Dodger that will prevent the atMonitor from showing in your Dock all the time.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.