Skip navigation

iPhoto freezes when editing and it also freezes the computer?

1217 Views 16 Replies Latest reply: Dec 29, 2013 2:37 PM by LarryHN RSS Branched to a new discussion.
1 2 Previous Next
Harryvv Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 14, 2013 5:21 PM

I am running OS 10.9 and iPhoto is updated to it's newest version.  While editing photo, particularly cropping, iPhoto will freeze and it will also freeze the computer and I have to turn the power off and restart.  This is a consistent problem with the new version of iPhoto.

iPhoto '11, OS X Mavericks (10.9)
  • Terence Devlin Level 10 Level 10 (121,745 points)

    No it's not.

     

    As a Test:

     

    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

     

    Post back with the result.

  • Terence Devlin Level 10 Level 10 (121,745 points)

    It might be a bug but it's a pretty esoteric one that's only affecting you. If you beleive it's a bug then contact Apple

     

    iPhoto Menu -> Provide iPhoto Feedback

     

    and report it. They're the only ones who can fix such things.

     

    On the off chance that it's a local issue I'd swtich to another User Account and repeat the test.

  • Terence Devlin Level 10 Level 10 (121,745 points)

    Harryvv

     

    You're mightly determined that Apple should fix this problem you're having, but they won't. One, because iPhoto works in the other account, it shows that iPhoto is functioning normally and two: you're the only person reporting it. All of that tells us that you have a local issue on your machine, in one user account. Most likely some out of date software or plugin is interfering with the normal running of iPhoto there.

     

    iPhoto 11 v9.5 is good for about 1,000,000 images. How many do you have?

  • AcesHoney Calculating status...

    I am having the exact same problem. OS 10.9 and  only since the last iphoto upgrade a few weeks ago.

  • photosb189 Level 1 Level 1 (60 points)

    Have you updated to 9.5.1 released yesterday?

  • AcesHoney Level 1 Level 1 (0 points)

    Just downloaded and installed it now..( I wasn't aware it came out)  and it has solved the problem
    Thank you photosb189

  • artsquawk Level 1 Level 1 (0 points)

    This was happening to me in iPhoto 9.5 I did all the rebuilds, etc.  Then updated to 9.5.1 - AND it happened again, just as you describe:  works on some then freezes the computer -  have to totally shut down and reboot.  There appears to be no difference in why or how it freezes on some crops - a really bad fault in iPhoto.

  • Old Toad Level 10 Level 10 (113,235 points)

    Try the two fixes below in order as needed:

     

    Fix #1

     

    1 - launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iPMfirstaid.png

     

    2 - run Option #4 to rebuild the database.

     

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

    1 - download iPhoto Library Manager and launch.

     

    2 - click on the Add Library button and select the library you want to add in the selection window..

     

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option.

     

    4 - In the next  window name the new library and select the location you want it to be placed.

     

    5 - Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the probl

    Happy Holidays

     

    em or in case the rebuilt library is not satisfactory.


  • photosb189 Level 1 Level 1 (60 points)

    Have you tried creating a second library and testing the crop function there? If the problem still occurs, then you may want to try creating a new user account (in System Preferences) and trying iPhoto there. This will help you isolate the problem and determine if it is limited to the Library, user or system wide.

  • artsquawk Level 1 Level 1 (0 points)

    I tried Fix #1; didn’t work, so I will keep taking steps as others have so generously recommended.  I will say - this had never happened in all the years I’ve (happily) used iPhoto - until I updated to Mavericks and innocently to iPhoto 9.5.  Saying, this doesn't appear to be "my problem” but now indeed it seems it is….

  • henryauhk Calculating status...

    you are not alone. I have the same issue even I make a new library with 50 pics

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.