10 Replies Latest reply: Jul 9, 2014 9:56 PM by pumptronics
KoenraadVL Level 1 Level 1 (0 points)

Hi,

 

My iTunes updated last night to 11.1.3.

Now we can't use Airplay anymore... The icon is missing and resetting Networks is not helping.

Also AppleTV is nog working on AirPlay!


iMac, OS X Mavericks (10.9)
  • 1. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    adamjohnsonshort Level 1 Level 1 (0 points)

    I was looking at previous ways of solving this problem on upgrades in the past.........open miniplayer and select your Airplay device.

    It didn't play for me until I then quit and re-opened iTunes ...hopefully this will work for everyone else

     

    Good luck and hopefully stop stressing...I did!!!!

  • 2. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    Krayos Level 1 Level 1 (10 points)

    Hi KoenraadVL, last night I upgraded to 11.1.3, same problem as you, I restarted my computer but still no Airplay, I remembered when I had problems with iTunes Match often I found the solution was to sign out and then sign back in again. I thought I'd give this a go............ I signed out, shut iTunes, then I restarted iTunes and everything was back to normal. I didn't even need to sign in again

     

    Hope this helps you or anyone else experiencing this problem.

  • 3. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    ctnyc100 Level 1 Level 1 (0 points)

    I had this very same problem.  I followed Krayos' suggestion but it didn't work so I tried it again.  This time, after signing out and closing itunes I restarted my macbook pro - when I re-opened itunes the airplay icon was there.

     

    Hope this helps...and thanks Krayos!

  • 4. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    Aggienator Level 1 Level 1 (0 points)

    iMac OSX 10.8.5 here. I have experienced the loss of airplay as well, but sadly having done the above and shut down/restarted the iMac I still can't access Airplay

     

    Wondered if anyone has any other suggestions..

  • 5. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    Aggienator Level 1 Level 1 (0 points)

    Having switched off and the back on my ATV and Airport express they have reappeared No idea why!

  • 6. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    RemonJap Level 1 Level 1 (5 points)

    1) open control panel.

     

    2)Choose Network and internet

     

    3)Select the VIEW NETWORK STATUS TASKS under NETWORK and SHARING CENTER section

     

    4) Choose the active network connection. It is usually name " wireless Network Connection 1" or something similiar.

     

    5) Click the properties button

     

    6) If the Internet PROTOCOL VERSION 6(TCP/IPv6) is checked, uncheck it, then click OK.

     

    7) Click CLOSE

     

    8) Restart iTunes and try to use the Home Sharing feature again.

  • 7. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    Pieterjanbiz Level 1 Level 1 (0 points)

    Same problem here. Feels like wasting 800 euro on a B&O Beolit 12.

  • 8. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    nico_147 Level 1 Level 1 (0 points)

    Hi Guys,

     

    after installing 11.1.3, same problem on Maverick. Then I figured I would "reconfigure" my Airport Express. I opened "Airport Utility", and no need to reconfigure anything : it immediately triggered the Airplay icon to reappear in Itunes.

     

    By the way, because I still have an old Airport Express (it works perfectly, so I refuse this programmed obsolescence), I have to use Airport Utility 5.6.1....which Apple doesn't support anymore in Mavericks.

     

    Thanx to Corey Mahler  and its excellent "Airport Utility 5.6.1 Launcher"  it was not a problem :

    http://coreyjmahler.com/2013/10/24/airport-utility-5-6-1-on-os-x-10-9-mavericks/

     

    Hope this helps,

  • 9. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    bknewhaven Level 1 Level 1 (10 points)

    I also have a Rx-675 which works fine with the Yamaha app on iPad and iPhone, but it can't Aiplay with my iMac and Mavericks 10.9.2. No Airplay icon in menu bar. Is this me or a Mavericks problem?

  • 10. Re: iTunes 11.1.3 Airplay does not work (OS X 10.9)
    pumptronics Level 1 Level 1 (0 points)

    Likewise, I have a Yamaha RX-V473 which plays music via airplay from iPhone/iPad without problems. Since I upgraded my Mini to Mavericks (now 10.9.3) the iTunes airplay to the Yamaha is intermittent and after a song or so it gives up and shows an exclamation mark in iTunes on the Mini.

     

    I eliminated the problem by doing two things (all from other recommendations):

    Created a /etc/sysctl.conf file containing the line:  net.link.ether.inet.arp_unicast_lim: 5 -> 0

    Disabled IPv6 on the ethernet interface by using the command:   networksetup -setv6off Ethernet

     

    I was very pleased to have my music back but (as I now learn Bonjour needs IPv6) now my iPhones will not sync to iTunes remotely (wifi to the ethernet interface via a router - the Mac Mini wifi interface is disabled). If I re-enable IPv6 the airplay bombs out but the iPhone sync works!

     

    All airplay music and syncing via wifi worked fine before the Mavericks upgrade. Needless to say, airplay to an airport express device was not affected by the upgrade, just the Yamaha. I'm pretty annoyed to have to delve into the unix commands to fix something like this. The reason I bought a mac was to NOT have to fiddle about for hours troubleshooting. Combined with "beach-balling" my iTunes often, I think the networking in Mavericks is gash with SMB problems and spurious ARP broadcasts. There's nothing wrong with Yamaha's implementation of airplay and there is nothing wrong with my network set up. So now I have to contemplate a roll-back or more hours of troubleshooting. Apple, ***?