Skip navigation

What is error code -50?

20683 Views 15 Replies Latest reply: Dec 19, 2013 3:41 AM by jpacooper RSS
1 2 Previous Next
Rararak Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 6, 2012 10:43 PM

I have been receiving this error code whenever I try to move files to other folders, copy/paste them, or trash them:

"The operation can't be completed because an unexpected error occurred (error code -50)."


I can't empty the trash, either.


Two more problems.

1) I have been getting this message when I try to open certain pages in Safari:

"Safari can't open the page (insert URL here) because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again."

I don't get it for all webpages, though; it's been popping up for Facebook and several Apple-associated sites (like Apple Support). I'm getting a blank white page for Gmail and Twitter, but if I wait long enough they eventually show the previous "unexpected dropped connection" message as well.

I've cleared my cache, gotten rid of cookies, and reset Safari--nothing's been working.


2) Disk Utility is not opening for me. Well, I can see it in my sidebar, but when I click it there is no pop-up with which I can access Disk Utility itself. It says that the application is not responding and I have to Force Quit it.


All three of these problems surfaced today.


My Mid 2009 13" Macbook Pro is running on Mac OS X Lion 10.7.4 with Safari version 5.1.7; I recently replaced my hard drive with an SSD.



Another note: System Information (Apple sign --> About This Mac --> Get More Info) failed to respond when I clicked on the "Storage" tab (not for the others).

MacBook Pro, Mac OS X (10.7.4)
  • AnaMusic Level 9 Level 9 (55,060 points)
    Currently Being Moderated
    Jul 6, 2012 10:44 PM (in response to Rararak)
  • clintonfrombirmingham Level 7 Level 7 (26,655 points)
    Currently Being Moderated
    Jul 6, 2012 10:51 PM (in response to Rararak)

    Try to reboot to the Recovery disk (Command-R on boot) and use Disk Utility from there to verify and, if needed, repair your SSD. Call back with the results. While you're there, try repairing permissions both before and after you verify/repair your SSD.


    What brand of SSD do you have. Some (Samsung 830, amongst other) have been having some trouble with Mac's.



  • Linc Davis Level 10 Level 10 (107,380 points)
    Currently Being Moderated
    Jul 6, 2012 11:31 PM (in response to Rararak)

    Launch the Terminal application in any of the following ways:


    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.


    Drag or copy — do not type — the following line into the Terminal window, then press return:


    diskutil list


    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • clintonfrombirmingham Level 7 Level 7 (26,655 points)
    Currently Being Moderated
    Jul 7, 2012 7:39 PM (in response to Rararak)

    Yes, the "Macintosh HD" is the one that needs to be repaired. I believe that you said that you have a Samsung 830 series SSD? I've noticed quite a few posts here with folks having problems with the 830 series and Mac's.


    See if Samsung has an users forum and post a question on there concerning the 830 series in a MBP. Some people have had problems, some not. I don't know if there is a firmware upgrade that would fix your problems or not, but I'd check. Google "samsung ssd 830 users forum" and the top hit will be (should be) a MacRumors forum. Check it out.


    Good luck,



  • gulfcoaster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 12, 2013 11:40 AM (in response to Rararak)

    Did you resolve this problem? Or does anyone have a solution? I have almost an identical situation in every regard.

  • rj3000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 8:58 PM (in response to Linc Davis)

    My symptoms seem very similar to this person.  After a few minutes my browser (Chrome is my default) slows down and stops. Other services, like Finder also start crashing and I get the error - 50 message if I try to copy a file.   If I switch to Safari I get the "dropped by server message for Facebook, Twitter, Google but not necessarily "smaller" independent sites....  System (Hitachi MacBookPro running OSX 10.6.7) started to get flakey two days ago.  I did an applejack disk repair (apple disk utility said I had a disk error). Repair was successful.  Now I'm running applejack for cleanups which seem to provide a few minutes of stability.


    I ran the terminal as you described:



    Last login: Mon Jul  1 19:14:40 on console

    -MacBook-Pro:~$ diskutil list


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *160.0 GB   disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:                  Apple_HFS Untitled 1              159.7 GB   disk0s2

  • rj3000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 9:56 PM (in response to rj3000)

    Updated software to OSX 10.6.8.... If you don't see me back here then you can guess that fixed the issues....

  • PatrickFromFr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2013 10:12 AM (in response to Rararak)




    Since July, I have the exact same problem than rj3000. Indeed I tried to repair my computer by verifying the permissions and my Disk. The result was that it has repaired something, but I can only have a fully fonctioning computer for 5 or 10 minutes. After that i can't launch any sofware correctly. Even Safari won't work on websites such as Facebook or Gmail.

    If I launch Words or Excel I won't be abble to save any file.

    An other exemple is if i launch skype, during the launch of the software I will have an error message saying that it's impossible to creat a "lock file" (i'm not sure for the translation, in french it's "fichier vérrou").
    If I try to empty my trash, i'll get an error code - 50.


    I tried to copy diskutil list into the Terminal window, but it had no effect when I pressed return.


    I don't now if it can help, but I'm using Mountain lion 10.8.4 on a 4 years old MacBook Pro 13", and I had this problem since I did an update of airport. I don't know if it's linked..


    I'm wondering if this problem isn't linked to the SMS witch could lock the hard drive?


    Thanks for your help.

  • pappyhammer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2013 5:36 PM (in response to Rararak)



    I'm having the exact same situation with my mac for a few days now. With Kernel Panic from time to time, and an error code -50 after few minutes of activitites.


    Did you find a solution by any chance ?





  • GoGfried Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2013 2:00 PM (in response to Rararak)

    Same issue here.


    Any finding any knowledge to share?



  • pappyhammer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2013 12:13 PM (in response to GoGfried)

    I've found that while my external hard drive is plugged, then i have no error code -50 and can then use my mac for any longer i want.
    The kernel panic disapeared with the maverick update otherwise.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.