Skip navigation

Installed Mavericks and now my system partition needs repair

46068 Views 93 Replies Latest reply: Mar 4, 2014 7:19 PM by MeTooooo RSS
  • leeb00 Level 1 Level 1 (0 points)

    I had the same exact errors tonight. I have a 2012 Macbook Air. I installed Mavericks about 3 days ago.

     

    - The system got extremely bogged down while I was running VMWare Fusion (Win XP). Difficult to reboot, but finally was able to reboot into the Recovery Partition.

     

    ** "The partition map needs to be repaired because there's a problem with the EFI system partition's file system"

    ** Problems were found with the partition map which might prevent booting"

     

    - So I booted in the Recovery Partition, and Disk Utility could still not fix the partition.

     

    - FIX: I then booted from a USB backup hard drive (which was created with SuperDuper) and used Disk Utility to check the internal drive. It showed no errors at all!

     

    - So I reset SMC and PRAM, and booted into Safe Mode (for good measure, to run the automatic maintenance scripts)

     

    - After rebooting into normal mode, everything seems fine now.

     

    I hope this helps.

  • jamesfromoakland park Level 1 Level 1 (0 points)

    Hi Pascal,

     

    I have had pretty much the same findings as yours.  Also, my internal drive is Seagate and all external drives are Seagate with a couple by Hitachi.  No Western Digital anything and no RAID; now or ever before.

     

    After all the above iterations, I finally reinstalled a clone of Mountain Lion and updated it to 10.8.5.  I disconnected everything except the ethernet cable and rebooted.  Then made sure there were no more updates.  So basically, I had a clean installation of Mountain Lion with all the most recent updates, but nothing else installed or connected.

     

    Then I booted into the recovery partition 10.8.5 via the Option key and found absolutely no problems or errors when running Disk Utility on the Disk or its volume.  No problems with Verify or Repair on either Disk or Volume.

     

    So I proved this problem didn't exist with at least my version of Mountain Lion 10.8.5 and all other variables removed.

     

    Then I did an in place install of Mavericks.  That is to say, I did it via the App Store, exactly the way Apple intended it, without any alterations, making USB boot drives, etc.  I wanted to eliminate all those variables as the potential problem.  So after the in place upgrade to Mavericks, I installed the couple of Mavericks updates, iBooks and Mail, I think it was, then rebooted.  No problems so far.

     

    Then I had as clean an installation as I could get via the manner Apple intended and booted into the 10.9 recovery partition via the Option key.  Guess what?  I got the exact same problems I did before.  So I tried to boot using Command-R and got the exact same problems I did before.

     

    By the way, I'm referring to the ("The partition map needs to be repaired because there's a problem with the EFI system partition's file system") problem and the Alert!

     

    I think this isolates this down to a problem with either Maverick's Disk Utility &/or Recovery Partition.   Agree?

     

    I am also having all kinds of spinning beach balls, system slow downs, sync problems and all kinds of issues that are often fixed by using disk repair or permissions repair.  It is the kind of stuff that usually eats your lunch, if you don't address it.  I'm concerned that one day my system won't boot and data will be lost.  I spoke to AppleCare and the first person gave me to a higher level guy who said that since I could verify and repair the partition using an external hard drive or USB stick installation, that 2 out of 3 probably meant that I didn't have much to worry about.  Somehow, that did not give me much hope that I don't have much to worry about.

     

    So I'm not sure whether to tough it out and make backups every few minutes of work or just go back to Mountain Lion until they fix this.  Are they going to fix this?

  • subsonicsky Level 1 Level 1 (0 points)

    I used Mountain Lion Recovery a lot and I've never had any problems with it. I think Disk Utility in Mountain Lion skipped the recovery partition when it did repairs.

     

    I think the problem with Mavericks Disk Utility is that the recovery partition isn't skipped when it performs repair and verification. And if you boot from the recovery partition and perform a repair from there, you can pretty much expect problems since the recovery partition is mounted at that time.

     

    I've tested this quite extensively and here are my findings:

     

    • If you boot from an external drive like a Mavericks install USB drive, there will be no problems whatsoever.
    • If you boot from the Mavericks recovery partition and verify the whole disk, there still won't be problems.
    • If you boot from the Mavericks recovery partition and repair the whole disk, you'll get the "live file system repair is not supported" error.
    • It gets worse from there. If you then click "verify" after getting the "live file system repair is not supported" error, Disk Utility will throw a new error: "the partition map needs to be repaired because there's a problem with the EFI partition's file system".
    • At this point, there is still no data loss so you can still walk away. If you're still persistent and click "repair" after getting the error above, Disk Utility will create a new EFI partition while blowing away your existing one.
    • At this point, Boot Camp and FileVault 2 partitions will no longer be bootable. Regular unencrypted OS X partitions, however, will still be fine.

     

    If your Boot Camp partition was fried, start minimizing your losses. Boot into OS X, mount the Boot Camp drive, copy out your Windows files, then reinstall Windows.

     

    If your FileVault 2 partition was fried, decrypt it using Disk Utility or terminal commands. Once decrypted, it should once again be bootable.

     

    I think I'll stay with Mountain Lion until 10.10 comes out. And that's when I'll upgrade to Mavericks.

  • jamesfromoakland park Level 1 Level 1 (0 points)

    Yes, but I think that if you boot again into your system's recovery partition and run disk repair on the main disk, you will find that you have the same problem.  (Meaning the problems as outlined by subsonicsky and myself below.)  At least that is what happens to me.  Some recovery partition, huh?

     

    So basically, we do not have a functioning recovery partition in Mavericks, right?

     

    Does anyone know if this EFI problem represents a real problem?  I don't use BootCamp or FileVault so haven't experienced the complete loss of bootability, as subsonicsky mentioned.  However, I worry that I might and am experiencing ongoing system issues with apps hanging, slow downs, spinning beach balls, etc.  Everything that would tell you there is a problem, back up your data!

     

    I think it is safest to revert to Mountain Lion, but that is not exactly simple to do because of iCloud integration, etc.  I'm trying to wait it out with very frequent backups, but it is killing my productivity and who knows when/if Apple will fix this.

     

    Anyone have any thoughts about what is best to do? 

     

    Thanks.

  • jamesfromoakland park Level 1 Level 1 (0 points)

    Yes, Tyler_Zyco, you should be worried or at least that's what I think.  I provide as evidence the many people who have ended up with non-bootable systems.  That is apparently more likely if you use File Vault 2 or BootCamp and although I do not use those, I do not find that very reassurring.  I would venture to guess that partition problems cause more data loss than anything, except perhaps malware per se and definitely more than failing hard drives.

     

    If my Mavericks installation was operating without any problems, then I might be convinced this was not much to worry about, but that is not the case.  After multiple installations of Mavericks, I am still having multiple problems, app hangs, system slow downs, spinning beach balls, etc., etc.  This is occuring on an iMac with a Seagate HDD and on a MBP with a Hitachi HDD.  No SSDs involved for me.

     

    Even a brand new installation has 100s of permissions problems that when fixed don't change anything and reemerge as soon as you reboot and then reboot to recovery and recheck permissions.  This happens without even opening another app.  Surely, that shouldn't be!

     

    I had one AppleCare tech tell me it was not a problem and another tell me to revert to Mountain Lion.  Again, I don't feel reassured.  This is killing my productivity.  I have never had a fraction of this much trouble with any Apple upgrade and am hugely disappointed.  There are some pretty major problems out there with this one and reverting is not very easy to do.  Man I hope they get this stuff fixed promptly!

     

    Until then, I think they should call it Mavericks Vista!

  • subsonicsky Level 1 Level 1 (0 points)

    Boot Camp requires a Hybrid MBR to work. Filevault 2 on the other hand, uses the EFI system partition to first boot and show the initial light grey login screen. When a "repair" is attempted by Mavericks' buggy Disk Utility while booted in the recovery partition, it seems like both the EFI System Partition and the Hybrid MBR are erased and reset/rewritten, thus preventing the system from booting into any existing Boot Camp and FileVault 2 partitions.

     

    Here's a link containing some info on the Hybrid MBR and the EFI System Partition: https://developer.apple.com/library/mac/technotes/tn2166/_index.html

     

    These are just my impressions from several hours of testing on my old MacBook Pro, and I don't know if I'm 100% right in my understanding of Mac internals. Honestly, I no longer have the patience nor the time to do any more research and testing beyond what I already did; this kind of thing should have been done by Apple engineers after all, and not us end users.

     

    My personal recommendation for now is to never use the Mavericks "recovery" partition for anything. Do yourself a favor and keep a Mavericks install disk handy and just boot from that whenever you need to do recovery tasks. The more technical users among us can save space by burning just BaseSystem.dmg and not the full blown installer (look this up on the net if you're interested). I also don't recommend deleting the recovery partition despite it being buggy, because a future update might be able to fix it. Just leave it there and never use it.

     

    If you were using FileVault 2 and can no longer boot your computer because of this, try decrypting the partition manually (there are many ways to do this; look it up on the net). I was able to revive my test machine with this approach.

     

    If you had a Boot Camp installation that no longer works, as I pointed out earlier, just minimize your losses, mount the NTFS partition from OS X, and copy out whatever data you can. (anyone with a better solution, please do let us know!)

     

    Or if you're still on Mountain Lion, stay on Mountain Lion until this issue is solved.

  • Woo Level 2 Level 2 (200 points)

    Jus an update to what I've experienced with this "repair partition" via mavericks problem...the original hd in my 17" mbpro with the seagate hybrid drive after many attempts of diskwarrior, I was finally able to erase the hd and it's waiting to be backup restore drive. 

    The current 10.9 hd in my mbpro is also a seagate hybrid hd, restored from a good time machine backup 'BEFORE' I ran disk utility on it. 

  • Jeff Jay Level 1 Level 1 (25 points)

    Perhaps I've been lucky, but I seem to have had a pretty easy time recovering from the dreaded: "Error:  Live file system repair is not supported."

     

    Granted, I got this on an external 800 firewire drive (OWC). Following some random tips from the web, I shut down completely and restarted. Then shut down again and restared from the Recovery Drive (Cmd-R). Ran disk utility and voila, it fixed everything without a quibble.

     

    As many of you know, there are various Unix routines that are run at Start up. Don't know why I got so lucky, and of course it was an external drive (with 2 partitions).

  • benziine Level 1 Level 1 (0 points)

    Solution to the Mystery - almost

     

    1     Shut down

    2     Boot WITH OPTION + r into the Recover Partition

    3     Repair Drive and Volume -- all is perfect

    All this on a MBP Retina 15 with 512GB SSD

     

    BUT

    Start with OPTION key -- then select Recover Partition

    Then Repair Drive

    And...

    the LIVE REPAIR error comes up

     

    Does this give a hint as to where the error comes from?

    ben

  • subsonicsky Level 1 Level 1 (0 points)

    Jeff Jay, I think the error message always shows up on any version of Disk Utility if you attempt to do a repair on any mounted partition. Would you be able to recall if your external drive's partitions were mounted during the time you got the error?

     

    If you boot from the internal drive's recovery partition and attempt to repair an unmounted external drive, the operation will most likely succeed because the drive will likely be unmounted.

     

    The problem we're seeing in our computers is when we boot from the internal drive's recovery partition and attempt to repair the internal drive itself. Before Mavericks, the recovery partition is skipped and the operation succeeds. On Mavericks, however, Disk Utility won't skip the recovery partition, attempt to repair it, and fail with the "live file system repair not supported" error message.

     

    Or at least, that's how I understand it. Please correct me if I'm wrong.

  • subsonicsky Level 1 Level 1 (0 points)

    benziine, I also had the same experience on my 2010 MBP. If I boot into recovery using Command+R, Disk Utility will verify and repair the disk without problems, but if I hold down Option at startup and manually select the recovery partition, I would get the "live file system repair not supported" error when I try to verify and repair.

     

    The strange thing is that on my 2008 MBP, I always get the error regardless of whether I use Command+R or the Option key.

     

    I did a fresh install of Mavericks on both machines using the same USB drive.

  • Wally David Level 1 Level 1 (0 points)

    My Solution - I was getting the error  "Live file system repair is not supported"... and was unable to resize my 10.9 mac partition to use the full space of a drive after deleting a suddenly failed Windows 7 bootcamp partition.

     

    Here is what solved my problem, your mileage may vary.

     

    My bootcamp partion failed and would not boot or show up as a selectable boot disk from the startup disk manager in system preferences or by holding option and having it avalable as a selectable boot disk.

     

    There are a few things that changed right before this. I bought a new toshiba backup drive from best buy which was formatted by default as NTFS. Because I was mainly going to use it as a back up drive from my windows partion I opted to leave it NTFS and installed the Tuxera NTFS driver that came with the disk. This is what I believe was the first issue. After about two weeks and 20gigs of the new Elder Scrolls beta, i was out of room on the bootcamp drive and decided to repartition it to giveit  an extra 50 gigs... the resizing failed and that was the start of my troubles. After that the windows partion would not boot. The windows partition WAS still available from the mac side so I backed it up with carbon copy and started the process of re-installing windows via bootcamp because no matter what I did I couldn't get the windows partition "blessed" or bootable again.

     

    I opened disk utility and tried to delete the bootcap partition.. i cracked open bootcamp to start again but it would fail on the windows re-partion. I ran verify disk on the drive and it said it had errors. The NTFS partion was deleted but disk utility would not reclaim the space..

     

    Here is where part two of what I believe the problem was.. I totally screwed up while trying to re-re-format the bootcamp partion and deleted a backup mac partion that had a bunch of files on it.. so I downloaded DiskWarrior.. which failed to repair the main parition,  the boocamp partion or recover any file from the dive I accidently erased.. so I found a ulility called diskdrill to try and recover the partion I deleted, putting recovering the space from the bootcamp partion on hold...

     

    When I installed disk drill, it asked me if I wanted to let it monitor my S.M.A.R.T. status of my drives.. I said yes, because I though that sounded like a good idea.. Ii recoved my files from my drive nicely and I started back with the recaiming the space of the failed bootcamp drive. This is when I started getting the "Life file system repair is not supported" error.. I ran disk utility, I ran DiskWarrior again.. both repaired the drive this time, both said the drive was fine.. neither would resize the mac partion to reclaim the bootcamp space.

     

    I finally found this thread.. and I read the part about the Tuxera NTFS drivers and the MacFuse drivers causing issues with formatting the drive. This is when I noticed the that when these drivers are loaded, Disk Utility has (2) NTFS formatting options available from the partition manager. You can format as "NTFS" and then you can format as "NTFS_Tuxera". I believe that if you triy to parition a drive with either the Tuxera or MacFuse software installed and try to partion your drive, you will loose the ability to boot from the drive, mainly because I think Disk Utility defaults to the Tuxera_NTFS ans not the Apple NTFS supplied with Disk Utility. What ever the Tuxera NTFS is, as far as I can tell, is not supported when booting. It must change the flavor or the NTFS type so that apple doesn't recognise it as a bootable partion anymore... SO.. DELETE or DISABLE Tuxera or MacFUSE before changing any partion sizes.. This fixed my ability to make a bootable windows partiton. HOWEVER.. i still got the error about the "Live File System Repair Is Not Supported.."

     

    OK.. now, as far as the the error... I could finally boot a windows drive and it showed up in the system boot disk selector.. but I was still getting the error. After one of my many recovery disk boots, I actually saw something that I'm not sure how I missed before.. when It was throwing that error, in the details window, the repartioning failed because it could not "unmount" the drive to finalize the re-partion..  Nothing as far as I could tell was using the drive, so why it was failing to unmount had me scrathing my head..

     

    Remember that DiskDrill software I installed that asked me to monitor my S.M.A.R.T. status?.. well i disabled it.. and wa-la.. the error went away while using disk utility from the recovery disk and I was able to resize my partition. I reproduced this three times to make sure that was it.. but thats just the recovery disk version of disk utility..

     

    when I booted to the desktop and tried to repartion I was getting the same error again.. so I removed iStat-Menus (which also monitors S.M.A.R.T status.). and wa-la! I could re-size partitions and created new partions at will with no more errors...

     

    Everything is working as expected now.... 

    Moral of the story.. Delete or disable any third party NTFS drivers like tuxera or macfuse before partioning or re-partioning your drives.. then disable any third party software that monitors your your S.M.A.R.T. drive status like DiskDrill or iStats-Menu..

  • lightcaress Level 1 Level 1 (0 points)

    SOLVED:

     

    JUST USE INTERNET RECOVERY (CMR + ALT + R)

     

    After spending time with Apple Support, Support @ Apple Retailers who wanted to exchange the SSD, etc I just used internet recovery after trying every other possible solution listed everywhere.

     

    So the EFI partition can't be checked because the normal recovery locks it for some reason. I did disk utility verify on it -> live error message, the check -> responded with efi problems. No way to do anything.

     

    Internet recovery actually boots not from the SSD so it's kept unlocked.

  • subsonicsky Level 1 Level 1 (0 points)

    lightcaress, yup I think that would work. It's the same as booting into Recovery from an external drive. As long as you don't boot from the system drive's Recovery partition, it should work fine.

     

    However, I personally wouldn't call that a solution; it's better to call it a workaround. Hopefully we'll see the true solution (i.e., a  Recovery partition that doesn't om-nom-nom-nom users' data) when 10.9.1 comes out.

  • lightcaress Level 1 Level 1 (0 points)

    I haven't actually lost data in this case.

    However important to note is that there is currently no way to boot a late 2013 retina from an external medium like USB drive. This is a known problem, the system shows a denied sign.

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.