Skip navigation

Thunderbolt Display turns off randomly

63046 Views 394 Replies Latest reply: Apr 3, 2014 6:24 AM by Tim Hassett RSS Branched to a new discussion.
  • Christopher Twomey Calculating status...
    Currently Being Moderated
    Nov 1, 2013 10:04 AM (in response to gadget_aussie_man)

    Obviously there are different experiences, probably different problems, and it seems some faulty manufacturing.  But for those coming to this issue for the first time, it is worth trying a quick SMC reset, just in case.  That did the trick for me, thankfully.  (All of a sudden, the screen itself had was dead, sometimes passing through power over USB or data over Thunderbolt daisy chained drive, but mostly nothing. USB keyboard never worked in that time.)

     

    (Running a 27" Thunderbolt display off of a mid-2012 MacBook Air with Mavericks)

     

    Hope it stays fixed, although from the sound/quantity of above, probably not... 

  • Pappa3x11!! Calculating status...
    Currently Being Moderated
    Nov 1, 2013 10:09 AM (in response to OWC Larry)

    OWC Larry:  I used a cable I purchased at the Apple Store.  Bypassing the TBD built-in cable, I simply plugged it in to both the MBP and TBD.  It worked at the store (MBA and TBD) last week.  Guess I need to talk with the Apple Store and get something set up.

     

    Thank you for your response.

     

    Ron

  • OWC Larry Calculating status...
    Currently Being Moderated
    Nov 1, 2013 10:11 AM (in response to Pappa3x11!!)

    Sounds like you already did resets on the computer side... and that's good to know should the integrated TB cable fail on a TBD - learn something new everyday.  Bummers though.

  • stevenfrombrüggen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 11:26 AM (in response to Pappa3x11!!)

    I had this happen with my flickering TBD and MBA. I had audio but no video for a while but by messing about with it I eventually got the video back. The flickering problem remained though. I basically did things like open the display on the MBA, take out the TB connector, clode the lid, put the connector back in, reboot, change the order of connecting it all together etc etc and it eventually came back.

    Unfortunately I have no idea what I did that brought it back.

  • stevenfrombrüggen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2013 12:58 PM (in response to stevenfrombrüggen)

    Update:

    I have my TBD back after 10 days, and they told me that the multi-TB-Power-cable was faulty and changed it. I have used it all day today without any problem. Let's see how it goes.

  • bond604 Calculating status...
    Currently Being Moderated
    Nov 8, 2013 11:39 AM (in response to gadget_aussie_man)

    I had the same problem, it only seemed to start happening in the last couple weeks for some reason. The display would blank after a period when connected to my relatively new MacBook Pro, and also on my week old Mac Mini. I borrowed a thunderbolt cable from work, and connected through that instead, and the display has been working flawlessly since (except that it doesn't wake from sleep on the Mac Mini)...

     

    My theory is that the electronics in the cable didn't like getting plugged and unplugged all the time or something! My 2nd thunderbolt display seems to be starting to display the same behavior as well unfortunately, when I touch the cable connector the display goes dark ...

  • stevenfrombrüggen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2013 2:35 AM (in response to bond604)

    my TBD is still working after a couple of weeks so the replacement combi-cable for the display seems to have done thee trick. It even wakes from sleep with my MBA when I click the mouse (which is connected to an ancient Apple keyboard from my old PPC MDD machine, the keyboard being plugged into the TBD as well). So everything is working, attached Firewire disk, Ethernet, USB, the whole thing.

     

  • OWC Larry Level 1 Level 1 (45 points)
    Currently Being Moderated
    Nov 21, 2013 7:16 AM (in response to stevenfrombrüggen)

    That doesn't surprise and surprises me even less with our latest findings at OWC.

     

    We acquired a Mac mini from a customer that was demonstrating the issue a couple weeks ago. Been trying to get our hands on one we could repeat with for a while.

     

    This particular Mac mini which was shown to be exhibiting the Thunderbolt flicker issue at the customer's site - has ZERO issues with our Thunderbolt display and other displays at our site. Same OS, same everything - only difference is we don't have the Thunderbolt display that was in question. To be clear - we could not cause any issue to occur with this 'confirmed issue' Mac mini and our Thunderbolt display and other displays used in replication testing. ZERO issues.

     

    This issue, we strongly believe, is one related to line noise and/or interference on the connecting cables used with external displays connected via Thunderbolt/Displayport.

     

    The Mac mini we swapped the customer to also has no issues now for the customer.

     

    This leads to reasonable conclusions:

    Different Mac minis are more or less susceptible to interference/noise on this video line and/or have more or less inherent of a video chipset related issue.

     

    Different Thunderbolt displays have better or worse cable assemblies with respect to noise they will or won't add.

     

    And - we already knew this and goes right in line with the above - different mini-Display Adapters and display cables are of better or worse quality - (here's an example: http://www.newertech.com/video/ ) and have already seen new cables be the solution for some customers.

     

    This is also reinforced by plenty of examples of completely stock MacBook Air and Retina models (which use mobile chipsets like or similar to the mini in tight quarters) also having varying degrees of issue.

     

    Without a doubt, Apple has done a lot to improve this via EFI/Firmware updates over the past year - with the largest improvement probably in February of this year.

     

    If you have a Thunderbolt display with the issue - might be worthwhile trying a different Thunderbolt cable from the display to the system vs. the built in to see if that helps at all too. Either way - this is an issue inherent to these systems.

     

    Hope this helps.

  • hugo8 Calculating status...
    Currently Being Moderated
    Nov 22, 2013 5:49 AM (in response to gadget_aussie_man)

    I have a mid 2011 Mini and the Thunderbolt display.

    I have used this combination for several years  with no problems whatsoever.

     

    Then a few months ago the problems started. Blinking and then blank display.

    It got worse, and it is now super bad. I have the TB display stored away in my closet.

    I now use two other HD monitors, working great..

     

    Summary:

     

    - no problem, wonderful experience for more than a year

    - no changes to the hardware, just OS upgrade, etc.., then the problems started to appear

     

    3 guesses:

    - some hardware went bad, or some hardware parameters got worse

    - OS upgrade or other upgrade causes the problem, as I remember after the Mountain Lion upgrade I started to have problems with the power saving functionality

    - hardware got dirty, and the TD or the  Mac display hardware or the Cable gets too hot

     

    - Mavericks did not resolve this

    - new cable did not help

    - changing memory to the original set (from 8GB to 4GB) - did not help

    - all the tricks explained here - did hot help

    - the inside copper (or whatever) of the TD cable gets hot

    - when it started, switching off the display, turning it on (hardware power off-on), helped for some time, sometimes it worked ok for hours, days

    - now, when I freshly switch on the system (all power off-on)  it works for a few minutes, sometimes not at all

     

    Does anyone experience this with pre Mountain Lion releases?

    Still do not know which part is the culprit, the display, the cable, the machine, or the software.

     

    The TB is now waiting for better times...

  • stevenfrombrüggen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 5:56 AM (in response to hugo8)

    I would be concerned about the cable getting hot - is this the combination cable that comes woth the TBD with the power connector and the TB connector? or do you mean the power cable for the display?

    If it is the combi cable, then if you are using a mac-mini you don't need to supply power from the display to the mini, in that case I can not understand why it would get hot? If you mean the display powert cable, then I would say that that cable really shouldn't get hot either.

    It certainly implies that something is drawing a lot of / too much current.

    Can you test with a different computer?

  • krbmedia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 2:38 PM (in response to stevenfrombrüggen)

    Not sure if it's Mavericks or what but I have no had an issue in weeks.

  • bsupport Calculating status...
    Currently Being Moderated
    Nov 25, 2013 4:11 AM (in response to gadget_aussie_man)

    Using a factory Macbook Pro Retina 15 inch 2012 as the machine and then I connect to a (believe its 2011) 27 inch imac used as the second monitor via a thunderbolt cable.  All factory.  MBPR has recently had a logic board replaced, its own monitor replaced (due to many burnt out pixels), and has had the thunderbolt cable replaced.  The flickering issue still persits.

  • Jill Bauerle Calculating status...
    Currently Being Moderated
    Dec 18, 2013 8:39 AM (in response to gadget_aussie_man)

    My thunderbolt display had been having problems connecting for a few months, and suddenly went dark one day. However, the power cord still worked. Techserv suggested that I try plugging in a different thunderbolt cord, and it worked! If you're having similar problems, just try a new cord. It will save you from lugging the monitor to the genius bar or Tekserv!

  • clintonfrombirmingham Level 7 Level 7 (26,745 points)
    Currently Being Moderated
    Dec 18, 2013 9:33 AM (in response to Jill Bauerle)

    Jill Bauerle,

     

    Which Mac do you have? When you say that you just changed the Thunderbolt cord do you mean the entire Y connector assembly?

     

    Curious,

     

    Clinton

    MacBook Pro (15-inch Late 2011), OS X Mavericks, 16GB RAM 512GB SSD Apple TB Display
  • OWC Larry Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 18, 2013 10:54 AM (in response to Jill Bauerle)

    I have to say - it's rather concerning and disappointing that the built-in/hard wire integrated Thunderbolt cable is failing on these displays as now multiple parties have reported here. Good that a new Thunderbolt cable connected to what would otherwise be open for daisy-chain, etc prevents an expensive repair to an out of warranty display.... but none the less. If within warranty, I'd lug it in to get fixed/replaced right.

     

    The new Mac Pro is announced to go tomorrow, wonder when will see new Thunderbolt displays. I can not believe it's going on almost 3 years now since the current and only Thunderbolt display was made available... and not even an update to USB 3.0 hub ports made to it... and these kinds of issues persisting. hmmmmm

1 ... 21 22 23 24 25 ... 27 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.