1 2 3 4 Previous Next 51 Replies Latest reply: Apr 6, 2014 10:03 AM by martley Go to original post
  • 45. Re: Airport express drops off network
    JimmyBear Level 1 Level 1 (0 points)

    Thank you Wilson, I'm having the same dropped music connection problems (which I never had before).  I'm working off a 1st gen Express and can't believe that Apple has resorted to a cable connection solution either.  After playing with different firmware versions, I am finding that 7.6.1 is holding up fairly well.  No cable. 

  • 46. Re: Airport express drops off network
    Niels-SA Level 1 Level 1 (0 points)

    I experienced similar dropped connections with both my Airport Express (used for music streaming) and my Airport Time Capsule. Unplugging and plugging in again only solved the issue for a couple of minutes. Downgrading the firmware of only the Airport Express to 7.6.1 did it for me. Now both the Express and Time Capsule remain part of the network without having changed anything to the settings of the modem.

  • 47. Re: Airport express drops off network
    Aladdinsdad Level 1 Level 1 (0 points)

    After reading through this great set of posts I fixed my own problem - now working for several days. I changed the channel on my router, and it was either that or the simple fact that I reset my router afterwards which did the trick. Suggest people try resetting their router/modem first.

  • 48. Re: Airport express drops off network
    bjja Level 1 Level 1 (10 points)

    Just dropping in to share my experience with my 2nd generation airport express. So, starting with the network setup where problems occured:

     

    The internet connection is dsl via vodaphone using the EasyBox 803, which is an all-in-one box with dsl modem and wireless router. Since i already had a router and wifi the airport should just connect to the existing network to allow music playback. However, no matter if i connected it wireless, or through ethernet to the EasyBox, no matter WPA/WPA2 settings, no matter b/g/n settings, the airplay droped out constantly, even if it reponded to pings.

     

    The problems occured with my Macbook Pro, my gf's Macbook Pro Retina and our iPhones. (4s and 5) The phones rarely detected the airplay option, and using the computers it usually dropped after a couple of minutes, requiring a restart of the airport.

     

    Tested different firmwares as well, without effect.

     

    The solution for me ended up being ditching the wifi in the easybox, replacing it with the wifi from the airport. So, now the airplay is connected via ethernet to the EasyBox in bridge-mode. The wireless part of the EasyBox is completely turned of, since the airport now is used as a wireless access-point.

     

    Result for me: Works flawless with the computers and phones mentioned, using the 7.6.4 firmware. As a bonus, I now also have a 5 GHz wifi as well, which was not available in the EasyBox.

  • 49. Re: Airport express drops off network
    Dudley Curtis1 Level 1 Level 1 (5 points)

    I have managed to solve a similar problem to others on this thread.  Thought I would share what worked for me, as the various responses helped me get the solution.

     

    Briefly.  I have a cable wireless router as my main wireless gateway.  It supports Wifi 11b/g/n.  I wanted to add a 2004 airport express (v6.3) to the existing network simply to use the audio out to an old JBL iPod dock (AirPlay).

     

    As others reported, the AirPlay option would appear and disappear at random, and drop out often even when it was connected.  Very annoying, and basically useless.

     

    The setup that now seems to work is setting the router to WPA-PSK [TKIP] + WPA2-PSK [AES] security.  144Mbps option.  Channel-auto.  The AirPort Express needs to have the security setting as WPA2 Personal. 

     

    Key point here for me, the AirPort Express has two options which sounds similar: WPA/WPA2 Personal  and WPA2 Personal.  It needs to be the latter, WPA2 Personal.  Making this simple change, then resetting the modem and the AirPort seems to have fixed the problem.

     

    No need to connect the AirPort Express via a cable in my particular case, and as others have reported.  Rather defeats the object - and wouldn't have been a solution for me because of router location.

     

    Incidentally, a related problem was installing the AirPort Utility 5.6.1 on my ageing MacBook with Lion.  The software refused to install, as others trying to install on Mavericks have found.  There is a fix available online involving downloading a special launcher file which adds support to a missing library file that is needed by the old AirPort Utility.  That worked for me on Lion, and enabled me to run the utility.  Without it, my AirPort would be junk.  As it is, I'm chuffed to still be able to make use of this 10 year old box to stream spotify from my iPhone to an old dock!  I won't link to it, because others have reported Apple deleting references to that solution. 

  • 50. Re: Airport express drops off network
    stualden Level 1 Level 1 (0 points)

    I just wanted to add that making sure all Air Port Express boxes were set to WPA2 Personal, and the routers/access points are also set the same (there it might be called WPA2-PSK [AES]) solved my problem too, although I'm not totally sure why.  Thanks to all the previous posters who took the time to research this!

     

    My issue was that the list of AirPlay devices on the iPhone would randomly change - devices would come and go, whether they were currently being used or not.  This included wireless AEX, wired AEX, and PCs running Shairport4w.  Getting the wireless settings all consistent at WPA2 Personal solved the issue.  I'm not sure why this would have anything to do with the wired devices, but it did.

  • 51. Re: Airport express drops off network
    martley Level 1 Level 1 (0 points)

    Hello all, I just want to say thanks so much for this thread.  I moved hosue got a new router and couldn't get my Airport Express to stay on the network once I'd set it up.  It just kept disconnecting after about five minutes and wouldn't recognise.  The exact same thing as was happening to others on this thread.  I tried for almost seven hours trrying lots of different forum advice to sort it out and was on the verge of buying a new Airport.  Then I found this thread and changed the security to WPA 2 Personal from the other setting and it solved the problem.  Thanks again it's much appreciated I can now stream all my music from my MacBook, iPhone and iPad. 

1 2 3 4 Previous Next