8 Replies Latest reply: Dec 4, 2013 6:46 PM by Fringewood
raffi2 Level 1 Level 1 (0 points)

i have this message a lot every 2 second on the console

 

i am on Mac OS X 10.7.5

 

i repair all include keychains and change owner into this folder still same

 

Mac Pro

Informations matériel :

 

  Nom du modèle:          Mac Pro

  Identifiant du modèle:          MacPro1,1

  Nom du processeur:          Dual-Core Intel Xeon

  Vitesse du processeur:          3 GHz

  Nombre de processeurs:          2

  Nombre total de cœurs:          4

  Cache de niveau 2 (par processeur):          4 Mo

  Mémoire:          8 Go

  Vitesse du bus:          1,33 GHz

  Version de la ROM de démarrage:          MP11.005C.B08

  Version SMC (système):          1.7f10

 

 

 

sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions

 

 

The detail ::

 

-----------------------------------------------------------------

 

 

PluginProcess(522) deny file-read-data /Library/ScriptingAdditions

 

Process:         PluginProcess [522]

Path:            /System/Library/StagedFrameworks/Safari/WebKit2.framework/PluginProcess.app/Con tents/MacOS/PluginProcess

Load Address:    0x108e94000

Identifier:      PluginProcess

Version:         ??? (???)

Code Type:       X86-64 (Native)

Parent Process:  Safari [464]

 

 

Date/Time:       2013-06-21 12:56:35.038 +0200

OS Version:      Mac OS X 10.7.5 (11G63)

Report Version:  7

 

 

Backtrace:

0   libsystem_kernel.dylib                  0x00007fff96072afa __open_nocancel + 10

1   libsystem_c.dylib                       0x00007fff8a89f033 __opendir2$INODE64 + 51

2   CarbonCore                              0x00007fff8c5d8d71 FSMount::getIndexedDirectoryItem(unsigned int, unsigned int, unsigned int, char*, unsigned char*) + 283

3   CarbonCore                              0x00007fff8c58cf9e PBGetCatalogInfoBulkSync + 941

4   CarbonCore                              0x00007fff8c58cbd4 FSGetCatalogInfoBulk + 66

5   OpenScripting                           0x00007fff8ad6a3f4 _ZL13IterateFolderPK5FSRefP6AEDescsbb + 209

6   OpenScripting                           0x00007fff8ad6acc6 _ZL13LoadAdditionsP6AEDesc + 502

7   OpenScripting                           0x00007fff8ad6b3a0 HandleGDUT(AEDesc const*, AEDesc*, void*) + 260

8   AE                                      0x00007fff94039c25 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 200

9   AE                                      0x00007fff94039b03 _ZL25dispatchEventAndSendReplyPK6AEDescPS_ + 38

10  AE                                      0x00007fff940399f7 aeProcessAppleEvent + 250

11  HIToolbox                               0x00007fff91af9b69 AEProcessAppleEvent + 102

12  AppKit                                  0x00007fff94dc49c5 _DPSNextEvent + 1247

13  AppKit                                  0x00007fff94dc407d -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

14  AppKit                                  0x00007fff94dc09b9 -[NSApplication run] + 470

15  WebCore                                 0x000000010a419ff2 WebCore::RunLoop::run() + 82

16  WebKit2                                 0x00000001090b2165 int WebKit::ChildProcessMain<WebKit::PluginProcess, WebKit::PluginProcessMainDelegate>(int, char**) + 615

17  PluginProcess                           0x0000000108e95d75

18  PluginProcess                           0x0000000108e95c1c

 

 

Binary Images:

       0x108e94000 -        0x108e96fff  com.apple.WebKit.PluginProcess (7537 - 7537.43.58) <FF8F1AEC-1F3E-389E-942E-DCF535D684E3> /System/Library/StagedFrameworks/Safari/WebKit2.framework/PluginProcess.app/Con tents/MacOS/PluginProcess

       0x109017000 -        0x109279ff7  com.apple.WebKit2 (7537 - 7537.43.58) <4A980CED-94C0-3C28-8CAA-475823B9C289> /System/Library/StagedFrameworks/Safari/WebKit2.framework/WebKit2

       0x1098b6000 -        0x10a981fff  com.apple.WebCore (7537 - 7537.43.6) <923A7CE1-7A76-37D3-9DB5-5BD61B4DB44B> /System/Library/StagedFrameworks/Safari/WebCore.framework/WebCore

    0x7fff8a844000 -     0x7fff8a921fef  libsystem_c.dylib (763.13.0 - compatibility 1.0.0) <41B43515-2806-3FBC-ACF1-A16F35B7E290> /usr/lib/system/libsystem_c.dylib

    0x7fff8ad58000 -     0x7fff8ad75ff7  com.apple.openscripting (1.3.3 - ???) <F5E34F54-CE85-334B-8F25-53581D43960C> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting .framework/Versions/A/OpenScripting

    0x7fff8c56f000 -     0x7fff8c88bfff  com.apple.CoreServices.CarbonCore (960.25 - 960.25) <4FC1AB30-022C-3C67-AC46-FDCBFCB7EEDE> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonC ore.framework/Versions/A/CarbonCore

    0x7fff91ae9000 -     0x7fff91e15fff  com.apple.HIToolbox (1.9 - ???) <CCB32DEA-D0CA-35D1-8019-E599C8007AB6> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.fra mework/Versions/A/HIToolbox

    0x7fff94036000 -     0x7fff94075fff  com.apple.AE (527.7 - 527.7) <B82F7ABC-AC8B-3507-B029-969DD5CA813D> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.fram ework/Versions/A/AE

    0x7fff94dbc000 -     0x7fff959c2fff  com.apple.AppKit (6.7.5 - 1138.51) <44417D02-6123-3FC3-A119-CE51BB4C3006> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit

    0x7fff9605c000 -     0x7fff9607cfff  libsystem_kernel.dylib (1699.32.7 - compatibility 1.0.0) <66C9F9BD-C7B3-30D4-B1A0-03C8A6392351> /usr/lib/system/libsystem_kernel.dylib

 

 

------------------------------------------------------------------


Mac Pro, Mac OS X (10.7.5), 2 x 3 GHz Dual-Core Intel Xeon - 8G
  • 1. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    Fringewood Level 1 Level 1 (5 points)

    I have narrowed this down to the Flash Player plug.  It seems to be most common on YouTube, causing pauses in the video every few seconds because of high CPU use by sandboxd.  IP logs show Google addresses attempting connection at the same time this is happening.

     

    How to cure it?  Not sure.  I have tried blocking access to the IPs, but they just use other IPs.

  • 2. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    leichter Level 1 Level 1 (0 points)

    I was seeing the same problem (MacOS 10.7.5, Flash 11,9,900,152 - though I think I've been hitting it for a while. I have what appears to be a fix, though I'll warn you that it requires hand editing of a configuration file that I believe you're officially not supposed to touch.  If you follow the instructions as I give them, I think the worst you can do is break Safari - and likely just Flash in Safari, and you'll be able to recover quickly by just putting back a saved file.  But ... this is not a very "Mac friendly" procedure.

     

    The details:  The configuration file that controls what the Flash player is allowed to access from the sandbox is:

     

    /System/Library/StagedFrameworks/Safari/WebKit2.framework/Versions/A/Resources/P lugInSandboxProfiles/com.macromedia.Flash Player.plugin.sb

     

    You need to edit this as a simple text file.  I used Emacs.  You can probably use Textedit, but make sure the result is just a simple text file, not, for example, a Rich Text file.  Make sure to create a backup of the original file first.  The steps I followed - in a terminal window, cd'ed into the PluginSandboxProfiles directory - were:

     

    1.  sudo cp com.macromedia.Flash Player.plugin.sb com.macromedia.Flash Player.plugin.sb-save

    (Enter your password when prompted.)

    This makes a safe copy.  You need sudo to have permission to write in the PluginSandboxProfiles directory,

     

    2. cp com.macromedia.Flash Player.plugin.sb ~

    Make a copy in your home directory.  You can edit that copy without having to use an editor under sudo, which is safer.

     

    3. Open the copy of com.macromedia.Flash Player.plugin.sb in your home directory in whatever editor you will be using.  It's a fairly small file.  Search for a line that reads:

     

    (allow file-read*

     

    There's more than one of these, and there are others that start this way but also list other permissions,  One of the ones that has just "file-read*" is followed by a line reading:

     

        (literal "/Library/PreferencePanes/Flash Player.prefPane")

     

    Just before that line, insert the following two lines:

     

        (subpath "/Library/ScriptingAdditions")

        (home-library-literal "/ScriptingAdditions")

     

    4.  Save the file (to your local directory).

     

    5.  Execute:

     

    sudo  cp ~/com.macromedia.Flash Player.plugin.sb .

     

    (You'll need to be in that PluginSandboxProfiles directory again.  Depending on how long it's been since you previously typed your password to sudo, you may have to do it again.)

     

    And ... that should be it.  I found that the sandboxd process would time out and exit, and then restart, reading the modified file.  But just to be sure you can restart Safari.  Performance should now be much better.

     

    Good luck.

                                                            -- Jerry

  • 3. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    Fringewood Level 1 Level 1 (5 points)

    I can handle that.  I've been scripting in BBEdit for over a decade.  Actually, I have a backup system on an external firewire that I refreshed a week ago.  I can grab a copy easily to dupe and edit, and keep my backup handy.  I can do the swap booted from the external.  The Finder gives me comfort..... nothing against Terminal, but I keep its use to a minimum.  Typos can be deadly.

     

    Thanks.  I appreciate it.

  • 4. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    Fringewood Level 1 Level 1 (5 points)

    Didn't work.  It froze up the YouTube page (beachball), and I couldn't initiate any videos.

     

    Logs showed a problem determining pathway for the scripting additions folders.

     

    It worked fine on all other websites and the rest of Google.

     

    I might give it a try with hard pathways and see if that works.

  • 5. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    leichter Level 1 Level 1 (0 points)

    Odd.  It's been working for me - including on YouTube.  Could you post the exact error message you get?

  • 6. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    Fringewood Level 1 Level 1 (5 points)

    I ended up clearing the log and don't have any Console messages from the event.  The YouTube portal page would load partially, about half of the preview images would appear, and then freeze, and the spinning beachball would appear.  I had to force quit Safari.

     

    I ended up switching over to unsafe mode for YouTube and the sites where I often watch YouTube embedded.  I don't feel threatened by YouTube Flash encoding/player.

     

    Now I get many repetitions of the error:  sandboxd: ([2081]) PluginProcess(2081) deny file-read-data /Library/ScriptingAdditions

     

    Same for User/ folder too.  It's one of the reasons I cleared the log, it gets bloated with these when I use unsafe mode.

     

    If I find the time, I'll see if I can recreate the event.  Right now, I'm tied up with a long render time in a 3D studio, doing complex transparent liquids.  It will be tomorrow before it frees up and I feel comfortable going into the system.

  • 7. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    leichter Level 1 Level 1 (0 points)

    I've been playing around with this, and there's more to it than meets the eye.  I have several Mac's, all running the same release and patch configuration of MacOS and Safari and such.  Only one has so far exhibited this behavior.  Clearly something is different in its setup, but I have no idea what.

     

    As you've found, these log messages are associated with severe delays and really bad performance.  If everyone were seeing them, there would be a ton of complaints (and Apple would have fixed it by now).  But it seems only an unlucky few of us get hit by this.  It would be nice to track down and eliminate the root cause, but at the moment I have no idea what to look at.

     

                                                            -- Jerry

  • 8. Re: sandboxd: ([522]) PluginProcess(522) deny file-read-data /Library/ScriptingAdditions
    Fringewood Level 1 Level 1 (5 points)

    Here is the link to the thread that I posted initially, showing the Console message.

     

    https://discussions.apple.com/thread/5581123

     

    It's not YouTube, as I have found a number of other Flash video player sites that exhibit the same problem.  I noted it has the same problem with JWplayer, which is a lot easier to analyse.  I can tell it has to do with Flash Player plug, Safari 6.1, and the safe/unsafe protocol that Adobe placed in Flash.  I'm able to remove the pauses by using unsafe mode.  If I doubt the intent of the website, I use Firefox to watch the stream.

     

    My gut feeling is that Adobe created the safe browsing system to cover Flash's vulnerabilities and didn't spend a whole lot of time on older copies of Safari.  So I would look at Safari and see where it raises flags that kick in sandboxd.  I'm not sure if I can get a debugging version of Safari in AD, but I'll check.