Skip navigation

Can connect airport over ethernet but not wifi?

6253 Views 13 Replies Latest reply: Dec 1, 2013 8:24 AM by Bob Timmons RSS
Shags22 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 7, 2013 4:46 PM

Hi - first post...thanks for your help!  Also, not very technically minded, so the simpler the advice the better!

 

I've had real trouble adding my airport to my existing wireless network (so I can stream music to speakers).  I've previously had the airport set-up as its own network and it's worked fine for a couple of years.  I'd been using it to send music from itunes only to the speakers, but I now want to be able to stream music from the internet (e.g. spotify) and/or itunes to the speakers - hence trying to connect the airport to my existing wifi network.

 

I've followed all the advice to remove the previous settings (i.e. own network) and then establish a new connection to my wifi network, but the only way I've been able to get this to work is if I have the airport connected via ethernet cable to my wireless router.  When I do this, I get the much loved green light, and can see the connection in airport utility - beautiful.

 

But, when I unplug from power and ethernet cable and move it where my speakers are (about 15m away - same place when airport set-up as own network), all I get is the much hated amber flashing light and can no longer see it in airport utility?

 

Any advice?

 

Cheers.

Airport Express
  • John Galt Level 7 Level 7 (33,235 points)
    Currently Being Moderated
    Sep 7, 2013 9:09 PM (in response to Shags22)

    Shags22 wrote:

     

    But, when I unplug from power and ethernet cable and move it where my speakers are (about 15m away - same place when airport set-up as own network), all I get is the much hated amber flashing light and can no longer see it in airport utility?

     

    The reason is that you reconfigured the Express to connect to your router using its Ethernet port. When you unplugged the Ethernet cable, that connection was no longer available, leaving the Express all alone with its plaintive flashing light.

     

    Your previous configuration had the Express creating its own little network, perfectly capable of streaming music from your Mac, but with no connection to the world beyond its own. If you want to use an Internet service like Spotify, connecting it to your router is exactly what you need to do.

     

    You can do that with the Ethernet cable or wirelessly. Since you want to use it wirelessly, disconnect the Ethernet cable, "hard reset" the Express again (see below) so that it will create an open network for AirPort Utility to use for the purposes of configuring it, and then reconfigure it with AirPort Utility. It will examine your wireless network and offer to "join" it as a client. It will then be available for streaming music.

     

    The following Apple Support article explains the above steps in detail: AirPort Express: How to join an existing Wi-Fi network in client mode

     


    To "hard reset" an AirPort Base Station: make sure it's powered up, then press and hold its tiny reset button and keep it depressed for five to ten seconds, long enough for its LED to flash amber rapidly. Release the reset button. Then, the LED will glow amber steadily for about a minute. Then, it will flash amber, slowly, about once every second or two, waiting for you to configure it with AirPort Utility.

    MacBooks  iMacs  iPads  AirPorts, OS X Mountain Lion,  28 years Apple!
  • John Galt Level 7 Level 7 (33,235 points)
    Currently Being Moderated
    Sep 7, 2013 11:43 PM (in response to Shags22)

    An unexpected error has occured.png

     

    I agree the message "an unexpected error occurred" is decidedly unhelpful, but it happens whenever AirPort Utility loses communication with the Express for reasons it cannot determine.

     

    The problem with configuring it with the Ethernet cable attached is that it will result in the Express requiring that cable for its Internet connection. Disconnect the cable, "hard reset" it again, and configure it to join your network wirelessly. That is the only way to accomplish what you seek. Sometimes repeating the "hard reset" is necessary in the event you overlooked a setting or two.

     

    Make sure the Express has no excuse not to connect to your existing wireless network. Put it in the same room as your wireless router, at least. After it has been configured to join your existing wireless network, the Express should reward you with a solid green light which should reappear even after you relocate it to its permanent location.

     

    It may no longer appear in AirPort Utility though; since I no longer have any non-Apple routers I cannot be certain what the AirPort Utility picture will look like after it has been configured to join a different manufacturer's wireless.

     

    It may also help to temporarily disable any wireless encryption on your existing router to eliminate that as a source of uncertainty.

    MacBooks  iMacs  iPads  AirPorts, OS X Mountain Lion,  28 years Apple!
  • John Galt Level 7 Level 7 (33,235 points)
    Currently Being Moderated
    Sep 8, 2013 7:36 AM (in response to Shags22)

    If it's not an Apple AirPort Base Station, consult its documentation or support website.

     

    If it is:

     

    Screen Shot 2013-09-08 at 10.32.34 AM.png

  • John Galt Level 7 Level 7 (33,235 points)
    Currently Being Moderated
    Sep 8, 2013 11:15 AM (in response to Shags22)

    In addition to the above, refer to this Apple Support article:

     

    AirPort base station not seen or "An unexpected error occurred" appears in AirPort Utility 6.3

  • dhughes411 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2013 7:21 AM (in response to Shags22)

    John

     

    I am having a very similar issue and have been at it for about 6 hrs.  Set is as follows:  TWC Arris cable modem (wifi disabled), ethernet connected to an Airport Extreme.  I had and wish to reconnect two Airport Express units to boost the signal in other regions. 

     

    I followed all of your instructions (and tried every other trick in the help rooms).   Here is what I last did...Hard reset on one of the Express units.  Open Airport Utility and I see the 'reset' Airport Express 83a172 click on it and I get the dreaded error below...I am using the current Airport Express Utility 6.3.1. 

     

    Any other ideas would be welcome. 

     

    Darrell

     

     

     

  • dhughes411 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2013 7:31 AM (in response to dhughes411)

    John

     

    I also tried the additional recommend actions on IPv6.  These too did not work for me.

     

    Darrell

     

     

    AirPort base station not seen or "An unexpected error occurred" appears in AirPort Utility 6.3

    Symptoms

    • An AirPort base station that appeared in previous versions of AirPort Utility might not appear in AirPort Utility 6.3 for OS X.
    • The AirPort base station is detected, but this alert may appear during setup: "An unexpected error occurred. Try again."

     

    Resolution

    Steps for OS X Lion or Mountain Lion
    This can happen if IPv6 has been disabled. To enable IPv6 for your network interface:
    1. Choose Apple menu () > System Preferences, and then click Network.
    2. If a lock icon appears in the lower-left corner, click it and enter your admin name and password to unlock the pane.
    3. Click your network service (Wi-Fi or Ethernet) in the list, and then click Advanced.
    4. Click the TCP/IP tab.
    5. Choose Link-local only from the Configure IPv6 pop-up menu.
    6. Click OK.
    7. Click Apply.

    The AirPort device should now appear in AirPort Utility.

     

     

    Additional Information

    For AirPort Utility for iOS steps, please see this article.

     

  • Bob Timmons Level 9 Level 9 (75,875 points)
    Currently Being Moderated
    Dec 1, 2013 7:39 AM (in response to dhughes411)
    Set is as follows:  TWC Arris cable modem (wifi disabled), ethernet connected to an Airport Extreme

     

    So, the AirPort Extreme is operating normally, is that correct?

     

     

    I had and wish to reconnect two Airport Express units to boost the signal in other regions.

     

    Can you clarify whether you want the Express devices to connect to the AirPort Extreme wirelessly....or....will they connect to the AirPort Extreme using a permanent wired Ethernet connection?

  • dhughes411 Level 1 Level 1 (0 points)

    Yes.  The Extreme is working fine as far as I can tell.  It is broadcasting a Wifi signal and connecting to it works fine on my Iphone and Ipad.  I wish to connect the Express ( there are 2 but 1 at a time) to the AirPort Extreme wirelessly.     I am able to connect them using an Ethernet connection but as John indicated that only works via Ethernet and I need them to be wireless.  In otherwords, setting them up via the Ethernet does not set them up for wireless use.

     

    I am using Mac OS X 10.7.5. on a mid 2011 27" iMac.

     

    Darrell

  • Bob Timmons Level 9 Level 9 (75,875 points)
    Currently Being Moderated
    Dec 1, 2013 8:04 AM (in response to dhughes411)

    Thanks for the clarification.  I cannot duplicate the "unexpected error" that you are are reporting when I try this, so don't have a fix for that.

     

    Go ahead and perform a hard reset on an AirPort Express again and give it full minute to start up again to a slow, blinkng amber light.

     

    Temporarily, connect a spare Ethernet cable from your Mac.....not from the AirPort Extreme....... to the WAN "O" port on the AirPort Express and try the setup that way.

     

    If you can complete the setup that way, once you have a green light on the Express, you can disconnect the Ethernet cable from the Mac and Express and move the Express to a location that is about half way between the AirPort Extreme and the general area that needs more wireless signal coverage.

     

    Start up the Express and you should be all set in about a minute.

  • dhughes411 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2013 8:17 AM (in response to Shags22)

    well here's another clue for you all..."the walrus is Paul".  Seriously, I cannot explain this wierd world of Apple but I was able to configure the Airport Expresses (without the error) using my Ipad running IOS 7.0.4.  No luck on the Mac but the Ipad configured like a charm. 

  • Bob Timmons Level 9 Level 9 (75,875 points)
    Currently Being Moderated
    Dec 1, 2013 8:24 AM (in response to dhughes411)

    This tells me that the issue is likely with your Mac, or more correctly, the AirPort Utility application on your Mac.

     

    You might try downloading and installing the application again. If that does not help, then I am stumped.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.