Skip navigation

iPhoto locked with OSX Mavericks update

18407 Views 24 Replies Latest reply: Mar 7, 2014 8:55 PM by Babycatgrandma RSS
  • saholz Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 7, 2013 8:27 AM (in response to creativestreak)

    Mine worked fine after updating to Mavericks.  Then the other day, I was working with iPhoto in Mail, clicked on a library selection, and got the error message.  I tried moving the lock.data file, tried restarting the computer, but nothing worked.  I tried repairing it several times, with no effect at all.  I then used Finder to search for photos, and opened an image from there.  Once into iPhoto, I then moved back to all albums, looked at several albums and events, and closed the program completely.  It's worked fine since and now opens from the dock again.

     

    I did also notice I had several iPhoto libraries listed with numerical suffixes, but I have no idea if that's normal or not.

     

    It looked like the direct link somehow lost its direction and pointed to an invalid location.

  • ScienceDiva Calculating status...
    Currently Being Moderated
    Nov 18, 2013 1:24 PM (in response to saholz)

    I had to update iPhoto (free) and it opened fine after that.

  • Holzmana Calculating status...
    Currently Being Moderated
    Nov 29, 2013 9:53 AM (in response to bilsw)

    Thanks Bilsw! Moving the file out of library and into pictures folder worked.

    MBP, Mac OS X (10.6.5)
  • trvr Calculating status...
    Currently Being Moderated
    Nov 29, 2013 3:00 PM (in response to bilsw)

    This worked for me after trying everything else!

  • NYMOM222 Calculating status...
    Currently Being Moderated
    Dec 2, 2013 11:05 AM (in response to creativestreak)

    I was able to upgrade to the newest version of iphoto in the app store for no fee. I guess wether you get charged depends on what version you originally have? I have an old macbook pro, but I did pay for an upgrade once. It solved my lockout problem.

  • ttruelove Calculating status...
    Currently Being Moderated
    Dec 7, 2013 8:02 PM (in response to creativestreak)

    I too upgraded to the latest version of iPhoto (App Store) and it worked fine afterwards. I also had to update GarageBand.

  • Joyce Dever Calculating status...
    Currently Being Moderated
    Dec 12, 2013 7:25 PM (in response to CMTailor)

    Where did you get into users

  • mattdenton Calculating status...
    Currently Being Moderated
    Jan 19, 2014 2:29 PM (in response to bilsw)

    I solved this similarly by making an alias for the original ~/Library/Pictures/iPhoto Library in ~/Pictures/ and letting it rebuild. Removing the lock file didn't work for me.

  • ArtOverMatter Calculating status...
    Currently Being Moderated
    Feb 16, 2014 11:30 PM (in response to creativestreak)

    I had the same problem.  I went onto the live chat and asked them about it, and they gave me a redeemable code for iphotos.  I pretty much just redownloaded iphotos; everything was fine.  All of my old pictures were still there.

  • Babycatgrandma Calculating status...
    Currently Being Moderated
    Mar 7, 2014 8:55 PM (in response to ArtOverMatter)

    I cannot access my photos since updating to Maverick OSX.  Unlocking failed as well. No surprise there. I did find that I have two libraries, one is a default that does not contain all of my photos, the other is the one I'm locked out of.   I'm not sure how to create the new files that Matt was able to do. It seems that apple wants to charge me to find a solution to their faulty upgrade and I think that this is wrong.  That was in the live chat where I may have to go to get my code.  It seems that there have been various solutions for everyone after reviewing these posts.  I am not too saavy at this but I will give it my best at my age.  Hopefully when my daughter visits tomorrow she can resurrect the file.  Shame on you apple.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.