Skip navigation

Upgraded 2 macs to Mavericks, can no longer access shared folders/files.

5241 Views 20 Replies Latest reply: Mar 12, 2014 5:27 AM by stellarbill RSS
  • Joseph Heinen Calculating status...

    JK et al. -

    I can offer one solution after this discovery :

    I upgraded both my iMac and MacBook Air (MBA) to Mavericks and then experienced similar problem -- the shared file access and shared printer capabilities disappeared.  I spent hours trying changes to sharing preferences, AFP protocol, pinging network addresses, restarting, etc.  Discovered that it was a problem with my iMac name.  The iMac name had an apostrophe (Joe's iMac).  Somehow, after changing to Mavericks, the machine could not be discovered.  Changed the iMac name (Joe iMac) and now the MBA shows it in Finder and the shared folders and printer have returned. 

    Good luck.

  • mazg4182 Calculating status...

    Hi Joseph,

    You have solved my problem. I've been having the exact same problem with an iMac and MBA for the past month. Removing the apostrophe worked for me too.



  • Tracy McCarthy Calculating status...

    I am tearing out my hair due to lost productivity with this issue. Oddly, of the four Macs in my workgroup, three use an apostrophe in the computer name (and CAN share) while the fourth does not use an apostrophe and is not acccessible through conventional means.


    Before the upgrade to Mavericks, we had no problems accessing each other as registered users. Now, my MacPro (mid-2010, on 10.9) can connect to iMac-1 (mid-2011, on 10.9), and iMac-2 (mid-2011, on 10.6.8), but it cannot connect to iMac-3 (mid-2011, on 10.9), nor can iMac-3 connect to my MacPro.


    If I use 'Go to Server' and connect manually to iMac-3 by IP, it shows up in my Finder as 'imac-32-ac60', not 'Crystals Computer', and likewise when iMac-3 tries to manually connect, my computer shows up in her Finder as 'macpro-aa2-faf'.


    And this connection doesn't persist. I haven't noticed exactly when the connection is lost, but it doesn't stick around for very long.


    I'm fuzzy on terminology but we four are the mac-group in an office of PCs using Windows server 2003. We've always accesseed a folder on the server called Shared Files where we put docs for the office to use. Right now, iMacs-1 and -2, and my MacPro can all accesses files in Shared. Imac-3 can go to the folder but when she tries to open a file it says 'The application can't be found.'


    I have deselected the 'share using SMB' in the Options of the Sharing pane (as did iMac-3) but I notice that in the main Sharing window it says 'Other users can access shared folders on this computer, and administrators all volumes, at afp://... or smb://...'


    I would think deselecting 'share using SMB' in Options would remove that access.


    At any rate, I would deeply appreciate any ideas about how to troubleshoot this.

  • dharward Calculating status...

    For me the issue was that after upgrading to Mavericks there was not any share name at all on my MBP but there was one on my Mac Mini so my MBP was not able to access the files on the Mini. I just had to open the shareing settings under system preferences and set the share name.

  • Kosmodzik Calculating status...

    Hi everyone,

    I tried pretty much everything you mentioned throughout this discussion and becasue nothing worked, I figrued I'd give it a try to just add a new user in the sharing screen. Seems to have resolved all the problems. Try it yourself.



  • stellarbill Calculating status...

    Everyone may have figured this out but I was having the same issue with two Mac Minis inside the office, 7 others were fine after the upgrade. I did figure out that just changing your computer name seems to fix the issue, at least it did for the two problematic machines here. Removing the apostrophe should work because it ultimately changes the name. Goto System Preferences -> Sharing -> Change Computer Name. Hope this helps someone! :-)

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.