Skip navigation

USB 3.0 Hub that works with 15'' Retina MBP (OS X Mountain Lion)

20767 Views 123 Replies Latest reply: Mar 25, 2014 5:12 PM by AWMarine RSS Branched to a new discussion.
  • tryn2edu Calculating status...

    AWMarine, THANK YOU! You've probably already forgotten what i still need to learn about micro computing and i am brand new to Apple.

    I bouugh a DLink DUB1340 maybe Sept 2012 and became frustrated with it.  It's some where in a box in the junk room. I still believed that I could put my 2 USB 3.0 GDrive Slims 500 GB/GO drives, WD 3.0 USB 3.0 desktop drive and Apple USB Superdrive under my glass table and have one neat USB 3.0 extension into a working USB 3.0 hub and live happily ever after.

    Today I decided to revive transforming the nightmare into a dream and voila: I was not alone.  DSANC89 had a similar scenario.  Then AWMARINE dove in and did not stop until an apparent resolution was on the horizon.  I AM SO GRATEFUL. 

    I just ordered a Uspeed 7 port USB 3.0 hub and a 6' USB 3.0 extension and I hope to report my experience to you. 

    Again thanks to all who have worked towards a solution.

    PS: Interestingly I downloaded the SMC update to yield 2.3f35 SMC but it says that it did not pertain to my, i forgot exact message so I will say, environment.

  • lambchops99 Calculating status...

    Hi All,


    I have been using this USB 3 hub with my MBP retina 15" with no problems.


    Was data manager on a film using this setup to transfer hundred of GBs a day to 3 drives simultaneously (2 x Lacie desktop USB3 and 1 x Western digital Essential USB 3)


    Had no problems.


  • AWMarine Level 1 Level 1 (5 points)

    I was tempted to try lambchops99 hub until learning that I'd have to use it "down under". The Aussie connectors would be a problem in the US.


    My Uspeed 7-Port USB 3.0 powered hub is still limping by. After upgrading the hub firmware for the Mac (that has to be installed in a Windows PC )  the problems have been reduced substantially. There's still a problem a couple times a week with one, or all, drives spontaneously dismounting.


    Obviously if this were to happen during a data transfer the results wouldn't be good. Before the firmware upgrade my iTunes library was totally wiped out, and a backup drive was corrupted and unusable until repartioned and formatted. The drives dismounted during a transfer.


    An email was sent to Anker (formerly LaptopMate) updating them on my error log. I'm living too close to the edge, but the Uspeed hub is the best of about 15 hubs I've tried. I still believe it to be an Apple problem as the hubs work fine on a friend's PCs and laptop.


    Being considered is the new Belkin Thunderbolt Express Dock that supposedly became available on Wednesday for $300 (plus another $30 to $50 US for the cable). Trying to find a place that has the Dock is a challenge at this early date. It's hoped that going through the Thunderbolt bus, and avoiding the Apple USB 3.0 bus, the Dock's USB 3.0 ports would be absent the USB 3.0 problems of the two MacBook Pro Retina's I've had in the last year. 


    Message was edited by: AWMarine to indicate the cost of the Dock and cable.

    MacBook Pro with Retina display, OS X Mountain Lion (10.8), OS is current. Hubs are powered.
  • tryn2edu Level 1 Level 1 (0 points)

    Dear AWMarine,

    Thank you for your support.  I did acquire this Uspeed 3.0 7-port hub on April 11, 2013 (noted this data also Oct 2012 upgraded verion - via VL812 Chipset and 36W power adapter).  So far i have no complaint 23 days later.  All my external drives are present every time unlike with the DLink DUB-1340.  I MUST SAY HOWEVER that this Uspeed hub will not register the external CD/DVD Apple Superdrive - I seemed to recall that the hub was unable to deliver enough power. hey at least it did not leave me in mystery land.  Upfront it said "i cannot handle that drive."


    Not related to the usb resolution above BUT i am new and you helped so i will share this in case it helps someone.  I observed one other weird tidbit.  For a couple days when I started or restarted the MacBook Pro 15.4" with Retina Display, I would get the gray scren with Apple logo as normal.  HOWEVER it would just sit there and not deliver login page so I could not login.  Finally the display would time out and i would jiggle the mouse and then the login screen would appear and I could function.  So i did some research and i went to TERMINAL and executed a string which I found in "Macbook Pro with Retina display: Problems in every dimension".  I had gotten fearful that I had a real display of software or other hardware issue.  Wwll I do NOT have an LG display.  This display is SAMSUNG.  So that was a bit of relief but the problem persisted.  Then one day when I logging my observations in preparation to call Apple, i noticed that my mouse battery was low.  So I changed it.  THE LOGIN PROBLEM HAS NOT SINCE OCCURRED.

  • Michael Evans3 Level 1 Level 1 (45 points)

    I bought one of the first Belkin Express Thunderbolt Docks and had constant USB 3 drive disconnects when attached to either my mid-2012 MacBook Air or my 2013 MacBook Pro R. I am in the process of sending the device back as not fit for purpose. However, I did buy a Belkin four-port USB hub and this has been working perfectly for three weeks with three external disks attached. Unlike the Belkin Thunderbolt Dock, the hub is connected to the MBPr's USB 3 port. Could it be that there is some problem with Apple's implementation of Thunderbolt to USB, I wonder.


    I tend to agree with other contributors that the problem lies with the computer(s) and not with the hub manufacturers, although I am now surprised that my USB 3 hub is performing as well as it is.

  • BlueFrog69 Level 1 Level 1 (0 points)

    Has anybody tried the Inateck USB 3.0 4-Port Bus-Powered Hub or the Ugliest 5-Star Hub on Amazon?

    I'd be prepared to go USB 2.0 if it meant stability.

  • HughGriffiths Level 1 Level 1 (0 points)

    Interestingly that Anker Uspeed link on Amazon says thatthe hub specifically does NOT work on Macs ... what's the truth guys?


  • pBK1 Calculating status...

    Additional information: New 2013 iMAC. Brand new Anker 9 port USB 3.0 Hub. Two Seagate 4.0 TB 3.0 HD's.


    HD's will connect correctly (most of the time**) when connected directly to the computer. When either one or two HD's are connected through the Hub, they will mount and then discmount within 1 or 2 minutes.


    When the HD's are connected through a Belkin USB 2.0 Hib, they connect fine and stay connect--of course they run at 2.0 speeds.


    **NOTE I have noticed kernel panics when starting this computer with 3.O HD's connected, and if the HD's go to "sleep" via the energy saver option, I will get a "failed to eject properly" message. So even when connected directly to the computer, there are problems, confirming the fact that Apple does have driver or other software issues. Listen up Apple!!

  • Doug Lerner2 Level 4 Level 4 (1,030 points)

    dsanc89 wrote:


    After a long quest of information gathering in the past couple of months, I'm going to finally close this thread and answer the question posed by the title.


    By a majority reaction, it seems the Anker Uspeed USB 3.0 7-Port Hub is the clear winner and answer to the question of a compatible and very stable USB 3.0 hub for the 15'' Retina MacBook Pro. For those of you curious, just read through this whole thread to see the gathered feedback and results by others (especially AWMarine -- special thanks to him).


    Here's a link to the hub on Amazon for your purchasing needs:®-Uspeed-7-Port-Charge-Only-Ports/dp/B00B7GAE98


    Enjoy It Everyone and Case Closed!


    Well the Anker USB 3.0 9-port hub definitely is unstable. I just sent mine back to Amazon. It could not keep my WD My Passport Ultra 1 TB USB 3 drive consistently mounted. I would get multiple eject errors a day. This is with just the WD and my printer connected to the hub!


    Directly connected to the same USB port on my MacBook Pro retina 13" the WD runs flawlessly.


    I came here looking for a reliable hub and am still looking. But I don't believe Anker is the solution. I gave it a 1-star rating on Amazon.



  • AWMarine Level 1 Level 1 (5 points)

    I'm currently on my 20th USB 3.0 hub and I think I've found a solution to the spontaneous and unprovoked dismounts, hubs mounting as USB 2.0 or USB 1.1, and the other unstable conditions that Apple presented us with.


    I've been fighting this Apple/ USB 3.0 boondogle since June 2012. I say boondogle because hubs that were totally unusable with my MacBook Pro Retina were loaned to a friend with PCs. He still has one of the early ones and describes it as operating "like a dream". I've received a warranty exchange from Apple for my MacBook Pro Retina. That wasn't the answer.Same problems. I brought a USB 3.0 hub with 3 drives to an Apple Store and tested them with a late 2012 MacBook Pro Retina and an iMac 27". The drives failed to mount on both at times. From my experience working with Apple and vendors on this matter, the hubs worked on PCs, but not on Macs.


    Last summer I I took a chance and bought a Plugable 7-Port USB 3.0 powered hub from Amazon. It also had the “problems" and was returned. Plugable followed up with another at no charge. It was unsatisfactory so they sent another last September at no charge, with the understanding that I'd use the hub and give the pros and cons as I saw and experienced them. That was agreeable to Plugable.


    The new hub had the VIA VL812 chipset that had the current firmware installed. That appears to be the answer. The hub with new firmware has been operating on my MacBook Pro on and off for a couple of months in total. I've not had an error that could be attributed to the hub. What I have found was poor connections at the drives with the Micro-B connectors. The cables were replaced and all has been good since. I often have 4 to 7 portable and desktop drives connected.


    The key words, from what I can determine, are: USB 3.0 Hub (VIA VL812 Chipset with Latest 908x Firmware)

    Currently I’m using the Plugable USB3-HUB7A, the “A” is for brushed aluminum, and it' has 7-Ports. It looks Apple-like. In comparison with other hubs that I currently own, or have used, there are several things that I find notable:


    • It uses the chipset and firmware referred to above, and it works.


    • It uses a Type-B connector that is larger and makes positive contact. Some use the Micro-B connector which I’d found to be unreliable and now avoid after a bad history, and a box full of cables with intermittent connectors. A solid connection on the cable going to a Mac is critical.


    • It has a power switch so power can be turned off when not in use.


    • This model won’t charge an iOS device. Both Plugable and Anker have models with an extra port that only provides power for charging. It’s not connected to sync or transfer data.


    • The USB plugs fully engage to the “hilt” of the plug. Some models don’t fully enter the receptacle leaving excess room for lateral movement and the possibility of a broken connection. I like the solid feel.


    • It has non-slip material on the base to reduce movement on the surface it’s used on.


    • The brushed aluminum looks nice.


    • Read the descriptions on Amazon for more if interested.


    In the interest of fairness, Anker (previously LaptopMate & Uspeed) provided several hubs for testing early on that were found to be unstable, but better than the others I'd found at that time. Thus my qualified comment about them on this board. In a later email Sunnie mentioned an Anker hub they had with the VL812 chipset and updated firmware. Which firmware remains an unanswered question. They didn't provide a hub for testing, but their hub could be using the same chipset and firmware, However, I don't know that. (I do know that the 7-Port black Anker hub appears to be identical to a Plugable hub.) Sunnie has been evasive on recent questions about firmware, and reliability with a Mac, so I really can’t recommend them at this point.


    If you're looking for more information on Firmware, and some assurance that an answer may have been found to this puzzle, check out the below link to the full article on the Plugable site.The paragraph below is an excerpt to whet your appetite.


    I’d give other references if I was aware of them. Plugable has posted some good articles on their site/ blog, and they have been very open with details. So much so that I’ve referred other vendors to their site for information. The excerpt below is the first paragraph of their article. It goes on from there. It’s recommended reading if you’re reading this. Hopefully it will provide some useful information to others fighting this battle to get USB 3.0 hubs to work on 2012 Macs. It’s been time-consuming and expensive, but this might be the light we’ve been seeking.


    Plugable USB 3.0 7 Port Hub Firmware History

    Customers purchasing Plugable hubs after 9/2013 should not need to worry about firmware updates. Firmware versions on hubs shipping after September 2013 on all Plugable hubs have no known issues with Linux, Mac, and Windows hosts.



    MacBook Pro with Retina display, OS X Mountain Lion (10.8), OS is current. Hubs are powered.
  • Doug Lerner2 Level 4 Level 4 (1,030 points)

    Thanks for the detailed and very helpful post. I shall check out Plugabble. I'm disappointed that the problem is so widespread with these Apple notebooks - even my new MacBook Pro retina 13" late 2013 model that I just got!


    In addition to checking out Pluggable, what do you think of the Belkin hubs which Apple offers from their online stores?


    Thanks very much. I would give you "helpful points" but unfortunately I'm not the original poster.



  • AWMarine Level 1 Level 1 (5 points)

    Hmmm, what part of the world are you in for it to be Jan 30 already? In the US it's 0200 Central on the 29th. Interesting.


    Have you read the review posted this evening at:



    Flawless and perfection regarding USB 3.0 and Macs are conflicting terms. The best solution I've found is hubs with the VIA VL812 chipset with the 90.81 firmware version. through Amazon sells them and has a good article at:





    Plugable USB 3.0 7 Port Hub Firmware History


    Customers purchasing Plugable hubs after 9/2013 should not need to worry about firmware updates. Firmware versions on hubs shipping after September 2013 on all Plugable hubs have no known issues with Linux, Mac, and Windows hosts.


    Other vendors may have similar chipsets and firmware. Be vigilant. Some manufacturers have disavowed any compatibility with Macs, yet vendors sell them. In one case I had to get Amazon involved as their ads were misrepresenting the hubs as Mac compatible.


    From my experience with 20 hubs, I wouldn't touch one that was manufactured before Sept., even Oct. 2013 (How long have they been on the shelf?)


    Good luck,


    MacBook Pro with Retina display, OS X Mountain Lion (10.8), OS is current. Hubs are powered.
1 2 3 4 ... 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.